aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-redis/files
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-06-16 17:10:19 +0800
committerkoobs <koobs@FreeBSD.org>2013-06-16 17:10:19 +0800
commitd0319190f7cdc6a122cc3240a65536d9e5a7c240 (patch)
tree1abe007536c3e3c8de89efba6cff7e4a90b55dbe /databases/py-redis/files
parent287a5bd27cd8c557ab68a0b8a15f022271fc8ef1 (diff)
downloadfreebsd-ports-gnome-d0319190f7cdc6a122cc3240a65536d9e5a7c240.tar.gz
freebsd-ports-gnome-d0319190f7cdc6a122cc3240a65536d9e5a7c240.tar.zst
freebsd-ports-gnome-d0319190f7cdc6a122cc3240a65536d9e5a7c240.zip
databases/py-redis: Update to 2.7.6
- Update to 2.7.6 - Update setup.py patch Changes: * 2.7.6 * Added CONFIG RESETSTAT command. Thanks Yossi Gottlieb. * Fixed a bug introduced in 2.7.3 that caused issues with script objects and pipelines. Thanks Carpentier Pierre-Francois. * Converted redis-py's test suite to use the awesome py.test library. * Fixed a bug introduced in 2.7.5 that prevented a ConnectionError from being raised when the Redis server is LOADING data. * Added a BusyLoadingError exception that's raised when the Redis server is starting up and not accepting commands yet. BusyLoadingError subclasses ConnectionError, which this state previously returned. Thanks Yossi Gottlieb. * 2.7.5 * DEL, HDEL and ZREM commands now return the numbers of keys deleted instead of just True/False. * from_url now supports URIs with a port number. Thanks Aaron Westendorf.
Diffstat (limited to 'databases/py-redis/files')
-rw-r--r--databases/py-redis/files/patch-setup.py22
1 files changed, 5 insertions, 17 deletions
diff --git a/databases/py-redis/files/patch-setup.py b/databases/py-redis/files/patch-setup.py
index 9d21f02976dc..4cb0b62ae6df 100644
--- a/databases/py-redis/files/patch-setup.py
+++ b/databases/py-redis/files/patch-setup.py
@@ -1,22 +1,10 @@
---- ./setup.py.orig 2012-08-10 08:48:07.000000000 +1000
-+++ ./setup.py 2012-08-15 22:27:30.000000000 +1000
-@@ -3,10 +3,7 @@
-
- from redis import __version__
-
--try:
-- from setuptools import setup
--except ImportError:
-- from distutils.core import setup
-+from setuptools import setup
-
- f = open(os.path.join(os.path.dirname(__file__), 'README.md'))
- long_description = f.read()
-@@ -41,5 +38,6 @@
+--- ./setup.py.orig 2013-06-16 18:54:43.668848521 +1000
++++ ./setup.py 2013-06-16 18:54:57.779885292 +1000
+@@ -57,5 +57,6 @@
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
-- ]
-+ ],
+- ]
++ ],
+ zip_safe=False,
)