aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-sqlite3/Makefile
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-02-11 21:18:22 +0800
committerkoobs <koobs@FreeBSD.org>2015-02-11 21:18:22 +0800
commit2772c9aec2bc747ab23a86094c33350a8f2f9573 (patch)
tree5f9ec7803687d7de954163132cbd5ec1d635f2bb /databases/py-sqlite3/Makefile
parentacfa8bd48bf6075039931fe1b38b52a8270d8ba6 (diff)
downloadfreebsd-ports-gnome-2772c9aec2bc747ab23a86094c33350a8f2f9573.tar.gz
freebsd-ports-gnome-2772c9aec2bc747ab23a86094c33350a8f2f9573.tar.zst
freebsd-ports-gnome-2772c9aec2bc747ab23a86094c33350a8f2f9573.zip
databases/py-sqlite3: Strip shared library
- Strip shared extension - Sort DIST* entries - Sort USE_PYTHON values - Add LICENSE_FILE Approved by: python (with hat)
Diffstat (limited to 'databases/py-sqlite3/Makefile')
-rw-r--r--databases/py-sqlite3/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/databases/py-sqlite3/Makefile b/databases/py-sqlite3/Makefile
index 1cffa45eeff6..ca1535c39c5a 100644
--- a/databases/py-sqlite3/Makefile
+++ b/databases/py-sqlite3/Makefile
@@ -3,26 +3,27 @@
PORTNAME= sqlite3
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases python
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Python-${PORTVERSION}
+DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
COMMENT= Standard Python binding to the SQLite3 library
LICENSE= PSFL
+LICENSE_FILE= ${WRKDIR}/Python-${PORTVERSION}/LICENSE
LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
PORTSCOUT= ignore:1
USES= python tar:xz
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
-DIST_SUBDIR= python
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules
@@ -37,4 +38,7 @@ post-extract:
@${CP} ${FILESDIR}/setup3.py ${WRKSRC}/setup.py
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so
+
.include <bsd.port.post.mk>