aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-sqlite3/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:02:26 +0800
commitad9c5e72c063fd2001b42cfbb2fcc63cb86019d7 (patch)
tree9278ac4e2888d0d4639a79120e16d131e6c1a759 /databases/py-sqlite3/Makefile
parentf028d4118bfcd78d5e1bb92d8dc9fb40bd3d0328 (diff)
downloadfreebsd-ports-gnome-ad9c5e72c063fd2001b42cfbb2fcc63cb86019d7.tar.gz
freebsd-ports-gnome-ad9c5e72c063fd2001b42cfbb2fcc63cb86019d7.tar.zst
freebsd-ports-gnome-ad9c5e72c063fd2001b42cfbb2fcc63cb86019d7.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'databases/py-sqlite3/Makefile')
-rw-r--r--databases/py-sqlite3/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/py-sqlite3/Makefile b/databases/py-sqlite3/Makefile
index 23cf3fea9931..20b7a674d007 100644
--- a/databases/py-sqlite3/Makefile
+++ b/databases/py-sqlite3/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3
PORTSCOUT= ignore:1
USES= python tar:xz
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist distutils allflavors
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules