aboutsummaryrefslogtreecommitdiffstats
path: root/databases/qdbm
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-10-30 10:29:21 +0800
committernork <nork@FreeBSD.org>2003-10-30 10:29:21 +0800
commit5699d97a852c610bad17ca1eeb24b1c23a743f51 (patch)
tree7c14b3bd3564bccb59147eab1f2cd76cbc1fd590 /databases/qdbm
parent7983e4f02e60579901ff504bb62ac1febb05e730 (diff)
downloadfreebsd-ports-gnome-5699d97a852c610bad17ca1eeb24b1c23a743f51.tar.gz
freebsd-ports-gnome-5699d97a852c610bad17ca1eeb24b1c23a743f51.tar.zst
freebsd-ports-gnome-5699d97a852c610bad17ca1eeb24b1c23a743f51.zip
Add qdbm 1.7.5, quick Database Manager is a library of
routines for managing a database. The database is a simple data file containing records, each is a pair of a key and a value, organized in hash table or B+ tree.. PR: ports/58186 Submitted by: Kimura Fuyuki <fuyuki@nigredo.org>
Diffstat (limited to 'databases/qdbm')
-rw-r--r--databases/qdbm/Makefile26
-rw-r--r--databases/qdbm/distinfo1
-rw-r--r--databases/qdbm/pkg-descr8
-rw-r--r--databases/qdbm/pkg-plist32
4 files changed, 67 insertions, 0 deletions
diff --git a/databases/qdbm/Makefile b/databases/qdbm/Makefile
new file mode 100644
index 000000000000..74b2dc78f02e
--- /dev/null
+++ b/databases/qdbm/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: QDBM
+# Date created: 18 October 2003
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qdbm
+PORTVERSION= 1.7.5
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= Quick Database Manager
+
+GNU_CONFIGURE= yes
+MAKE_ARGS= RELCFLAGS="${CFLAGS}" \
+ MYSHAREDIR="${DOCSDIR}" \
+ MYDOCS="spex.html spex-ja.html"
+INSTALLS_SHLIB= yes
+
+MAN3= cabin.3 cropen.3 curia.3 depot.3 dpopen.3 hovel.3 \
+ odeum.3 odopen.3 qdbm.3 relic.3 villa.3 vlopen.3
+
+.include <bsd.port.mk>
diff --git a/databases/qdbm/distinfo b/databases/qdbm/distinfo
new file mode 100644
index 000000000000..0fbc3fa28447
--- /dev/null
+++ b/databases/qdbm/distinfo
@@ -0,0 +1 @@
+MD5 (qdbm-1.7.5.tar.gz) = a249fb971b83b396cb12b02ae0ec23e2
diff --git a/databases/qdbm/pkg-descr b/databases/qdbm/pkg-descr
new file mode 100644
index 000000000000..d372016a30cc
--- /dev/null
+++ b/databases/qdbm/pkg-descr
@@ -0,0 +1,8 @@
+QDBM is a library of routines for managing a database. The database
+is a simple data file containing records, each is a pair of a key and
+a value. Every key and value is serial bytes with variable length.
+Both binary data and character string can be used as a key and a
+value. There is neither concept of data tables nor data types.
+Records are organized in hash table or B+ tree.
+
+WWW: http://qdbm.sourceforge.net/
diff --git a/databases/qdbm/pkg-plist b/databases/qdbm/pkg-plist
new file mode 100644
index 000000000000..e2a3bc3a60e0
--- /dev/null
+++ b/databases/qdbm/pkg-plist
@@ -0,0 +1,32 @@
+bin/cbcodec
+bin/cbtest
+bin/crmgr
+bin/crtest
+bin/crtsv
+bin/dpmgr
+bin/dptest
+bin/dptsv
+bin/hvmgr
+bin/hvtest
+bin/odidx
+bin/odmgr
+bin/odtest
+bin/rlmgr
+bin/rltest
+bin/vlmgr
+bin/vltest
+bin/vltsv
+include/cabin.h
+include/curia.h
+include/depot.h
+include/hovel.h
+include/odeum.h
+include/relic.h
+include/villa.h
+lib/libqdbm.a
+lib/libqdbm.so
+lib/libqdbm.so.1
+lib/libqdbm.so.1.0.0
+%%DOCSDIR%%/spex-ja.html
+%%DOCSDIR%%/spex.html
+@dirrm %%DOCSDIR%%
> * Add some shebangfix to allow building most of the ports tree without /usr/bin...bapt2013-05-071-5/+4 * - Separate print/tex-dvipdfmx from print/texlive-base and add libpaperhrs2013-05-071-5/+6 * Convert from WITHOUT_NLS to PORT_OPTIONS:MNLSbapt2013-05-061-9/+7 * Remove *_DEPENDS from ports which depend on teTeX and add USE_TEX=tetexhrs2013-05-068-43/+16 * TeXLive mega commit. The following ports have been added:hrs2013-05-067-0/+3909 * Use OPTIONS_DEFINE and add style clean-ups.hrs2013-05-062-12/+13 * - Fix fork() and select() in skkserv. It didn't work properly.hrs2013-05-054-19/+130 * - Ubreak.kuriyama2013-05-045-3/+42 * Trim old-style header and add style clean-ups.hrs2013-05-041-8/+2 * - Fix build after utmp->utmpx migration.hrs2013-05-044-52/+78 * - Update to 3.0.j2.1b.hrs2013-05-045-114/+322 * - Trim old-style header.hrs2013-05-041-24/+22 * Unmark BROKEN. It seems buildable.ume2013-05-041-2/+0 * Chase security/libgcrypt updateehaupt2013-05-041-6/+2 * Fix syntax errorbapt2013-05-031-3/+3 * Trim old-style header.hrs2013-05-032-10/+2 * Fix pkg-plist.hrs2013-05-031-1/+1 * - Trim old-style header.hrs2013-05-031-21/+21 * - Trim old-style header.hrs2013-05-032-7/+4 * - Rename files/patch-aa.hrs2013-05-034-17/+17 * - Trim old-style header.hrs2013-05-035-57/+15 * - Add paperconf(1) support for the default paper size configuration.hrs2013-05-012-17/+34 * Update to 3.03.hrs2013-05-013-32/+106 * - Trim old-style header.hrs2013-05-011-6/+3 * - Trim old-style header.hrs2013-05-012-14/+16 * Fix DATADIR.hrs2013-05-011-1/+2 * Update to 20130430 and add style clean-ups.hrs2013-05-013-28/+32 * Use an old version of IPA fonts as Ryumin-Light and GothicBBB-Medium forhrs2013-05-011-13/+13 * - Trim old-style header.hrs2013-05-011-13/+14 * - Fix DATADIR.hrs2013-05-011-6/+8 * - Use OPTIONS_DEFINE.hrs2013-05-012-8/+14 * Fix DATADIR.hrs2013-05-011-0/+2 * Fix DATADIR.hrs2013-05-011-0/+2 * - Trim old-style header.hrs2013-05-011-13/+14 * - Trim old-style header.hrs2013-05-012-13/+15 * Fix DATADIR.hrs2013-05-011-0/+2 * Fix DATADIR.hrs2013-05-011-0/+2 * - Trim old-style header.hrs2013-05-012-13/+15 * Update to 20130422 and add style clean-ups.hrs2013-05-013-18/+17 * - Trim old-style header.hrs2013-05-011-17/+14 * Update to 20130430 and add style clean-ups.hrs2013-05-013-28/+32 * Update to 450 and style clean-ups.hrs2013-04-302-11/+15 * Update to TESTFLIGHT-055 and add style clean-ups.hrs2013-04-303-29/+31 * - Trim old-style header.hrs2013-04-302-12/+12 * Rely on bsdtar to autodetermine the format of the distfiles when possiblebapt2013-04-293-12/+6 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-2718-26/+21 * Convert from USE_GETTEXT to USES= gettextbapt2013-04-271-28/+22 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-261-1/+1 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-2513-15/+15 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-241-1/+1 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-241-2/+1 * fixed a mozc-el build issuedaichi2013-04-242-5/+5 * Convert j* categories to USES=pkgconfigbapt2013-04-236-16/+8 * enabled mozc_renderder, default on.daichi2013-04-231-5/+10 * update to 1.10.1390.102daichi2013-04-2321-137/+164 * Update to 4.0.2.jkim2013-04-171-4/+4 * Update to 449 because the old distfile was removed.hrs2013-04-152-3/+3 * - Mark broken fails to buildmiwi2013-04-021-0/+2 * - update japanes/bugzilla templatesohauer2013-04-016-10/+10 * GNU Emacs updatesashish2013-03-305-4/+5 * - Update Calligra and l10n ports to 2.6.2:avilla2013-03-301-1/+1 * - Fix buildmiwi2013-03-292-6/+85 * Style: tab -> space.eadler2013-03-2914-16/+16 * Drop support for old versions of FreeBSD from unmaintained portseadler2013-03-281-4/+0 * Mechanically convert unmaintained ports which use "gnomehack" to use "pathfix...eadler2013-03-281-6/+3 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-275-19/+13 * - Divide ebnetd.sh into 3 scriptstota2013-03-2510-94/+111 * - Add explicit pkgconf dependencybdrewery2013-03-241-5/+2 * - update to 15.1rm2013-03-232-3/+3 * - Update to 9.1tota2013-03-232-10/+5 * - convert USE_CMAKE to USESmakc2013-03-231-1/+1 * Mk/bsd.kde4.mk:makc2013-03-221-1/+2 * - Update to 0.995tota2013-03-203-9/+12 * - Update to 0.995tota2013-03-203-12/+16 * - Update to 0.995tota2013-03-204-12/+28 * - Update to 0.995tota2013-03-204-38/+31 * "aaargh, quoted Makefile variables"eadler2013-03-196-38/+12 * 1: Upgrade protobuf to 2.5.0.vanilla2013-03-181-2/+2 * Google droped SCIM support from Mozc.daichi2013-03-093-50/+0 * Update to 4.0.1.jkim2013-03-091-4/+4 * Convert USE_BISON to USES= bisonbapt2013-03-083-13/+5 * * Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 whichkwm2013-03-083-1/+11 * - Add new knob USE_LHA [1]miwi2013-03-084-21/+6 * - Undo patch for buggy Net:DNS .69. caused 404 errors <.69scheidell2013-03-071-1/+1 * - Update *_DEPENDS on databases/py-sqlite3 after _sqlite3.so relocationlwhsu2013-03-041-6/+2 * - Add CONFLICTS as a preparation of importing new TeX ports based on TeXLive.hrs2013-03-044-20/+23 * - Fix EXPIRATION date, we are in 2013, not 2012swills2013-03-033-3/+3 * - Deprecate ports which don't work with Ruby 1.9swills2013-03-033-10/+11 * - Update to 20130228.kuriyama2013-03-024-10/+10 * - Fix build on FreeBSD 9+miwi2013-02-271-6/+2 * - Sync with MASTER: fix problem with Net:DNS > .69scheidell2013-02-271-5/+2 * - remove german, french and japanese localization of www/MT. They wererm2013-02-243-26/+0 * - BROKEN does not buildmiwi2013-02-231-0/+2 * - BROKEN checksum mismatchmiwi2013-02-211-0/+2 * - Update to 14.4miwi2013-02-183-12/+13 * - Update to 201302swills2013-02-182-12/+8 * - Fix patchingtota2013-02-172-15/+11 * - Fix issue that option settings are saved in /var/db/ports/ja-mecabtota2013-02-112-25/+9