aboutsummaryrefslogtreecommitdiffstats
path: root/databases/qt-pgsql-plugin
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /databases/qt-pgsql-plugin
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'databases/qt-pgsql-plugin')
-rw-r--r--databases/qt-pgsql-plugin/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/databases/qt-pgsql-plugin/Makefile b/databases/qt-pgsql-plugin/Makefile
index 6327a09a7269..49c30880d0fe 100644
--- a/databases/qt-pgsql-plugin/Makefile
+++ b/databases/qt-pgsql-plugin/Makefile
@@ -1,10 +1,5 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: qt-pgsql-plugin
-# Date created: 5 August 2003
-# Whom: Lauri Watts <lauri@kde.org>
-#
+# Created by: Lauri Watts <lauri@kde.org>
# $FreeBSD$
-#
PORTNAME= qt-${DB}-plugin
PORTVERSION= 3.3.8
@@ -28,8 +23,8 @@ USE_PGSQL= yes
USE_BZIP2= yes
PLUGIN= plugins/src/sqldrivers/${DB}
DRIVER= src/sql/drivers/${DB}
-EXTRACT_AFTER_ARGS?=| ${TAR} -xf - ${DISTNAME}/${PLUGIN} \
- ${DISTNAME}/${DRIVER} ${DISTNAME}/src/sql/drivers/cache
+EXTRACT_AFTER_ARGS?= ${DISTNAME}/${PLUGIN} \
+ ${DISTNAME}/${DRIVER} ${DISTNAME}/src/sql/drivers/cache
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV+= DB="${DB}" DRIVER="${DRIVER}" PLUGIN="${PLUGIN}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \