aboutsummaryrefslogtreecommitdiffstats
path: root/databases/qt4-odbc-plugin
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /databases/qt4-odbc-plugin
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'databases/qt4-odbc-plugin')
-rw-r--r--databases/qt4-odbc-plugin/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/databases/qt4-odbc-plugin/Makefile b/databases/qt4-odbc-plugin/Makefile
index 0d771853af34..0b4497cc82e4 100644
--- a/databases/qt4-odbc-plugin/Makefile
+++ b/databases/qt4-odbc-plugin/Makefile
@@ -19,9 +19,8 @@ MAKE_JOBS_SAFE= yes
DRIVER= src/sql/drivers/${DB}
PLUGIN= src/plugins/sqldrivers/${DB}
-EXTRACT_AFTER_ARGS?=| ${TAR} -xf - \
- ${DISTNAME}/${DRIVER} \
- ${DISTNAME}/${PLUGIN}
+EXTRACT_AFTER_ARGS?= ${DISTNAME}/${DRIVER} \
+ ${DISTNAME}/${PLUGIN}
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV+= DB="${DB}" DRIVER="${DRIVER}" MOC="${MOC}" \
PLUGIN="${PLUGIN}" \