aboutsummaryrefslogtreecommitdiffstats
path: root/databases/recutils
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2012-11-01 21:43:27 +0800
committerdanfe <danfe@FreeBSD.org>2012-11-01 21:43:27 +0800
commit3195fb54a8feed54d29198259edbe96fa6754bb3 (patch)
tree50c68a01058f21cce5c4775ea01910d85d98ab2c /databases/recutils
parent98178092001d5db54b0f5f1d4b6375bccb1b0ab8 (diff)
downloadfreebsd-ports-gnome-3195fb54a8feed54d29198259edbe96fa6754bb3.tar.gz
freebsd-ports-gnome-3195fb54a8feed54d29198259edbe96fa6754bb3.tar.zst
freebsd-ports-gnome-3195fb54a8feed54d29198259edbe96fa6754bb3.zip
Install a few docs; omit port revision bump as this port was added for a
private request just couple of hours ago and thus probably not installed in sufficient quantities to warrant it. Feature safe: yes
Diffstat (limited to 'databases/recutils')
-rw-r--r--databases/recutils/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/databases/recutils/Makefile b/databases/recutils/Makefile
index e3418f580a3e..706bc393bf51 100644
--- a/databases/recutils/Makefile
+++ b/databases/recutils/Makefile
@@ -11,7 +11,7 @@ COMMENT= Tools and libraries to access human-editable, plain text databases
LICENSE= GPLv3
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= NLS DOCS
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -19,6 +19,7 @@ USE_LDCONFIG= yes
INFO= ${PORTNAME}
MAN1= csv2rec.1 rec2csv.1 recdel.1 recfix.1 recfmt.1 recinf.1 \
recins.1 recsel.1 recset.1
+PORTDOCS= ChangeLog NEWS README
.include <bsd.port.options.mk>
@@ -30,4 +31,10 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>