aboutsummaryrefslogtreecommitdiffstats
path: root/databases/redis
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2011-09-14 14:39:19 +0800
committerosa <osa@FreeBSD.org>2011-09-14 14:39:19 +0800
commitf7639cc849b13e8379e820fdd138336e29b08cb5 (patch)
tree0430d89910f4a8b23647095fef99dc486af0f1ac /databases/redis
parent1dacb8468bb29fdffa98272249ba0690e3334358 (diff)
downloadfreebsd-ports-gnome-f7639cc849b13e8379e820fdd138336e29b08cb5.tar.gz
freebsd-ports-gnome-f7639cc849b13e8379e820fdd138336e29b08cb5.tar.zst
freebsd-ports-gnome-f7639cc849b13e8379e820fdd138336e29b08cb5.zip
Update from 2.2.12 to latest bugfix release 2.2.13.
<ChangeLog> * [BUGFIX] Fixed issue 593 (BRPOPLPUSH related crash). * [BUGFIX] Fixed an issue with the networking layer that may prevent Redis from sending the whole reply back to client under extreme conditions. </ChangeLog>
Diffstat (limited to 'databases/redis')
-rw-r--r--databases/redis/Makefile3
-rw-r--r--databases/redis/distinfo4
-rw-r--r--databases/redis/files/patch-src::Makefile12
3 files changed, 9 insertions, 10 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 51e44d545125..3e9955d4452b 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= redis
-PORTVERSION= 2.2.12
-PORTREVISION= 1
+PORTVERSION= 2.2.13
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index 89b9a92ed234..0da834621eee 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis-2.2.12.tar.gz) = 9e2a4133b920fc4eed731c9cd3a9d0b60e701179ea98b2944ab434e7b1d0db03
-SIZE (redis-2.2.12.tar.gz) = 455240
+SHA256 (redis-2.2.13.tar.gz) = e6353c022bc6442d61f196ca411348a6a3ab61cfa30f629c2c954d759710d370
+SIZE (redis-2.2.13.tar.gz) = 455330
diff --git a/databases/redis/files/patch-src::Makefile b/databases/redis/files/patch-src::Makefile
index 21674a4798b2..1a3bdd9047d9 100644
--- a/databases/redis/files/patch-src::Makefile
+++ b/databases/redis/files/patch-src::Makefile
@@ -1,6 +1,6 @@
---- src/Makefile.orig 2010-12-24 09:29:14.000000000 +0300
-+++ src/Makefile 2010-12-24 09:31:51.000000000 +0300
-@@ -9,6 +9,9 @@
+--- src/Makefile.orig 2011-09-14 10:32:32.000000000 +0400
++++ src/Makefile 2011-09-14 10:34:08.000000000 +0400
+@@ -22,6 +22,9 @@
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
CCLINK?= -ldl -lnsl -lsocket -lm -lpthread
DEBUG?= -g -ggdb
@@ -10,12 +10,12 @@
else
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
CCLINK?= -lm -pthread
-@@ -19,9 +22,9 @@
+@@ -32,9 +35,9 @@
CCLINK+= -ltcmalloc
CFLAGS+= -DUSE_TCMALLOC
endif
--CCOPT= $(CFLAGS) $(CCLINK) $(ARCH) $(PROF)
-+CCOPT= $(CFLAGS) $(CCLINK) $(PROF)
+-CCOPT= $(CFLAGS) $(ARCH) $(PROF)
++CCOPT= $(CFLAGS) $(PROF)
-PREFIX= /usr/local
+PREFIX?= $(PREFIX)