aboutsummaryrefslogtreecommitdiffstats
path: root/databases/rocksdb/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-06-06 02:56:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-06-06 02:56:58 +0800
commit2e107a153c66b03ff8eec8b3becef29ec24f9302 (patch)
treefbde4f21745a15d2ea2b5ef22f70e8452265262a /databases/rocksdb/Makefile
parent86939f6e352cad042de90fd68da107c33aef75dc (diff)
downloadfreebsd-ports-gnome-2e107a153c66b03ff8eec8b3becef29ec24f9302.tar.gz
freebsd-ports-gnome-2e107a153c66b03ff8eec8b3becef29ec24f9302.tar.zst
freebsd-ports-gnome-2e107a153c66b03ff8eec8b3becef29ec24f9302.zip
- Disable SSE4.2 on i386 architecture to fix i386 builds on FreeBSD package building cluster
- Cleanup Makefile: something forgot to removed before committing r388095
Diffstat (limited to 'databases/rocksdb/Makefile')
-rw-r--r--databases/rocksdb/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index 791187d49a68..a674e33a2e33 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -33,12 +33,9 @@ PROGRAMS= db_bench db_repl_stress db_sanity_test db_stress ldb sst_dump table_re
CFLAGS+= -D_GLIBCXX_USE_C99
.endif
-.if ${COMPILER_TYPE} == clang
-#CXXFLAGS+= -Wno-shift-count-overflow
-.if ${COMPILER_VERSION} >= 36
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 36
CXXFLAGS+= -Wno-inconsistent-missing-override
.endif
-.endif
post-patch:
@${REINPLACE_CMD} -e '/^all: / s| $$(TESTS)||' ${WRKSRC}/Makefile
@@ -46,8 +43,9 @@ post-patch:
.if defined(WITHOUT_PROFILE)
@${REINPLACE_CMD} -e '/pg = / s| -pg||' ${WRKSRC}/Makefile
.endif
-.if !defined(MACHINE_CPU:Msse42)
-# @${REINPLACE_CMD} -e 's| -msse4.2||' ${WRKSRC}/build_tools/build_detect_platform
+# Disable SSE4.2 on i386 architecture to fix i386 builds on FreeBSD package building cluster
+.if ${ARCH} == i386
+ @${REINPLACE_CMD} -e 's|#ifdef __SSE4_2__|&DISABLED__|' ${WRKSRC}/util/crc32c.cc
.endif
do-install: