aboutsummaryrefslogtreecommitdiffstats
path: root/databases/rubygem-sqlite3-ruby
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-06-07 03:25:10 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-06-07 03:25:10 +0800
commit3ce7d09e6cb23f7c5b6ed1696276c8217b89b269 (patch)
treec83099a1416420b251b7dff34f02f34558b886bf /databases/rubygem-sqlite3-ruby
parent9e6b05898aa0f314786d557f8d5442836ca2c060 (diff)
downloadfreebsd-ports-gnome-3ce7d09e6cb23f7c5b6ed1696276c8217b89b269.tar.gz
freebsd-ports-gnome-3ce7d09e6cb23f7c5b6ed1696276c8217b89b269.tar.zst
freebsd-ports-gnome-3ce7d09e6cb23f7c5b6ed1696276c8217b89b269.zip
- GEMS are always RUN_DEPENDS of other GEMS
- Bump PORTREVISION when something other then BUILD_DEPENDS changes - Some minor verticle whitespace in some ports for consistency with the rest PR: ports/147551 Submitted by: pgollucci@ (myself) Reviewed by: portmgr (pav) With Hat: ruby
Diffstat (limited to 'databases/rubygem-sqlite3-ruby')
-rw-r--r--databases/rubygem-sqlite3-ruby/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/databases/rubygem-sqlite3-ruby/Makefile b/databases/rubygem-sqlite3-ruby/Makefile
index c6492884ab8c..310a10d91e8e 100644
--- a/databases/rubygem-sqlite3-ruby/Makefile
+++ b/databases/rubygem-sqlite3-ruby/Makefile
@@ -14,13 +14,15 @@ DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby interface to the SQLite DB engine version 3
-BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
-USE_RUBY= yes
-USE_RUBYGEMS= yes
CONFIGURE_ARGS+=--with-sqlite3-dir=${LOCALBASE}
+
GEM_NAME= ${DISTNAME}
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>