aboutsummaryrefslogtreecommitdiffstats
path: root/databases/slony1v2/Makefile
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-06-24 19:22:43 +0800
committerlawrance <lawrance@FreeBSD.org>2005-06-24 19:22:43 +0800
commitd35cb934cf4fe8ba48f438586f275d0aaa75f48c (patch)
treee33e2cd48a7b4b046fa96d61d43d291704b35d0b /databases/slony1v2/Makefile
parent6e257d6c50a3b5f38431420081284691ae0c8c8b (diff)
downloadfreebsd-ports-gnome-d35cb934cf4fe8ba48f438586f275d0aaa75f48c.tar.gz
freebsd-ports-gnome-d35cb934cf4fe8ba48f438586f275d0aaa75f48c.tar.zst
freebsd-ports-gnome-d35cb934cf4fe8ba48f438586f275d0aaa75f48c.zip
Update to 1.1.0
PR: ports/82589 Submitted by: Vivek Khera <vivek@khera.org> (maintainer)
Diffstat (limited to 'databases/slony1v2/Makefile')
-rw-r--r--databases/slony1v2/Makefile74
1 files changed, 31 insertions, 43 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 85f210207892..b5514ac2b046 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -6,73 +6,61 @@
#
PORTNAME= slony1
-PORTVERSION= 1.0.5
-PORTREVISION= 2
+PORTVERSION= 1.1.0
CATEGORIES= databases
MASTER_SITES= http://developer.postgresql.org/~wieck/slony1/download/
MAINTAINER= vivek@khera.org
-COMMENT= PostgreSQL master to multiple slaves replication system
+COMMENT= PostgreSQL master to multiple replicas replication system
PGSQL_PORT= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-BUILD_DEPENDS= ${NONEXISTENT}:${PGSQL_PORT}:configure
-.if ! defined(NOPORTDOCS)
-BUILD_DEPENDS+= ${LOCALBASE}/bin/pnmtops:${PORTSDIR}/graphics/netpbm \
- ${LOCALBASE}/bin/djpeg:${PORTSDIR}/graphics/jpeg \
- ${LOCALBASE}/bin/ps2pdf:${PORTSDIR}/print/ghostscript-gnu
-.else
-EXTRA_PATCHES= ${FILESDIR}/extra-GNUmakefile.in
-.endif
RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
GNU_CONFIGURE= yes
-USE_BISON= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-PGSQL_SRC= `cd ${PGSQL_PORT}; make -V WRKSRC`
-CONFIGURE_ARGS= --with-pgsourcetree=${PGSQL_SRC}
+USE_BZIP2= yes
+USE_RC_SUBR= slon.sh
-PLIST_FILES= bin/slon bin/slonik bin/slony_setup.pl \
- lib/postgresql/slony1_funcs.so lib/postgresql/xxid.so \
- share/postgresql/slony1_base.sql \
- share/postgresql/slony1_funcs.sql \
- share/postgresql/slony1_base.v73.sql \
- share/postgresql/slony1_base.v74.sql \
- share/postgresql/slony1_funcs.v73.sql \
- share/postgresql/slony1_funcs.v74.sql \
- share/postgresql/xxid.v73.sql \
- share/postgresql/xxid.v74.sql
-PORTDOCS= *.pdf howto COPYRIGHT README slonik_commands.html
+SUB_FILES= pkg-message slon-mkservice.sh
+SUB_LIST+= NAME=slon
-DEFAULT_PGSQL_VER?=74
+OPTIONS= PERLTOOLS "Install perl configuration tools" Off
.include <bsd.port.pre.mk>
+
+.if defined(WITH_PERLTOOLS)
+USE_PERL5_RUN= yes
+CONFIGURE_ARGS+= --with-perltools=${LOCALBASE}/sbin
+PLIST_SUB+= PERLTOOLS=""
+SUB_LIST+= PERLTOOLS=""
+.else
+PLIST_SUB+= PERLTOOLS="@comment "
+SUB_LIST+= PERLTOOLS="@comment "
+.endif
+
+DEFAULT_PGSQL_VER?=80
+
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | \
- ${SED} -n 's/postmaster.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+ ${SED} -En 's/postmaster.*PostgreSQL[^0-9]*([0-9]+)\.([0-9]+)\..*/\1\2/p'
.elif exists(${LOCALBASE}/bin/pg_config)
-PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | \
+ ${SED} -En 's/PostgreSQL[^0-9]*([0-9]*)\.([0-9]+)\..*/\1\2/p'
.else
PGSQL_VER= ${DEFAULT_PGSQL_VER}
.endif
-pre-configure:
- cd ${PGSQL_SRC}/src/interfaces/libpq && ${GMAKE} all
- cd ${PGSQL_SRC}/src/port && ${GMAKE} all
-
-do-install:
- cd ${WRKSRC} && ${GMAKE} install
- ${INSTALL_SCRIPT} ${WRKSRC}/tools/slony_setup.pl ${PREFIX}/bin
+post-install:
.if ! defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/concept/Slony-I-concept.pdf ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/implementation/Slony-I-implementation.pdf ${DOCSDIR}
- ${MKDIR} ${DOCSDIR}/howto
- ${INSTALL_DATA} ${WRKSRC}/doc/howto/*.txt ${DOCSDIR}/howto
- ${INSTALL_DATA} ${WRKSRC}/doc/howto/slonik_commands.html ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/adminguide
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${WRKSRC}/INSTALL ${WRKSRC}/SAMPLE ${WRKSRC}/README ${WRKSRC}/UPGRADING ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*/*.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/adminguide/prebuilt/*.html ${DOCSDIR}/adminguide/
.endif
- ${CAT} ${PKGMESSAGE}
+ @${INSTALL_SCRIPT} ${WRKDIR}/slon-mkservice.sh ${PREFIX}/sbin/slon-mkservice
+ @${INSTALL_DATA} ${FILESDIR}/slon.conf-sample ${PREFIX}/etc/
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>