aboutsummaryrefslogtreecommitdiffstats
path: root/databases/sqlclient
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-10-31 14:10:09 +0800
committerdinoex <dinoex@FreeBSD.org>2006-10-31 14:10:09 +0800
commit9d850892571e61b1c3fb261bad4fbac53ad82bc2 (patch)
tree7f5c2ae964bea2fd88353b3b5f38c48a1921b6d5 /databases/sqlclient
parentaa724209c7c639d0437e73ec1c9843280af56582 (diff)
downloadfreebsd-ports-gnome-9d850892571e61b1c3fb261bad4fbac53ad82bc2.tar.gz
freebsd-ports-gnome-9d850892571e61b1c3fb261bad4fbac53ad82bc2.tar.zst
freebsd-ports-gnome-9d850892571e61b1c3fb261bad4fbac53ad82bc2.zip
This library is a lightweight database abstraction layer designed to make
it simple to write high performance applications using SQL databases from Objective-C. The library consists of a semi-abstract superclass doing much of the work and allowing extremely simple database specific bundles to be written to talk to particular database servers. It comes with backend bundles for Postgres, MySQL, and SQLite (plus an untested Oracle bundle).
Diffstat (limited to 'databases/sqlclient')
-rw-r--r--databases/sqlclient/Makefile45
-rw-r--r--databases/sqlclient/distinfo3
-rw-r--r--databases/sqlclient/pkg-descr7
-rw-r--r--databases/sqlclient/pkg-plist41
4 files changed, 96 insertions, 0 deletions
diff --git a/databases/sqlclient/Makefile b/databases/sqlclient/Makefile
new file mode 100644
index 000000000000..d760eec57d87
--- /dev/null
+++ b/databases/sqlclient/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: sqlclient
+# Date created: 28 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlclient
+PORTVERSION= 1.2.0
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_GNUSTEP}
+MASTER_SITE_SUBDIR= libs
+DISTNAME= SQLClient-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Lightweight database abstraction layer
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_CONFIGURE= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+LDCONFIG_DIRS= ${LOCALLIBDIR}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+
+USE_GNUSTEP_LOCAL_LIBS+= Performance:${PERFORMANCE_PORT}
+PERFORMANCE_PORT?= devel/performance
+
+USE_PGSQL=yes
+
+USE_MYSQL=yes
+USE_SQLITE=yes
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+
+#CONFIGURE_ARGS+= --with-additional-lib="${PHREAD_LIBS}"
+#ADDITIONAL_LDFLAGS+= -L${LOCALBASE}/lib
+#MAKE_ENV+= ADDITIONAL_LDFLAGS="${ADDITIONAL_LDFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/databases/sqlclient/distinfo b/databases/sqlclient/distinfo
new file mode 100644
index 000000000000..1de047773bca
--- /dev/null
+++ b/databases/sqlclient/distinfo
@@ -0,0 +1,3 @@
+MD5 (SQLClient-1.2.0.tar.gz) = c26320a747092baa72dc7fb51994ae61
+SHA256 (SQLClient-1.2.0.tar.gz) = 2fc495e2be7935aae6669bf30c5229c84a7cb12ba40e3c960b3e9b0e6f272fed
+SIZE (SQLClient-1.2.0.tar.gz) = 125555
diff --git a/databases/sqlclient/pkg-descr b/databases/sqlclient/pkg-descr
new file mode 100644
index 000000000000..ac5377975046
--- /dev/null
+++ b/databases/sqlclient/pkg-descr
@@ -0,0 +1,7 @@
+This library is a lightweight database abstraction layer designed to make
+it simple to write high performance applications using SQL databases from
+Objective-C.
+The library consists of a semi-abstract superclass doing much of the work
+and allowing extremely simple database specific bundles to be written to
+talk to particular database servers. It comes with backend bundles for
+Postgres, MySQL, and SQLite (plus an untested Oracle bundle).
diff --git a/databases/sqlclient/pkg-plist b/databases/sqlclient/pkg-plist
new file mode 100644
index 000000000000..c7782d1253c3
--- /dev/null
+++ b/databases/sqlclient/pkg-plist
@@ -0,0 +1,41 @@
+Local/Library/Bundles/SQLClient/ECPG.bundle/ECPG
+Local/Library/Bundles/SQLClient/ECPG.bundle/Resources/Info-gnustep.plist
+Local/Library/Bundles/SQLClient/ECPG.bundle/stamp.make
+Local/Library/Bundles/SQLClient/ECPG_libs.bundle/ECPG_libs
+Local/Library/Bundles/SQLClient/ECPG_libs.bundle/Resources/Info-gnustep.plist
+Local/Library/Bundles/SQLClient/ECPG_libs.bundle/stamp.make
+Local/Library/Bundles/SQLClient/Postgres.bundle/Postgres
+Local/Library/Bundles/SQLClient/Postgres.bundle/Resources/Info-gnustep.plist
+Local/Library/Bundles/SQLClient/Postgres.bundle/stamp.make
+Local/Library/Bundles/SQLClient/Postgres_libs.bundle/Postgres_libs
+Local/Library/Bundles/SQLClient/Postgres_libs.bundle/Resources/Info-gnustep.plist
+Local/Library/Bundles/SQLClient/Postgres_libs.bundle/stamp.make
+Local/Library/Bundles/SQLClient/SQLite.bundle/Resources/Info-gnustep.plist
+Local/Library/Bundles/SQLClient/SQLite.bundle/SQLite
+Local/Library/Bundles/SQLClient/SQLite.bundle/stamp.make
+Local/Library/Bundles/SQLClient/SQLite_libs.bundle/Resources/Info-gnustep.plist
+Local/Library/Bundles/SQLClient/SQLite_libs.bundle/SQLite_libs
+Local/Library/Bundles/SQLClient/SQLite_libs.bundle/stamp.make
+Local/Library/Documentation/SQLClient/SQLClient.gsdoc
+Local/Library/Documentation/SQLClient/SQLClient.html
+Local/Library/Documentation/SQLClient/SQLClient.igsdoc
+Local/Library/Documentation/SQLClient/dependencies
+Local/Library/Headers/SQLClient/SQLClient.h
+Local/Library/Libraries/libSQLClient.so
+Local/Library/Libraries/libSQLClient.so.%%MAJORVERSION%%.2
+Local/Library/Libraries/libSQLClient.so.%%VERSION%%
+@dirrm Local/Library/Headers/SQLClient
+@dirrm Local/Library/Documentation/SQLClient
+@dirrm Local/Library/Bundles/SQLClient/SQLite_libs.bundle/Resources
+@dirrm Local/Library/Bundles/SQLClient/SQLite_libs.bundle
+@dirrm Local/Library/Bundles/SQLClient/SQLite.bundle/Resources
+@dirrm Local/Library/Bundles/SQLClient/SQLite.bundle
+@dirrm Local/Library/Bundles/SQLClient/Postgres_libs.bundle/Resources
+@dirrm Local/Library/Bundles/SQLClient/Postgres_libs.bundle
+@dirrm Local/Library/Bundles/SQLClient/Postgres.bundle/Resources
+@dirrm Local/Library/Bundles/SQLClient/Postgres.bundle
+@dirrm Local/Library/Bundles/SQLClient/ECPG_libs.bundle/Resources
+@dirrm Local/Library/Bundles/SQLClient/ECPG_libs.bundle
+@dirrm Local/Library/Bundles/SQLClient/ECPG.bundle/Resources
+@dirrm Local/Library/Bundles/SQLClient/ECPG.bundle
+@dirrm Local/Library/Bundles/SQLClient