aboutsummaryrefslogtreecommitdiffstats
path: root/databases/sqlite2
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-17 05:51:43 +0800
committerbapt <bapt@FreeBSD.org>2014-07-17 05:51:43 +0800
commit3b6d397179df63cc7b496e0428a54ea39e7daa10 (patch)
treed8adf73a5c043a0c8cc9655b3619027ba54c1f24 /databases/sqlite2
parentfa25d87fcb7167d8cb6103df7a45d159895e4219 (diff)
downloadfreebsd-ports-gnome-3b6d397179df63cc7b496e0428a54ea39e7daa10.tar.gz
freebsd-ports-gnome-3b6d397179df63cc7b496e0428a54ea39e7daa10.tar.zst
freebsd-ports-gnome-3b6d397179df63cc7b496e0428a54ea39e7daa10.zip
Fix build without shared readline in base
Diffstat (limited to 'databases/sqlite2')
-rw-r--r--databases/sqlite2/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 45525057e510..816948a3ba32 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= SQL database engine in a C library
-USES= gmake pkgconfig
+USES= gmake pkgconfig readline
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
@@ -19,12 +19,14 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
DOCSDIR= ${PREFIX}/share/doc/sqlite2
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite2
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}2
-
EXTRACT_AFTER_ARGS= --exclude CVS
OPTIONS_DEFINE= TCL THREADS DOCS
+.if !exists(/usr/lib/libreadline.so)
+MAKE_ARGS= READLINE_FLAGS="-DHAVE_READLINE=1 -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+.endif
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTCL}