aboutsummaryrefslogtreecommitdiffstats
path: root/databases/sybase-ocsd/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-07-31 08:05:21 +0800
committermi <mi@FreeBSD.org>2002-07-31 08:05:21 +0800
commit6f028b16242e4a256228a6049b95bbfe1dd56672 (patch)
tree8e78d50cd2f74fbd683cca75e4808f4fde4620db /databases/sybase-ocsd/Makefile
parentb269a419425a807d29df8bb6adad83576ada39a8 (diff)
downloadfreebsd-ports-gnome-6f028b16242e4a256228a6049b95bbfe1dd56672.tar.gz
freebsd-ports-gnome-6f028b16242e4a256228a6049b95bbfe1dd56672.tar.zst
freebsd-ports-gnome-6f028b16242e4a256228a6049b95bbfe1dd56672.zip
Port of Sybase's OpenClient -- discovered by accident on Sybase's
"Linux" web-site this port has static versions of native FreeBSD libraries good enough to build sqsh with it instead of the freetds. See pkg-descr and pkg-message for more. i386 only, though...
Diffstat (limited to 'databases/sybase-ocsd/Makefile')
-rw-r--r--databases/sybase-ocsd/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/databases/sybase-ocsd/Makefile b/databases/sybase-ocsd/Makefile
new file mode 100644
index 000000000000..d73e765cc1a8
--- /dev/null
+++ b/databases/sybase-ocsd/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: sybase-openclient
+# Date created: Jul 25, 2002
+# Whom: mi
+#
+# $FreeBSD$
+#
+
+PORTNAME= sybase-ocsd
+PORTVERSION= 10.0.4.6
+CATEGORIES= databases
+MASTER_SITES= http://linux.sybase.com/REL11033/ \
+ http://virtual-estates.net/~mi/port-stuff/
+DISTFILES= ${PORTNAME}-${PORTVERSION:R}-FreeBSD-${PORTVERSION:E}.i386.tgz \
+ LICENSE ${RESTRICTED_FILES}
+DIST_SUBDIR= sybase
+EXTRACT_ONLY=
+
+MAINTAINER= mi@aldan.algebra.com
+
+NO_BUILD= no sources :-\
+WRKSRC= ${WRKDIR}/sybase
+ONLY_FOR_ARCHS= i386
+NO_PACKAGE= Packaging is pointless, the port does not build anything
+
+# The file below contains the locale data files missing from the official
+# distribution. Sybase noticed the mistake in
+# http://www.sybase.com/detail/1,6904,2894,00.html
+# but the only reasonable workaround suggested there points to a broken
+# link. This file is just a subset of a much bigger
+# http://linux.sybase.com/REL11033/sybase-ase-11.0.3.3-FreeBSD-6.i386.tgz
+# which, despite its name, contains only Linux binaries and kernel patches.
+
+# I follow the spirit of the license by making the locale file available
+# unaltered, but don't want FreeBSD to appear to disrespect the letter.
+# A comment from Sybase would be most welcome as well as the newer version
+# of the binaries for all of the FreeBSD platforms.
+RESTRICTED_FILES=sybase-11.0.3.3-locale.tar.bz2
+
+do-install:
+ ${TAR} -xpzf ${_DISTDIR}/${DISTFILES:M*.tgz} -C ${PREFIX} \
+ sybase/include sybase/lib sybase/devlib
+ ${TAR} -xpyf ${_DISTDIR}/${DISTFILES:M*locale*} -C ${PREFIX}/sybase
+ ${INSTALL_DATA} ${FILESDIR}/interfaces.sample ${PREFIX}/sybase/
+ -@${SED} 's|PREFIX|${PREFIX}|g' < pkg-message
+
+.include <bsd.port.mk>