aboutsummaryrefslogtreecommitdiffstats
path: root/databases/tcl-Mysql
diff options
context:
space:
mode:
authorru <ru@FreeBSD.org>2002-07-22 01:23:29 +0800
committerru <ru@FreeBSD.org>2002-07-22 01:23:29 +0800
commit356e44033fea83887c12078f1a9c3c0a416ae000 (patch)
treec2f10ec4a4868b0fa127a08e3d1b251de91359dc /databases/tcl-Mysql
parent85ae63e74c16db02a1d2722f73ff18698a27684f (diff)
downloadfreebsd-ports-gnome-356e44033fea83887c12078f1a9c3c0a416ae000.tar.gz
freebsd-ports-gnome-356e44033fea83887c12078f1a9c3c0a416ae000.tar.zst
freebsd-ports-gnome-356e44033fea83887c12078f1a9c3c0a416ae000.zip
Catch up to the new bsd.lib.mk API (the lib is not internal).
Diffstat (limited to 'databases/tcl-Mysql')
-rw-r--r--databases/tcl-Mysql/files/Makefile.bsd5
1 files changed, 1 insertions, 4 deletions
diff --git a/databases/tcl-Mysql/files/Makefile.bsd b/databases/tcl-Mysql/files/Makefile.bsd
index 07b65cc542fd..eb19e914f869 100644
--- a/databases/tcl-Mysql/files/Makefile.bsd
+++ b/databases/tcl-Mysql/files/Makefile.bsd
@@ -1,8 +1,6 @@
TCL_VERSION?= tcl8.3
TCL_NODOT?= ${TCL_VERSION:S/.//}
-LIB = TclMySQL
-SHLIB_MAJOR= 1
-SHLIB_MINOR= 0
+SHLIB_NAME= libTclMySQL.so.1
SRCS = sql-mysql.cc sql.cc sql-manager.cc
CXXFLAGS+= -I${LOCALBASE}/include/${TCL_VERSION}
@@ -10,7 +8,6 @@ CXXFLAGS+= -I${LOCALBASE}/include/mysql
LDADD += -L${LOCALBASE}/lib -l${TCL_NODOT}
LDADD += -L${LOCALBASE}/lib/mysql -lmysqlclient
LDADD += -lgcc
-INTERNALLIB= yeah, don't make the useless static lib
printname:
@echo -n ${SHLIB_NAME}