aboutsummaryrefslogtreecommitdiffstats
path: root/databases/typhoon
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /databases/typhoon
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'databases/typhoon')
-rw-r--r--databases/typhoon/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/databases/typhoon/Makefile b/databases/typhoon/Makefile
index e05d77c7def9..802610d500c7 100644
--- a/databases/typhoon/Makefile
+++ b/databases/typhoon/Makefile
@@ -3,7 +3,7 @@
# Date created: Wed Dec 11 15:16:19 CST 1996
# Whom: erich@FreeBSD.org
#
-# $Id: Makefile,v 1.4 1998/10/20 01:30:01 steve Exp $
+# $Id: Makefile,v 1.5 1998/10/22 02:30:24 asami Exp $
#
DISTNAME= typhoon-1.10.3
@@ -22,13 +22,15 @@ MAN3=d_close.3 d_crget.3 d_crread.3 d_crset.3 d_dbdpath.3 d_dbfpath.3 \
d_recwrite.3 d_setfiles.3
MAN1=ddlp.1
+.include <bsd.port.pre.mk>
+
post-install:
@${MKDIR} ${PREFIX}/share/typhoon
@${INSTALL_DATA} ${WRKSRC}/man/manual.asc ${PREFIX}/share/typhoon
@${INSTALL_DATA} ${WRKSRC}/include/environ.h ${WRKSRC}/include/typhoon.h ${PREFIX}/include
- @if [ ${PORTOBJFORMAT} = "aout" ]; then \
- ${LN} -sf libtyphoon.so.1.10 ${PREFIX}/lib/libtyphoon.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libtyphoon.so.1.10 ${PREFIX}/lib/libtyphoon.so
+.endif
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>