aboutsummaryrefslogtreecommitdiffstats
path: root/databases/unixODBC
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-16 22:01:40 +0800
committerkrion <krion@FreeBSD.org>2004-01-16 22:01:40 +0800
commit7b2bce80cbe22cf780225d759a03b053329c463b (patch)
tree607395b1a20f03c8cb919bc3a337d13dcd490396 /databases/unixODBC
parentc1a7ba823a0a17247beeb35a45020f6bf67e9898 (diff)
downloadfreebsd-ports-gnome-7b2bce80cbe22cf780225d759a03b053329c463b.tar.gz
freebsd-ports-gnome-7b2bce80cbe22cf780225d759a03b053329c463b.tar.zst
freebsd-ports-gnome-7b2bce80cbe22cf780225d759a03b053329c463b.zip
- Fix a bug in 2.2.7 that will send a statement to the
incorrect state if SQLMoreResults is used PR: 61421 Submitted by: Ports Fury
Diffstat (limited to 'databases/unixODBC')
-rw-r--r--databases/unixODBC/Makefile1
-rw-r--r--databases/unixODBC/files/patch-DataManager::SQLMoreResults.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/databases/unixODBC/Makefile b/databases/unixODBC/Makefile
index a59539378cf6..91f4dcbd281e 100644
--- a/databases/unixODBC/Makefile
+++ b/databases/unixODBC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unixODBC
PORTVERSION= 2.2.7
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.unixodbc.org/
diff --git a/databases/unixODBC/files/patch-DataManager::SQLMoreResults.c b/databases/unixODBC/files/patch-DataManager::SQLMoreResults.c
new file mode 100644
index 000000000000..cba763bd0d9d
--- /dev/null
+++ b/databases/unixODBC/files/patch-DataManager::SQLMoreResults.c
@@ -0,0 +1,11 @@
+--- DriverManager/SQLMoreResults.c.orig Fri Oct 31 03:20:46 2003
++++ DriverManager/SQLMoreResults.c Tue Jan 13 23:25:00 2004
+@@ -262,7 +262,7 @@
+ * We don't know for sure
+ */
+ statement -> hascols = 0;
+- statement -> state = STATE_S4;
++ statement -> state = STATE_S5;
+ #endif
+ }
+ else if ( ret == SQL_STILL_EXECUTING )