aboutsummaryrefslogtreecommitdiffstats
path: root/databases/virtuoso
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2012-06-14 19:55:53 +0800
committerfjoe <fjoe@FreeBSD.org>2012-06-14 19:55:53 +0800
commit2a8a6c0f63c150a7c2d5668a83d2f519f9997050 (patch)
treebd3fbd679f88486ef69503758a43793b7ff95b0e /databases/virtuoso
parent48ece88dbc4acb24f70e95dd1f03da092a458b23 (diff)
downloadfreebsd-ports-gnome-2a8a6c0f63c150a7c2d5668a83d2f519f9997050.tar.gz
freebsd-ports-gnome-2a8a6c0f63c150a7c2d5668a83d2f519f9997050.tar.zst
freebsd-ports-gnome-2a8a6c0f63c150a7c2d5668a83d2f519f9997050.zip
- Use flex and gperf from ports [1]
flex and gperf from base system are too old for Virtuoso build. While pre-generated sources (included into the dist tarball) are usually used during virtuoso port build, flex/gperf can potentially be called when those source files become out of date (e.g. when some prerequisites are patched by ports patches that could be potentially included in future). - Fix clang build: use -std=gnu89 as virtuoso relies on GNU89 definition of `inline' Submitted by: Patrick van Kleef [1]
Diffstat (limited to 'databases/virtuoso')
-rw-r--r--databases/virtuoso/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index ce9db43c4ac6..359ae9ddba2d 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -19,7 +19,9 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk\
- htmldoc:${PORTSDIR}/textproc/htmldoc
+ htmldoc:${PORTSDIR}/textproc/htmldoc\
+ flex>2.5.4:${PORTSDIR}/textproc/flex\
+ gperf>=3.0.3:${PORTSDIR}/devel/gperf
LIB_DEPENDS= iodbc.3:${PORTSDIR}/databases/libiodbc\
xml2.5:${PORTSDIR}/textproc/libxml2
@@ -33,8 +35,9 @@ CONFIGURE_ARGS= --with-readline\
--with-layout=freebsd\
--datadir="${PREFIX}"\
--localstatedir="${PREFIX}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -std=gnu89 -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ENV= PATH=${LOCALBASE}/bin:${PATH}
USE_RC_SUBR= virtuoso.sh
ONLY_FOR_ARCHS= i386 amd64
USERS= virtuoso