aboutsummaryrefslogtreecommitdiffstats
path: root/databases/virtuoso
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-02-10 12:08:18 +0800
committerfjoe <fjoe@FreeBSD.org>2010-02-10 12:08:18 +0800
commit7fb9b10a24cbcb69663b831e601aa227a4c87779 (patch)
tree7af38ea3c4d59a034e6b687d98af1f1b762acb32 /databases/virtuoso
parenta78bbee1202ece3d86dd98de29a993407bff3888 (diff)
downloadfreebsd-ports-gnome-7fb9b10a24cbcb69663b831e601aa227a4c87779.tar.gz
freebsd-ports-gnome-7fb9b10a24cbcb69663b831e601aa227a4c87779.tar.zst
freebsd-ports-gnome-7fb9b10a24cbcb69663b831e601aa227a4c87779.zip
Due to mistake in virtuoso startup scripts the following error can happen
during the build: expr: illegal option -- N usage: expr [-e] expression where N is any decimal number, because some variables used in "expr" invocations can be negative integers. Protect against this error (although the workaround does not fix the root of this problem).
Diffstat (limited to 'databases/virtuoso')
-rw-r--r--databases/virtuoso/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 44c1d343019b..1e2601864a59 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -54,7 +54,8 @@ post-patch:
${WRKSRC}/configure
${FIND} ${WRKSRC} -name '*.sh' | ${XARGS} ${GREP} -l 'netstat -an.*grep LISTEN' |\
${XARGS} ${REINPLACE_CMD}\
- -e 's,netstat -an.*grep.*$$\([a-zA-Z0-9]*\).*grep LISTEN,${CHECK_PORT},'
+ -e 's,expr \$$,expr -- $$,'\
+ -e 's,netstat -an.*grep.*$$\([a-zA-Z0-9]*\).*grep LISTEN,${CHECK_PORT},'
.include <bsd.port.pre.mk>