aboutsummaryrefslogtreecommitdiffstats
path: root/databases/zodb/Makefile
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-02-05 18:51:19 +0800
committerwjv <wjv@FreeBSD.org>2002-02-05 18:51:19 +0800
commite287cb848045ea1e852f833516fa04a9794e1b95 (patch)
treecab253879aa3f435e1d41cfbbef7f5310a6bef0a /databases/zodb/Makefile
parent584414712cf596ff5721cebb8494ccd6106102c0 (diff)
downloadfreebsd-ports-gnome-e287cb848045ea1e852f833516fa04a9794e1b95.tar.gz
freebsd-ports-gnome-e287cb848045ea1e852f833516fa04a9794e1b95.tar.zst
freebsd-ports-gnome-e287cb848045ea1e852f833516fa04a9794e1b95.zip
- Migrated port from the unofficial 3rd party standalone distribution of ZODB
to the newly merged official StandaloneZODB from Zope Corp.
Diffstat (limited to 'databases/zodb/Makefile')
-rw-r--r--databases/zodb/Makefile31
1 files changed, 11 insertions, 20 deletions
diff --git a/databases/zodb/Makefile b/databases/zodb/Makefile
index 4a8f7d98f01a..3fb39604c248 100644
--- a/databases/zodb/Makefile
+++ b/databases/zodb/Makefile
@@ -6,10 +6,12 @@
#
PORTNAME= zodb
-PORTVERSION= 2001.06.16
+PORTVERSION= 1.0.c1
+PORTEPOCH= 1
CATEGORIES= databases python
-MASTER_SITES= http://amk.ca/files/zodb/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
+MASTER_SITES= http://www.zope.org/Products/StandaloneZODB/
+DISTNAME= StandaloneZODB-${PORTVERSION:C/\.([^.]*)$/\1/}
+EXTRACT_SUFX= .tgz
MAINTAINER= wjv@FreeBSD.org
@@ -17,26 +19,15 @@ BUILD_DEPENDS= ${PYDISTUTILS}
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/bsddb3/__init__.py:${PORTSDIR}/databases/py-bsddb3
USE_PYTHON= yes
-SRCDIRS= zodb-basic ExtensionClass ZODB BTrees
+PYTHON_SETUP= ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
do-build:
-.for dir in ${SRCDIRS}
- @ cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
- setup.py build
-.endfor
+ @ cd ${WRKSRC} && ${PYTHON_SETUP} build
+
+pre-install:
+ @ ${SH} ${PKGREQ} INSTALL
do-install:
-.for dir in ${SRCDIRS}
- @ cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
- setup.py install -c -O1 --prefix=${PREFIX}
-.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${DOCSDIR}
-.for docfile in ACKS CHANGES README TODO
- @ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
-.endfor
-.endif
+ @ cd ${WRKSRC} && ${PYTHON_SETUP} install -c -O1 --prefix=${PREFIX}
.include <bsd.port.mk>