aboutsummaryrefslogtreecommitdiffstats
path: root/databases/zpygresqlda/Makefile
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2000-09-07 21:12:36 +0800
committernbm <nbm@FreeBSD.org>2000-09-07 21:12:36 +0800
commitfed129519e8d922bcf2c89f3b1d8c580af1dc790 (patch)
tree0a734176ddbc0edc56c53c8b00aca44ebeacfcc6 /databases/zpygresqlda/Makefile
parent53adf4e0cf1df78c0c513d871f882acefac431a4 (diff)
downloadfreebsd-ports-gnome-fed129519e8d922bcf2c89f3b1d8c580af1dc790.tar.gz
freebsd-ports-gnome-fed129519e8d922bcf2c89f3b1d8c580af1dc790.tar.zst
freebsd-ports-gnome-fed129519e8d922bcf2c89f3b1d8c580af1dc790.zip
Add ZPyGreSQLDA, a PostgreSQL database adaptor for Zope.
Diffstat (limited to 'databases/zpygresqlda/Makefile')
-rw-r--r--databases/zpygresqlda/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/databases/zpygresqlda/Makefile b/databases/zpygresqlda/Makefile
new file mode 100644
index 000000000000..7a05b1ea7cab
--- /dev/null
+++ b/databases/zpygresqlda/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: ZPyGreSQLDA
+# Date created: 07 Sep 2000
+# Whom: makeport.pl
+#
+# $FreeBSD$
+#
+
+PORTNAME= zpygresqlda
+PORTVERSION= 0.3.2
+CATEGORIES= databases
+MASTER_SITES= http://www.zope.org/Members/reedstrm/ZPyGreSQLDA-rjr/
+DISTNAME= ZPyGreSQLDA-0.3-rjr2
+
+MAINTAINER= nbm@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+
+# You can change this in the environment
+SZOPEBASEDIR?= www/Zope
+
+# Don't change these
+ZOPEBASEDIR= ${PREFIX}/${SZOPEBASEDIR}
+ZOPEPRODUCTNAME= ZPyGreSQLDA
+ZOPEPRODUCTDIR= lib/python/Products
+
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+
+PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
+
+do-build:
+ @${ECHO} '*shared*' > ${WRKSRC}/src/Setup
+ @${ECHO} '' >> ${WRKSRC}/src/Setup
+ @${ECHO} '_pg pgmodule.c ' \
+ '-I${LOCALBASE}/pgsql/include ' \
+ '-L${LOCALBASE}/pgsql/lib ' \
+ '-lpq -lcrypt' >> ${WRKSRC}/src/Setup
+ @(cd ${WRKSRC}/src && \
+ make -f Makefile.pre.in boot && \
+ make )
+ @${CP} ${WRKSRC}/src/_pgmodule.so ${WRKSRC}/
+
+do-install:
+ @${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}/
+ @${CP} -Rf ${WRKSRC}/* \
+ ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}/
+
+.include <bsd.port.mk>