aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-10-08 05:24:58 +0800
committerpav <pav@FreeBSD.org>2005-10-08 05:24:58 +0800
commit0f0f7a1bb464fcd0fb9061b223d5a6d393848002 (patch)
tree736ad8a4797b28d378628cb187f5881286d63c0e /databases
parentb83b3cece998dc4d6dea865a293538a6394b207e (diff)
downloadfreebsd-ports-gnome-0f0f7a1bb464fcd0fb9061b223d5a6d393848002.tar.gz
freebsd-ports-gnome-0f0f7a1bb464fcd0fb9061b223d5a6d393848002.tar.zst
freebsd-ports-gnome-0f0f7a1bb464fcd0fb9061b223d5a6d393848002.zip
This extension provides an ODBC v3 driver for PDO. It supports unixODBC
and IBM DB2 libraries, and will support more in future releases. PR: ports/86903 Submitted by: Alexander Zhuravlev <zaa@ulstu.ru>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pecl-PDO_ODBC/Makefile32
-rw-r--r--databases/pecl-PDO_ODBC/distinfo2
-rw-r--r--databases/pecl-PDO_ODBC/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 445b5b378640..f7df0388e9ab 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -250,6 +250,7 @@
SUBDIR += pear-MDB_QueryTool
SUBDIR += pecl-PDO
SUBDIR += pecl-PDO_MYSQL
+ SUBDIR += pecl-PDO_ODBC
SUBDIR += pecl-PDO_PGSQL
SUBDIR += pecl-PDO_SQLITE
SUBDIR += pecl-memcache
diff --git a/databases/pecl-PDO_ODBC/Makefile b/databases/pecl-PDO_ODBC/Makefile
new file mode 100644
index 000000000000..d71080747fdc
--- /dev/null
+++ b/databases/pecl-PDO_ODBC/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pecl-PDO_ODBC
+# Date created: 2005-10-03
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PDO_ODBC
+DISTVERSION= 0.9
+CATEGORIES= databases www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= ODBC v3 Interface driver for PDO
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo.so:${PORTSDIR}/databases/pecl-PDO
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= odbc.1:${PORTSDIR}/databases/unixODBC
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+PHP_MODNAME= pdo_odbc
+
+CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.mk>
diff --git a/databases/pecl-PDO_ODBC/distinfo b/databases/pecl-PDO_ODBC/distinfo
new file mode 100644
index 000000000000..12d87e885740
--- /dev/null
+++ b/databases/pecl-PDO_ODBC/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/PDO_ODBC-0.9.tgz) = f4c3251e37457e928df3a668501c5b8d
+SIZE (PECL/PDO_ODBC-0.9.tgz) = 12838
diff --git a/databases/pecl-PDO_ODBC/pkg-descr b/databases/pecl-PDO_ODBC/pkg-descr
new file mode 100644
index 000000000000..29d6969eab13
--- /dev/null
+++ b/databases/pecl-PDO_ODBC/pkg-descr
@@ -0,0 +1,4 @@
+This extension provides an ODBC v3 driver for PDO. It supports unixODBC
+and IBM DB2 libraries, and will support more in future releases.
+
+WWW: http://pecl.php.net/package/PDO_ODBC