aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-04-17 08:57:35 +0800
committerglarkin <glarkin@FreeBSD.org>2010-04-17 08:57:35 +0800
commit2ce55972cc604937d9d6348719e449ef3118dfd4 (patch)
treea9b87433ae66801d68afab4e331164b4a2d21a50 /databases
parent2e5552ce8c4adf1450a69a95843f12a2874fc142 (diff)
downloadfreebsd-ports-gnome-2ce55972cc604937d9d6348719e449ef3118dfd4.tar.gz
freebsd-ports-gnome-2ce55972cc604937d9d6348719e449ef3118dfd4.tar.zst
freebsd-ports-gnome-2ce55972cc604937d9d6348719e449ef3118dfd4.zip
This extension provides an API for communicating with Redis database,
a persistent key-value database with built-in net interface written in ANSI-C for Posix systems. It is a fork of alfonsojimenez's phpredis, adding many methods and fixing a lot of issues. WWW: http://github.com/owlient/phpredis/ PR: ports/145711 Submitted by: Benedikt Niessen <ports at niessen.ch>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php5-redis/Makefile25
-rw-r--r--databases/php5-redis/distinfo3
-rw-r--r--databases/php5-redis/pkg-descr8
4 files changed, 37 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b325b10ec370..2d538f95b584 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -512,6 +512,7 @@
SUBDIR += php5-pdo_sqlite
SUBDIR += php5-pgsql
SUBDIR += php5-propel
+ SUBDIR += php5-redis
SUBDIR += php5-rrdtool
SUBDIR += php5-sqlite
SUBDIR += php5-sybase_ct
diff --git a/databases/php5-redis/Makefile b/databases/php5-redis/Makefile
new file mode 100644
index 000000000000..a89b0548493e
--- /dev/null
+++ b/databases/php5-redis/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: php5-redis
+# Date created: 9 April 2010
+# Whom: Benedikt Niessen <ports@niessen.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= redis
+PORTVERSION= 1.2.0
+CATEGORIES= databases
+MASTER_SITES= http://ports.niessen.ch/ \
+ LOCAL/glarkin
+PKGNAMEPREFIX= php5-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@niessen.ch
+COMMENT= PHP5-Extension for Redis
+
+USE_PHP= yes
+DEFAULT_PHP_VER=5
+USE_PHPEXT= yes
+
+PHP_MODNAME= redis
+
+.include <bsd.port.mk>
diff --git a/databases/php5-redis/distinfo b/databases/php5-redis/distinfo
new file mode 100644
index 000000000000..5a9d3fda5129
--- /dev/null
+++ b/databases/php5-redis/distinfo
@@ -0,0 +1,3 @@
+MD5 (php5-redis-1.2.0.tar.gz) = 27c76eedd1bf8ff486deda2c194d41df
+SHA256 (php5-redis-1.2.0.tar.gz) = 147b792694291af9f70f217cfbfa527907ebe4887c54a8989923a855ee8a3ccf
+SIZE (php5-redis-1.2.0.tar.gz) = 29958
diff --git a/databases/php5-redis/pkg-descr b/databases/php5-redis/pkg-descr
new file mode 100644
index 000000000000..91b752829f6b
--- /dev/null
+++ b/databases/php5-redis/pkg-descr
@@ -0,0 +1,8 @@
+This extension provides an API for communicating with Redis database,
+a persistent key-value database with built-in net interface written
+in ANSI-C for Posix systems.
+
+It is a fork of alfonsojimenez's phpredis, adding many methods and
+fixing a lot of issues.
+
+WWW: http://github.com/owlient/phpredis/