aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2008-12-07 19:54:36 +0800
committerale <ale@FreeBSD.org>2008-12-07 19:54:36 +0800
commit32dcfd80bd4cce5e3893332449cbd46872942c4d (patch)
tree6d66c38223ff470133dd1e25e37def561d06ba26 /databases
parent0223905cb34c313d1482e2e02dc6fd1623e8a010 (diff)
downloadfreebsd-ports-gnome-32dcfd80bd4cce5e3893332449cbd46872942c4d.tar.gz
freebsd-ports-gnome-32dcfd80bd4cce5e3893332449cbd46872942c4d.tar.zst
freebsd-ports-gnome-32dcfd80bd4cce5e3893332449cbd46872942c4d.zip
Update to 5.2.7 release.
Diffstat (limited to 'databases')
-rw-r--r--databases/php5-oci8/files/patch-oci8_lob.c20
-rw-r--r--databases/php5-pdo_pgsql/Makefile1
-rw-r--r--databases/php5-pdo_sqlite/files/patch-sqlite_statement.c50
-rw-r--r--databases/php5-pgsql/Makefile1
4 files changed, 50 insertions, 22 deletions
diff --git a/databases/php5-oci8/files/patch-oci8_lob.c b/databases/php5-oci8/files/patch-oci8_lob.c
deleted file mode 100644
index 113c216e0c8a..000000000000
--- a/databases/php5-oci8/files/patch-oci8_lob.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- oci8_lob.c.orig Sat May 26 09:41:51 2007
-+++ oci8_lob.c Sat May 26 09:45:36 2007
-@@ -301,6 +301,7 @@
- }
-
- if (is_clob) {
-+#ifdef OCI_NLS_CHARSET_MAXBYTESZ
- PHP_OCI_CALL_RETURN(connection->errcode, OCINlsNumericInfoGet, (connection->env, connection->err, &bytes_per_char, OCI_NLS_CHARSET_MAXBYTESZ));
-
- if (connection->errcode != OCI_SUCCESS) {
-@@ -308,6 +309,9 @@
- PHP_OCI_HANDLE_ERROR(connection, connection->errcode);
- return 1;
- }
-+#else
-+ bytes_per_char = 4;
-+#endif
- } else {
- /* BLOBs don't have encoding, so bytes_per_char == 1 */
- }
diff --git a/databases/php5-pdo_pgsql/Makefile b/databases/php5-pdo_pgsql/Makefile
index 4d6461ec100d..f8afb5c012b2 100644
--- a/databases/php5-pdo_pgsql/Makefile
+++ b/databases/php5-pdo_pgsql/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= databases
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/databases/php5-pdo_sqlite/files/patch-sqlite_statement.c b/databases/php5-pdo_sqlite/files/patch-sqlite_statement.c
new file mode 100644
index 000000000000..8785b86ecff0
--- /dev/null
+++ b/databases/php5-pdo_sqlite/files/patch-sqlite_statement.c
@@ -0,0 +1,50 @@
+--- sqlite_statement.c.orig 2007-12-31 08:20:10.000000000 +0100
++++ sqlite_statement.c 2008-12-07 11:50:35.000000000 +0100
+@@ -104,6 +104,21 @@
+ pdo_sqlite_error_stmt(stmt);
+ return 0;
+
++ case PDO_PARAM_INT:
++ case PDO_PARAM_BOOL:
++ if (Z_TYPE_P(param->parameter) == IS_NULL) {
++ if (sqlite3_bind_null(S->stmt, param->paramno + 1) == SQLITE_OK) {
++ return 1;
++ }
++ } else {
++ convert_to_long(param->parameter);
++ if (SQLITE_OK == sqlite3_bind_int(S->stmt, param->paramno + 1, Z_LVAL_P(param->parameter))) {
++ return 1;
++ }
++ }
++ pdo_sqlite_error_stmt(stmt);
++ return 0;
++
+ case PDO_PARAM_LOB:
+ if (Z_TYPE_P(param->parameter) == IS_RESOURCE) {
+ php_stream *stm;
+@@ -117,8 +132,24 @@
+ pdo_raise_impl_error(stmt->dbh, stmt, "HY105", "Expected a stream resource" TSRMLS_CC);
+ return 0;
+ }
++ } else if (Z_TYPE_P(param->parameter) == IS_NULL) {
++ if (sqlite3_bind_null(S->stmt, param->paramno + 1) == SQLITE_OK) {
++ return 1;
++ }
++ pdo_sqlite_error_stmt(stmt);
++ return 0;
++ } else {
++ convert_to_string(param->parameter);
++ }
++
++ if (SQLITE_OK == sqlite3_bind_blob(S->stmt, param->paramno + 1,
++ Z_STRVAL_P(param->parameter),
++ Z_STRLEN_P(param->parameter),
++ SQLITE_STATIC)) {
++ return 1;
+ }
+- /* fall through */
++ pdo_sqlite_error_stmt(stmt);
++ return 0;
+
+ case PDO_PARAM_STR:
+ default:
diff --git a/databases/php5-pgsql/Makefile b/databases/php5-pgsql/Makefile
index 5ace360df491..a34252804bc2 100644
--- a/databases/php5-pgsql/Makefile
+++ b/databases/php5-pgsql/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= databases
MASTERDIR= ${.CURDIR}/../../lang/php5