aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2001-12-01 04:20:14 +0800
committernectar <nectar@FreeBSD.org>2001-12-01 04:20:14 +0800
commit32f15234d1e3c20caf28adfaba54620a6bf38837 (patch)
treed9de15cb0f09770e9db443e3c1ddf88c9c27f78e /databases
parent2cc57528264b298d35399abab70ac08ff58b25d3 (diff)
downloadfreebsd-ports-gnome-32f15234d1e3c20caf28adfaba54620a6bf38837.tar.gz
freebsd-ports-gnome-32f15234d1e3c20caf28adfaba54620a6bf38837.tar.zst
freebsd-ports-gnome-32f15234d1e3c20caf28adfaba54620a6bf38837.zip
The patch for using mx.DateTime instead of DateTime was incomplete.
Update it. Submitted by: Allan Saddi <asaddi@philosw.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/py-PyGreSQL/Makefile2
-rw-r--r--databases/py-PyGreSQL/files/patch-pgdb.py21
2 files changed, 20 insertions, 3 deletions
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 56bb0c33ea81..23af6405acd6 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= PyGreSQL
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases python
MASTER_SITES= ftp://ftp.druid.net/pub/distrib/
PKGNAMEPREFIX= py-
diff --git a/databases/py-PyGreSQL/files/patch-pgdb.py b/databases/py-PyGreSQL/files/patch-pgdb.py
index 6f22a42e8474..8877fefcfcff 100644
--- a/databases/py-PyGreSQL/files/patch-pgdb.py
+++ b/databases/py-PyGreSQL/files/patch-pgdb.py
@@ -1,5 +1,5 @@
---- pgdb.py.orig Thu Oct 11 12:14:35 2001
-+++ pgdb.py Thu Oct 11 12:14:42 2001
+--- pgdb.py.orig Sun Nov 5 20:15:26 2000
++++ pgdb.py Thu Nov 29 17:38:24 2001
@@ -58,7 +58,7 @@
import string
import exceptions
@@ -10,3 +10,20 @@
### module constants
+@@ -384,13 +384,13 @@
+
+ # mandatory type helpers
+ def Date(year, month, day):
+- return DateTime.DateTime(year, month, day)
++ return mx.DateTime.DateTime(year, month, day)
+
+ def Time(hour, minute, second):
+- return DateTime.TimeDelta(hour, minute, second)
++ return mx.DateTime.TimeDelta(hour, minute, second)
+
+ def Timestamp(year, month, day, hour, minute, second):
+- return DateTime.DateTime(year, month, day, hour, minute, second)
++ return mx.DateTime.DateTime(year, month, day, hour, minute, second)
+
+ def DateFromTicks(ticks):
+ return apply(Date, time.localtime(ticks)[:3])