aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-11-15 18:16:20 +0800
committerdinoex <dinoex@FreeBSD.org>2009-11-15 18:16:20 +0800
commit38415d5f08f0da03bfa8d4a4398c6f7f07cce953 (patch)
tree5cac8bb405373f30fd2a7ed1b5d535fe732dd9aa /databases
parent4134169fcf6d3ab13658c12e8fcb2435bf4afb8e (diff)
downloadfreebsd-ports-gnome-38415d5f08f0da03bfa8d4a4398c6f7f07cce953.tar.gz
freebsd-ports-gnome-38415d5f08f0da03bfa8d4a4398c6f7f07cce953.tar.zst
freebsd-ports-gnome-38415d5f08f0da03bfa8d4a4398c6f7f07cce953.zip
- fix search for ruby*postgres
Reported by: Penty Wenngren
Diffstat (limited to 'databases')
-rw-r--r--databases/ruby-dbd_pg/Makefile1
-rw-r--r--databases/ruby-dbd_pg/files/patch-Pg.rb18
2 files changed, 19 insertions, 0 deletions
diff --git a/databases/ruby-dbd_pg/Makefile b/databases/ruby-dbd_pg/Makefile
index 7c4c34ac755d..d9b1971bc631 100644
--- a/databases/ruby-dbd_pg/Makefile
+++ b/databases/ruby-dbd_pg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dbd_pg
PORTVERSION= 0.3.8
+PORTREVISION= 1
CATEGORIES= databases ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= ruby-dbi
diff --git a/databases/ruby-dbd_pg/files/patch-Pg.rb b/databases/ruby-dbd_pg/files/patch-Pg.rb
new file mode 100644
index 000000000000..8a1ab5d650de
--- /dev/null
+++ b/databases/ruby-dbd_pg/files/patch-Pg.rb
@@ -0,0 +1,18 @@
+--- lib/dbd/Pg.rb.orig 2009-07-11 19:07:38.000000000 +0200
++++ lib/dbd/Pg.rb 2009-11-15 10:18:13.000000000 +0100
+@@ -31,13 +31,13 @@
+
+ begin
+ require 'rubygems'
+- gem 'pg'
++ gem 'postgres'
+ gem 'dbi'
+ rescue Exception => e
+ end
+
+ require 'dbi'
+-require 'pg'
++require 'postgres'
+
+ module DBI
+ module DBD