aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-10 00:52:28 +0800
committermiwi <miwi@FreeBSD.org>2008-08-10 00:52:28 +0800
commit4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08 (patch)
treedb3c1cc1231d3aef48831d470847f62ba1858521 /databases
parentd97d7e91b2c078b87375499ca4591297c54f5d50 (diff)
downloadfreebsd-ports-gnome-4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08.tar.gz
freebsd-ports-gnome-4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08.tar.zst
freebsd-ports-gnome-4e715c72d3e6a4f08f2bfb8fa1a1f93600fbca08.zip
The KDE FreeBSD team is proud to announce the release of KDE 4.1.0
for FreeBSD. The official KDE 4.1.0 release notes can be found at http://www.kde.org/announcements/4.1/. Some note: * Prefix KDE4 will be install into a custom prefixes namely ${LOCALBASE}/kde4. KDE4 and KDE3 can co-exist * Sound For sound to work, it is necessary to have dbus and hal enabled in your system. Please see the respective documentation on how to enable these. For more Informations see the HEADS UP at ports@ and kde-freebsd@ or our wiki page http://wiki.freebsd.org/KDE4/Install. Have fun!
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/akonadi/Makefile62
-rw-r--r--databases/akonadi/distinfo3
-rw-r--r--databases/akonadi/pkg-descr25
-rw-r--r--databases/akonadi/pkg-plist41
5 files changed, 132 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3f4182421da8..5a9b1e7b6bc7 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -7,6 +7,7 @@
SUBDIR += adodb
SUBDIR += adodb5
SUBDIR += adstudio
+ SUBDIR += akonadi
SUBDIR += animenfo-client
SUBDIR += animenfo-client-gtk
SUBDIR += aolserver-nsmysql
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
new file mode 100644
index 000000000000..776f47e4ce65
--- /dev/null
+++ b/databases/akonadi/Makefile
@@ -0,0 +1,62 @@
+# New ports collection Makefile for: akonadi
+# Date created: 2008-01-20
+# Whom: miwi
+#
+# $FreeBSD$
+
+PORTNAME= akonadi
+PORTVERSION= 1.0.0
+CATEGORIES= databases kde ipv6
+MASTER_SITES= http://akonadi.omat.nl/
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Storage server for kdepim
+
+BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin \
+ ${LOCALBASE}/bin/mysqld_safe:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+RUN_DEPENDS+= update-mime-database:${PORTSDIR}/misc/shared-mime-info \
+ ${LOCALBASE}/bin/mysqld_safe:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+USE_XORG= x11
+QT_COMPONENTS= corelib network qtestlib moc rcc uic qmake dbus
+USE_MYSQL= yes
+USE_KDE4= kdeprefix kdehier automoc4 sharedmime
+KDE4_BUILDENV= yes
+PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+post-patch:
+#fix finding automoc when PREFIX is not matched KDE4_PREFIX
+ ${REINPLACE_CMD} -e 's|NO_DEFAULT_PATH|${KDE4_PREFIX} NO_DEFAULT_PATH|' \
+ ${WRKSRC}/../cmake/modules/FindAutomoc4.cmake
+ ${REINPLACE_CMD} -e '/akonadi.pc/s|pkgconfig|../libdata/pkgconfig|' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
+ ${CP} ${PATCH_WRKSRC}/server/src/storage/entities-header.xsl \
+ ${PATCH_WRKSRC}/server/src/storage/entitiesKDE4.header.xsl
+ cd ${PATCH_WRKSRC}/server && \
+ ${REINPLACE_CMD} -e 's|entities.h|entitiesKDE4.h|g' \
+ CMakeLists.txt \
+ src/storage/entities.xsl \
+ src/storage/doxygen-preprocess-entities.sh
+# graphics/gd installs entities.h to ${LOCALBASE}/include, rename kde's entities.h to fix build
+.for ext in *.cpp *.h
+ ${FIND} ${PATCH_WRKSRC} -name ${ext} | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|include "entities.h"|include <entitiesKDE4.h>|g' \
+ -e 's|include <entities.h>|include <entitiesKDE4.h>|g'
+.endfor
+ ${REINPLACE_CMD} -e 's| MYSQLD_EXECUTABLE mysqld | MYSQLD_EXECUTABLE mysqld_safe /usr/local/bin |g' \
+ ${PATCH_WRKSRC}/server/CMakeLists.txt
+ #prevent updating mime during build
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/d; /SharedMimeInfo/d' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
+
+post-install:
+ @-update-mime-database ${KDE4_PREFIX}/share/mime
+
+.include <bsd.port.mk>
diff --git a/databases/akonadi/distinfo b/databases/akonadi/distinfo
new file mode 100644
index 000000000000..24eb5a0e0ac2
--- /dev/null
+++ b/databases/akonadi/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/akonadi-1.0.0.tar.bz2) = 90039928f818a55a7e2a1bf852a32f2d
+SHA256 (KDE/akonadi-1.0.0.tar.bz2) = fab1f59019d277ad461acaa866a520350240927c3c526cbfdebe825cc6be55fd
+SIZE (KDE/akonadi-1.0.0.tar.bz2) = 122815
diff --git a/databases/akonadi/pkg-descr b/databases/akonadi/pkg-descr
new file mode 100644
index 000000000000..8fd63775257c
--- /dev/null
+++ b/databases/akonadi/pkg-descr
@@ -0,0 +1,25 @@
+Akonadi - The PIM Storage Service
+
+ * Common PIM data cache
+ o Type agnostic design
+ o Extensible
+ o Generic offline access, change recording and replay
+ o Generic conflict detection and resolution
+ o Resources are groupable by profile
+ o Items composed of independently retrievable multiple parts
+ o Zero-copy retrieval possible
+
+ * Concurrent access allows background activity independent of UI client
+ o Syncing mail, calendar, addressbooks to remote servers
+ o Syncing with mobile devices
+ o Permits semantic desktop infrastructure to access PIM data
+ o Archiving
+ o Indexing
+ o Out-of-process search
+ * Multi-process design
+ o Crash isolation
+ o Large items can't block whole system
+ o Linkage by IPC allows proprietary components
+ o Thin client installations can share components for scalability
+
+WWW: http://pim.kde.org/akonadi/
diff --git a/databases/akonadi/pkg-plist b/databases/akonadi/pkg-plist
new file mode 100644
index 000000000000..34540c408bb6
--- /dev/null
+++ b/databases/akonadi/pkg-plist
@@ -0,0 +1,41 @@
+bin/akonadi_control
+bin/akonadictl
+bin/akonadiserver
+include/akonadi/private/akonadiprotocolinternals_export.h
+include/akonadi/private/imapparser_p.h
+include/akonadi/private/imapset_p.h
+include/akonadi/private/notificationmessage_p.h
+include/akonadi/private/protocol_p.h
+include/akonadi/private/xdgbasedirs_p.h
+lib/libakonadiprivate.so
+lib/libakonadiprivate.so.1
+lib/libakonadiprivate.so.1.0.0
+lib/libakonadiprotocolinternals.so
+lib/libakonadiprotocolinternals.so.1
+lib/libakonadiprotocolinternals.so.1.0.0
+libdata/pkgconfig/akonadi.pc
+share/config/akonadi/mysql-global.conf
+share/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Control.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Status.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.AgentManager.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.ControlManager.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.NotificationManager.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.Resource.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.Search.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.SearchQuery.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.SearchQueryIterator.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.Server.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.Tracer.xml
+share/dbus-1/interfaces/org.freedesktop.Akonadi.TracerNotification.xml
+share/dbus-1/services/org.freedesktop.Akonadi.Control.service
+share/mime/packages/akonadi-mime.xml
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrmtry share/dbus-1/services
+@dirrm share/config/akonadi
+@dirrmtry share/config
+@dirrmtry share/pixmaps
+@dirrm include/akonadi/private
+@dirrm include/akonadi
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true