aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2003-08-20 16:26:23 +0800
committermat <mat@FreeBSD.org>2003-08-20 16:26:23 +0800
commit53a95f370cc8d9b5b6c7ec3f0dd8031f601eb4d9 (patch)
treec2cb24e52bbf6812bc564a7b8be7d6e6bd178ade /databases
parentd15a5aa802745f903935e07d1dc7bb0e537c3596 (diff)
downloadfreebsd-ports-gnome-53a95f370cc8d9b5b6c7ec3f0dd8031f601eb4d9.tar.gz
freebsd-ports-gnome-53a95f370cc8d9b5b6c7ec3f0dd8031f601eb4d9.tar.zst
freebsd-ports-gnome-53a95f370cc8d9b5b6c7ec3f0dd8031f601eb4d9.zip
Add p5-DBIx-Ease 0.07
DBIx::Ease is intended to allow less-code DBI interactions. PR: 54706 Submitted by: mat Approved by: demon (mentor)
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Ease/Makefile25
-rw-r--r--databases/p5-DBIx-Ease/distinfo1
-rw-r--r--databases/p5-DBIx-Ease/pkg-descr11
-rw-r--r--databases/p5-DBIx-Ease/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 86af18aae12b..8cbbd6d4f0ea 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -105,6 +105,7 @@
SUBDIR += p5-DBIx-Browse
SUBDIR += p5-DBIx-DBSchema
SUBDIR += p5-DBIx-DataSource
+ SUBDIR += p5-DBIx-Ease
SUBDIR += p5-DBIx-Password
SUBDIR += p5-DBIx-Recordset
SUBDIR += p5-DBIx-SQLEngine
diff --git a/databases/p5-DBIx-Ease/Makefile b/databases/p5-DBIx-Ease/Makefile
new file mode 100644
index 000000000000..2dae9d006eb2
--- /dev/null
+++ b/databases/p5-DBIx-Ease/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-DBIx-Ease
+# Date created: 21 july 2003
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Ease
+PORTVERSION= 0.07
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Less-code DBI interactions for all drivers
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Ease.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Ease/distinfo b/databases/p5-DBIx-Ease/distinfo
new file mode 100644
index 000000000000..bf9bd24c6d0f
--- /dev/null
+++ b/databases/p5-DBIx-Ease/distinfo
@@ -0,0 +1 @@
+MD5 (DBIx-Ease-0.07.tar.gz) = c25fa1d9dba1f3a3a0da78684f841d44
diff --git a/databases/p5-DBIx-Ease/pkg-descr b/databases/p5-DBIx-Ease/pkg-descr
new file mode 100644
index 000000000000..59786dd7ae77
--- /dev/null
+++ b/databases/p5-DBIx-Ease/pkg-descr
@@ -0,0 +1,11 @@
+DBIx::Ease is intended to allow less-code DBI interactions.
+
+Upon creation of a new DBIx::Ease object you should pass the portion of the DSN
+(Data Source Name) common to all connections the object is supposed to store.
+Replace the variable portions with '<databasename>'. Whenever you wish to make
+only one connection you may enter the complete DSN, also when you want to make
+connections with the same source but as different users, then call exec() with
+different names of your choice as initial argument.
+
+
+WWW: http://search.cpan.org/dist/DBIx-Ease/
diff --git a/databases/p5-DBIx-Ease/pkg-plist b/databases/p5-DBIx-Ease/pkg-plist
new file mode 100644
index 000000000000..9e6b90a5d5e0
--- /dev/null
+++ b/databases/p5-DBIx-Ease/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DBIx/Ease.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Ease/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Ease
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DBIx 2>/dev/null || true