aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2011-12-09 03:46:29 +0800
committerscheidell <scheidell@FreeBSD.org>2011-12-09 03:46:29 +0800
commit5540fdf79c951ecae33df1173d5fa7362c3be7cc (patch)
treeeb1f574e2944abe58f26f685c2e444a80127ff69 /databases
parenta703e7f42bb455a4eb5c70511a946b5c830e11b5 (diff)
downloadfreebsd-ports-gnome-5540fdf79c951ecae33df1173d5fa7362c3be7cc.tar.gz
freebsd-ports-gnome-5540fdf79c951ecae33df1173d5fa7362c3be7cc.tar.zst
freebsd-ports-gnome-5540fdf79c951ecae33df1173d5fa7362c3be7cc.zip
- New port, copy of databases/php5-rrdtool, needed for companies
- stuck on php52 PR: ports/159894 [1] Submitted by: scheidell@secnap.net [1] Approved by: gabor (mentor) Feature safe: yes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php52-rrdtool/Makefile34
-rw-r--r--databases/php52-rrdtool/distinfo2
-rw-r--r--databases/php52-rrdtool/files/patch-config.m455
-rw-r--r--databases/php52-rrdtool/pkg-descr5
5 files changed, 97 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 434220064100..93de992a9ed0 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -593,6 +593,7 @@
SUBDIR += php52-pdo_pgsql
SUBDIR += php52-pdo_sqlite
SUBDIR += php52-pgsql
+ SUBDIR += php52-rrdtool
SUBDIR += php52-sqlite
SUBDIR += php52-sybase_ct
SUBDIR += phpminiadmin
diff --git a/databases/php52-rrdtool/Makefile b/databases/php52-rrdtool/Makefile
new file mode 100644
index 000000000000..932120b3dd97
--- /dev/null
+++ b/databases/php52-rrdtool/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: php5-rrdtool
+# Date created: 27 Nov 2011
+# Whom: scheidell@freebsd.org
+# Credits: rick@wzoeterwoude.net
+#
+# $FreeBSD$
+
+PORTNAME= rrdtool
+PORTVERSION= 1.00
+CATEGORIES= databases
+MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/contrib/ \
+ http://ftp.ntua.gr/pub/net/monitoring/rrdtool/contrib/ \
+ http://www.mirrors.wiretapped.net/security/network-monitoring/rrdtool/contrib/
+PKGNAMEPREFIX= php52-
+DISTNAME= php_rrdtool
+
+MAINTAINER= scheidell@secnap.net
+COMMENT= A php 52 rrdtool glue
+
+LIB_DEPENDS= rrd:${PORTSDIR}/databases/rrdtool
+
+WRKSRC= ${WRKDIR}/rrdtool
+
+USE_PHP= yes
+DEFAULT_PHP_VER=52
+USE_PHPEXT= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not configure on 6.X
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/php52-rrdtool/distinfo b/databases/php52-rrdtool/distinfo
new file mode 100644
index 000000000000..7c2e98e8f52c
--- /dev/null
+++ b/databases/php52-rrdtool/distinfo
@@ -0,0 +1,2 @@
+SHA256 (php_rrdtool.tar.gz) = 922719f2dd8772512339e82856ed4f102b493ef5d34d6cb389eded57c0a1bce4
+SIZE (php_rrdtool.tar.gz) = 9353
diff --git a/databases/php52-rrdtool/files/patch-config.m4 b/databases/php52-rrdtool/files/patch-config.m4
new file mode 100644
index 000000000000..733aa4b443b5
--- /dev/null
+++ b/databases/php52-rrdtool/files/patch-config.m4
@@ -0,0 +1,55 @@
+--- config.m4.orig Wed Nov 30 19:44:51 2005
++++ config.m4 Sun Mar 19 20:48:34 2006
+@@ -13,7 +13,7 @@
+ [ --with-rrdtool[=DIR] Include rrdtool support (requires rrdtool >= 1.0.49).])
+
+ if test "$PHP_RRDTOOL" != "no"; then
+-
++ PHP_NEW_EXTENSION(rrdtool, rrdtool.c, $ext_shared)
+ if test "$PHP_RRDTOOL" != "yes"; then
+ AC_MSG_CHECKING(if rrdtool specified path is valid)
+ if test -r $PHP_RRDTOOL/include/rrd.h && test -f $PHP_RRDTOOL/lib/librrd.$SHLIB_SUFFIX_NAME -o -f $PHP_RRDTOOL/lib/librrd.a; then # path given as parameter
+@@ -51,7 +51,14 @@
+ fi
+ fi
+
+-dnl Finish the setup
++
++ dnl PHP Libaries include
++ AC_DEFINE(HAVE_RRDTOOL,1,[ ])
++ PHP_SUBST(RRDTOOL_SHARED_LIBADD)
++ PHP_ADD_LIBRARY_WITH_PATH(rrd, $RRDTOOL_LIBDIR, RRDTOOL_SHARED_LIBADD)
++ PHP_ADD_INCLUDE($RRDTOOL_INCDIR)
++
++ dnl Finish the setup
+
+ RRD_H_PATH="$RRDTOOL_INCDIR/rrd.h"
+ PHP_RRDTOOL_DIR=$RRDTOOL_DIR
+@@ -59,14 +66,9 @@
+
+ PHP_CHECK_LIBRARY(rrd, rrd_create,
+ [],[
+- PHP_CHECK_LIBRARY(rrd, rrd_create,
+- [],[
+- AC_MSG_ERROR([wrong rrd lib version or lib not found])
+- ],[
+- -L$RRDTOOL_LIBDIR -ldl
+- ])
++ AC_MSG_ERROR([wrong rrd lib version or lib not found])
+ ],[
+- -L$RRDTOOL_LIBDIR -ldl
++ -L$RRDTOOL_LIBDIR
+ ])
+
+ AC_MSG_CHECKING([rrdtool version])
+@@ -87,10 +89,4 @@
+ if test "$ac_cv_rrdversion" = yes; then
+ AC_DEFINE(HAVE_RRD_12X, 1, [Whether you have rrd_verion])
+ fi
+-
+- PHP_ADD_LIBRARY_WITH_PATH(rrd, $RRDTOOL_LIBDIR, RRDTOOL_SHARED_LIBADD)
+-
+- PHP_NEW_EXTENSION(rrdtool, rrdtool.c, $ext_shared)
+- PHP_SUBST(RRDTOOL_SHARED_LIBADD)
+- AC_DEFINE(HAVE_RRDTOOL, 1, [ ])
+ fi
diff --git a/databases/php52-rrdtool/pkg-descr b/databases/php52-rrdtool/pkg-descr
new file mode 100644
index 000000000000..f69073be4841
--- /dev/null
+++ b/databases/php52-rrdtool/pkg-descr
@@ -0,0 +1,5 @@
+Contained herein are bindings to allow you to interface php scripts with RRD
+tool directly via RRD tool's 'librrd' library, thus avoiding the need to use
+system() calls to the rrdtool binary.
+
+WWW: http://oss.oetiker.ch/rrdtool/pub/contrib/php_rrdtool.txt
runner: release maintainershipgahr2018-06-041-1/+1 * - Bump PORTREVISION (editors/lazarus was updated)acm2018-06-031-0/+1 * - Fix stageacm2018-05-311-5/+4 * Mark BROKEN: fails to stageantoine2018-05-311-0/+2 * Update WWWsunpoet2018-05-281-1/+1 * - Moved ports to Uses/lazarus.mkacm2018-05-262-88/+63 * Add PY_FLAVOR to Python module dependencies.mat2018-05-222-2/+2 * Update Krusader to 2.7.0.rakuco2018-05-165-496/+179 * Copy x11-fm/krusader2 to x11-fm/krusader-kde4.rakuco2018-05-167-0/+778 * Update WWW in pkg-descrrakuco2018-05-151-1/+1 * Update KDE Applications to 18.04.1tcberner2018-05-112-6/+6 * - Update WWWamdmi32018-04-301-1/+1 * Update KDE Applications to 18.04.0tcberner2018-04-293-7/+7 * Update grahics/exiv2 to 0.26tcberner2018-04-281-1/+1 * Updating MATE ports to and patch for MATE 1.20ericbsd2018-04-144-30/+10 * New ports: x11-fm/dolphin, x11-fm/konquerortcberner2018-04-109-0/+1747 * - Update Thunar to 1.6.15madpilot2018-04-073-7/+6 * www/webkit2-gtk3: Update to 2.20.0tobik2018-04-061-0/+1 * - Migrate Mk/bsd.fpc.mk to Mk/Uses/fpc.mkacm2018-04-051-1/+1 * Make libgnome and libgnomeui not implying esound dependencybapt2018-03-261-0/+1 * Fix build on ppc64 by specifying what is needed from the compiler.brd2018-03-261-1/+2 * portmaster@bsdforge.com takes maintainership of 3 ports.yuri2018-03-211-1/+1 * - Update to 1.8.1danilo2018-03-123-15/+6 * Marco Beishuizen <mbeis@xs4all.nl> takes maintainership of 3 portsyuri2018-03-031-1/+1 * Add patches to thunar from upstream bug report to mitigate crashmadpilot2018-02-222-0/+28 * Fix build by adding chm to USE_FPCantoine2018-02-221-1/+1 * - Update to 1.8.0danilo2018-02-203-237/+231 * Fix bunch of ports by TundraWare, which share a common set of problemsamdmi32018-02-193-17/+19 * Reduce dependency on the python2 metaportantoine2018-02-191-1/+2 * Update Thunar to 1.6.14madpilot2018-02-172-4/+4 * Rename KDE4 meta portstcberner2018-02-101-1/+1 * - Bump PORTREVISION. Lazarus was updated to 1.8.0acm2018-02-011-1/+2 * - update from 3.13.0 to 3.14.0misha2018-01-033-4/+7 * x11-fm/doublecmd: update to version 0.8.1swills2017-12-314-18/+58 * Change default version of samba from 4.4 to 4.6antoine2017-12-232-2/+2 * - Those ports fail to build with python3antoine2017-12-121-1/+1 * - Those ports fail to build with python3antoine2017-12-121-3/+3 * - Those ports fail to build with python3antoine2017-12-113-5/+5 * Cleanup LIB_DEPENDS on libpngantoine2017-12-011-1/+1 * Convert Python ports to FLAVORS.mat2017-11-301-6/+6 * - Fix LICENSEamdmi32017-11-282-6/+5 * x11-fm/thunar: Update from 1.6.12 to 1.6.13joneum2017-11-272-4/+6 * - update from 3.12.0 to 3.13.0misha2017-11-163-4/+6 * Fix whitespace issues (mixed tab/spaces, alignment) in a few ports.olgeni2017-11-011-10/+10 * x11-fm/pcmanfm{-qt}: whitespace cleanup.olgeni2017-10-312-7/+7 * x11-fm/pcmanfmqt-l10n: Update to 0.12.0swills2017-10-272-2/+3 * x11-fm/pcmanfm-qt: Update to 0.12.0swills2017-10-276-9/+37 * - update from 3.11.0 to 3.12.0misha2017-10-163-5/+6 * * Add post-release patch that reverts the columns autosizing. It makeskwm2017-10-163-12/+25 * Minor MATE 1.18 update.kwm2017-10-152-4/+4 * Remove WANT_GNOME and HAVE_GNOME.mat2017-10-121-1/+0 * Fix LICENCE usage with multiple licence.madpilot2017-10-081-2/+3 * Bump PORTREVISION in ports depending on archivers/libzip.rakuco2017-09-281-1/+1 * x11-fm/filerunner: update to 17.04.01.19gahr2017-09-273-24/+58 * - Update deskutils/xfce4-tumbler to 0.2.0 [1]madpilot2017-09-183-14/+14 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-114-4/+4 * Bump PORTREVISION after recent poppler updateswills2017-08-241-1/+1 * - update from 3.9.0 to 3.11.0misha2017-08-193-4/+5 * Update the mate desktop to 1.18.kwm2017-07-043-40/+38 * Revision bump of all ports with USE_GL after consolidation of mesa-libsrezny2017-05-232-1/+2 * - Fix various stage-qa warnings/errors by declaring missing dependenciesehaupt2017-05-191-3/+7 * - update 3.8.5 to 3.9.0misha2017-05-163-5/+6 * Chase ffmpeg 3.3 update (ABI changes)riggs2017-04-251-1/+1 * - Fix shebangsmiwi2017-04-241-1/+3 * - Fix shebangsmiwi2017-04-211-2/+3 * - Pet portlintamdmi32017-04-103-14/+11 * - Add LICENSEamdmi32017-04-083-7/+12 * Bump PORTREVISIONs for ports depending on the canonical version of GCC andgerald2017-04-014-1/+4 * Take maintainership of x11-fm/krusader2tcberner2017-03-301-1/+1 * Switch default version of samba from 4.3 to 4.4antoine2017-03-262-2/+2 * - Add USES=samba to handle dependency on sambaantoine2017-03-222-4/+5 * Take in olivierd@'s commit bit on his request.rene2017-03-192-2/+2 * - Update to 1.6.3danilo2017-03-022-5/+4 * - Bump PORTREVISION. Lazarus was update to 1.6.4acm2017-03-021-2/+2 * - Bump PORTREVISION. Freepascal was updatedacm2017-02-271-0/+1 * Update to 0.7.8tobik2017-02-252-5/+4 * - Update to 1.6.11olivierd2017-02-156-102/+11 * Update to 0.20.7.vanilla2017-01-312-3/+4 * Reset mva@'s ports, he handed in his ports bit.rene2017-01-231-1/+1 * Reset sanpei@'s ports after 18 months of inactivity.rene2017-01-231-1/+1 * Update WWW: SF redirects to https://sourceforge.net/projects/<PROJECT_NAME>/sunpoet2017-01-211-1/+1 * Add new mirror, it avoids to change value of MASTER_SITES in LXQt related portsolivierd2017-01-151-2/+1 * Update to 0.11.3olivierd2017-01-152-4/+4 * - update from 3.8.4 to 3.8.5misha2017-01-132-6/+10 * Use archivers/libunrar5 for the unrar libraryjhale2017-01-111-1/+2 * Chase update of graphics/poppler (and slaves ports) in revision r430777olivierd2017-01-071-0/+1 * Update to 0.11.2olivierd2017-01-032-2/+2 * Update to 0.5.1olivier2017-01-023-34/+14 * Update to 0.7.7.rakuco2016-12-272-5/+4 * Reset ports per maintainer request.rene2016-12-261-3/+2 * Unbreak fetcholivierd2016-12-241-0/+1 * - Update to 0.11.1olivierd2016-12-234-10/+13 * Update to 0.11.2olivierd2016-12-232-10/+9 * - Update to 1.2.5olivierd2016-12-223-42/+17 * Remove libintl.so.9 compatibility link that was added in r374303 totijl2016-12-095-5/+5 * Remove libtiff.so.4 compatibility links that were added in r374303 totijl2016-12-091-1/+1 * Don't quote {} in find -exec calls.mat2016-12-011-2/+2 * - Bump PORTREVISION. Lazarus was updated to 1.6.2acm2016-11-221-1/+2 * - Fix linker errorolivierd2016-11-201-1/+2 * Add:olivierd2016-11-199-0/+102 * Spell CHOSEN_COMPILER_TYPE correctlyantoine2016-11-131-1/+1 * - Fix build on 9.x by specifying c++ standard requirementsamdmi32016-11-121-1/+1 * x11-fm/doublecmd: update 0.7.5 -> 0.7.6robak2016-11-092-8/+8 * - Update to 1.6.2danilo2016-11-093-9/+17 * Use USES=pathfix where applicable.mat2016-10-211-11/+0 * ${RM} already has -f.mat2016-10-213-4/+4 * - Update to 1.4.9danilo2016-10-022-6/+12 * Update to 3.8.4olivierd2016-09-273-4/+6 * Small and highly customizable twin-panel file manager with support for plugins.olivierd2016-09-206-0/+438 * Update to 0.7.5olivierd2016-09-142-4/+4 * Chase update of Poppler after revision r421386olivierd2016-09-061-1/+1 * - Add 2 patches, which avoid crashes:olivierd2016-08-313-1/+80 * - Update to 0.7.4amdmi32016-08-252-3/+4 * Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks andtcberner2016-08-241-2/+2 * - Pet portlintamdmi32016-08-171-9/+6 * x11-fm/rodent: Fix LIB_DEPENDS broken by r300560 (July 2012)marino2016-08-041-1/+2 * - Update to version 0.7.3pawel2016-07-312-3/+6 * Update to 1.42.madpilot2016-07-292-5/+4 * Update graphics/exiv2 to 0.25.tcberner2016-07-271-0/+1 * When there is a do-install target, do not use a post-install target, domat2016-07-191-1/+1 * Remove expired ports without open PRs:rene2016-07-0512-402/+0 * Reset ports maintained by horia@racoviceanu.com.rakuco2016-06-281-1/+1 * Deprecate ports broken for more than 6 monthsantoine2016-06-041-0/+3 * Remove expired misc/kdehier4 and update all of its consumers to not reference...rene2016-05-261-1/+1 * Remove NLS, DOCS, EXAMPLES and IPV6 from OPTIONS_DEFAULT, they are enabled by...amdmi32016-05-241-1/+1 * Update to 3.8.3olivierd2016-05-232-3/+4 * - Fix trailing whitespace in pkg-messagesamdmi32016-05-191-1/+1 * - Fix trailing whitespace in pkg-descrs, categories [p-x]*amdmi32016-05-195-12/+12 * - No need to specify master site subdirectory when it's the same as defaultamdmi32016-05-181-1/+1 * Do not attempt to create ${STAGEDIR}${DESKTOPDIR}: `share/applications'danfe2016-04-161-3/+1 * - Upgrade to version 1.2.1.0 and thus unbreak; it no longer requires KDEdanfe2016-04-163-25/+31 * Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.mat2016-04-0126-111/+111 * - Update to 0.7.1amdmi32016-03-302-4/+3 * - Update to 1.2.4olivierd2016-03-282-3/+5 * - Fix incorrect df command invocation which makes the port unusableamdmi32016-03-283-4/+15 * - Update to 1.4.8danilo2016-03-193-5/+3 * - Bump PORTREVISION. lazarus was updated to 1.6.0acm2016-03-181-1/+2 * Un-break port, update to upstream version 0.7.0riggs2016-03-146-38/+33 * - patch for main deforaos libraryolivier2016-03-081-0/+1 * Update to 0.5.0 add DOCS and NLS optionsolivier2016-03-034-47/+120 * Update caja to 1.12.4.kwm2016-03-032-3/+3 * - Clarify LICENSEamdmi32016-02-251-9/+9 * Update my email for ports I maintainolivier2016-02-171-2/+2 * - Fix licenseamdmi32016-02-172-5/+7 * - Fix licenseamdmi32016-02-161-5/+5 * - Clarify LICENSEamdmi32016-02-151-6/+6 * The FreeBSD GNOME team proudly presents GNOME 3.18 for FreeBSD.kwm2016-02-156-29/+23 * Update to 3.8.2olivierd2016-02-102-3/+3 * Update caja to 1.12.3.kwm2016-02-012-3/+3 * Update the MATE DE to 1.12.kwm2016-01-252-3/+3 * - Update to 0.20.6 [1]olivierd2016-01-243-8/+7 * Update poppler to 0.40.0. [1]kwm2016-01-221-1/+1 * Upgrade to 1.41.vanilla2016-01-156-1001/+56 * Convert LICENSE= "GPLxx # or later" to "GPLxx+"amdmi32016-01-131-1/+1 * x11-fm/doublecmd: Make less broken, then set BROKENmarino2015-12-221-2/+6 * Fix usage of ${PERL5}.mat2015-12-181-3/+2 * Update to the lastest GNOME 3.16 releases.kwm2015-12-12