aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /databases
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'databases')
-rw-r--r--databases/glom/Makefile6
-rw-r--r--databases/libgdamm/Makefile4
-rw-r--r--databases/libiodbc/Makefile1
-rw-r--r--databases/libzdb/Makefile4
-rw-r--r--databases/vsqlite/Makefile4
5 files changed, 10 insertions, 9 deletions
diff --git a/databases/glom/Makefile b/databases/glom/Makefile
index a00d70c91efc..6c2eb9250b13 100644
--- a/databases/glom/Makefile
+++ b/databases/glom/Makefile
@@ -4,7 +4,7 @@
PORTNAME= glom
PORTVERSION= 1.12.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -29,8 +29,8 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
USE_BZIP2= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- shared-mime-info
+USES= desktop-file-utils gettext gmake libtool:keepla pathfix \
+ pkgconfig shared-mime-info
USE_GNOME= gnomedocutils gnomeprefix pygnomeextras
USE_LDCONFIG= yes
USE_PGSQL= yes
diff --git a/databases/libgdamm/Makefile b/databases/libgdamm/Makefile
index 9b0056b9102a..98c88e305f10 100644
--- a/databases/libgdamm/Makefile
+++ b/databases/libgdamm/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libgdamm
PORTVERSION= 3.99.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,7 +16,7 @@ COMMENT= C++ wrapper for libgda4 library
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
-USES= gmake libtool pathfix pkgconfig
+USES= gmake libtool:keepla pathfix pkgconfig
USE_GNOME= glibmm libgda4
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/databases/libiodbc/Makefile b/databases/libiodbc/Makefile
index 3adedfe3b49a..d5b38b870965 100644
--- a/databases/libiodbc/Makefile
+++ b/databases/libiodbc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libiodbc
PORTVERSION= 3.52.8
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= SF/iodbc/iodbc/${PORTVERSION}
diff --git a/databases/libzdb/Makefile b/databases/libzdb/Makefile
index 51387f2bf88c..e09ee151df30 100644
--- a/databases/libzdb/Makefile
+++ b/databases/libzdb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libzdb
PORTVERSION= 2.11.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://www.tildeslash.com/libzdb/dist/ \
http://www.c-s.li/ports/
@@ -21,7 +21,7 @@ OPTIONS_DEFAULT=MYSQL SQLITE PGSQL
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix
+USES= gmake libtool:keepla pathfix
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/databases/vsqlite/Makefile b/databases/vsqlite/Makefile
index 4dafe5f4b273..cfcce6078b89 100644
--- a/databases/vsqlite/Makefile
+++ b/databases/vsqlite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vsqlite
PORTVERSION= 0.3.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MAINTAINER= kwm@FreeBSD.org
@@ -20,7 +20,7 @@ GH_TAGNAME= 3fa8d32
GH_COMMIT= 3fa8d32
USE_AUTOTOOLS= libtoolize autoconf automake
-USES= compiler:c++0x libtool
+USES= compiler:c++0x libtool:keepla
USE_SQLITE= 3
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include