aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-09 20:22:34 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-09 20:22:34 +0800
commit70d4cd7f38841c720761b98f954fdc3855ff4e45 (patch)
treee0344409aab9b8e98dedeb129d518adac79b7e8d /databases
parent002c56acfb2f2294e401823594a07ec895a6e5b4 (diff)
downloadfreebsd-ports-gnome-70d4cd7f38841c720761b98f954fdc3855ff4e45.tar.gz
freebsd-ports-gnome-70d4cd7f38841c720761b98f954fdc3855ff4e45.tar.zst
freebsd-ports-gnome-70d4cd7f38841c720761b98f954fdc3855ff4e45.zip
- Change PORTDOCS handling: kyotocabinet.idl is now installed to DOCSDIR
- Bump PORTREVISION for package change
Diffstat (limited to 'databases')
-rw-r--r--databases/kyotocabinet/Makefile20
-rw-r--r--databases/kyotocabinet/files/patch-Makefile.in13
-rw-r--r--databases/kyotocabinet/pkg-plist279
3 files changed, 286 insertions, 26 deletions
diff --git a/databases/kyotocabinet/Makefile b/databases/kyotocabinet/Makefile
index 9c4505349ddc..222ee32bf413 100644
--- a/databases/kyotocabinet/Makefile
+++ b/databases/kyotocabinet/Makefile
@@ -7,8 +7,9 @@
PORTNAME= kyotocabinet
PORTVERSION= 1.2.70
+PORTREVISION= 1
CATEGORIES= databases
-MASTER_SITES= http://fallabs.com/kyotocabinet/pkg/ \
+MASTER_SITES= http://fallabs.com/${PORTNAME}/pkg/ \
LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
@@ -34,10 +35,6 @@ PKGMESSAGE= ${FILESDIR}/pkg-message.${ARCH}
.include <bsd.cpu.mk>
.endif
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-
MAN1= kccachetest.1 \
kcdirmgr.1 \
kcdirtest.1 \
@@ -56,15 +53,16 @@ MAN1= kccachetest.1 \
kcutilmgr.1 \
kcutiltest.1
-check: build
- cd ${WRKSRC}; ${MAKE} check
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/DOCDIR/d' ${WRKSRC}/Makefile.in
+.endif
post-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/kyotocabinet.idl ${DATADIR}/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "COPYING ChangeLog doc" ${DOCSDIR}/
+ ${FIND} ${DOCSDIR}/ -type d -exec ${CHMOD} 755 '{}' \;
+ ${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} 444 '{}' \;
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/
.endif
.if exists(${PKGMESSAGE})
@${CAT} ${PKGMESSAGE}
diff --git a/databases/kyotocabinet/files/patch-Makefile.in b/databases/kyotocabinet/files/patch-Makefile.in
deleted file mode 100644
index a209db611add..000000000000
--- a/databases/kyotocabinet/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig 2011-07-05 22:01:53.000000000 +0900
-+++ Makefile.in 2011-08-23 00:40:30.126471262 +0900
-@@ -121,8 +121,8 @@
- cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
- mkdir -p $(DESTDIR)$(MAN1DIR)
- cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
-- mkdir -p $(DESTDIR)$(DOCDIR)
-- cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DOCDIR)
-+ #mkdir -p $(DESTDIR)$(DOCDIR)
-+ #cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DOCDIR)
- mkdir -p $(DESTDIR)$(PCDIR)
- cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
- @printf '\n'
diff --git a/databases/kyotocabinet/pkg-plist b/databases/kyotocabinet/pkg-plist
index 22064449c681..0078387b5093 100644
--- a/databases/kyotocabinet/pkg-plist
+++ b/databases/kyotocabinet/pkg-plist
@@ -39,5 +39,280 @@ lib/libkyotocabinet.so
lib/libkyotocabinet.so.15
lib/libkyotocabinet.so.15.9.0
libdata/pkgconfig/kyotocabinet.pc
-%%DATADIR%%/kyotocabinet.idl
-@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/FOSSEXCEPTION
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/bc_s.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classes.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ArcfourCompressor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ArcfourCompressor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1AtomicInt64-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1AtomicInt64.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1Error-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1Error.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1FileProcessor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1FileProcessor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1Logger-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1Logger.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1MetaTrigger-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1MetaTrigger.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1ProgressChecker-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1BasicDB_1_1ProgressChecker.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CacheDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CacheDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CacheDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CacheDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Comparator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Comparator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Compressor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Compressor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CondMap-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CondMap.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CondVar-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1CondVar.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DB_1_1Visitor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DB_1_1Visitor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DecimalComparator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DecimalComparator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DecimalDescendingComparator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DecimalDescendingComparator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DirDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DirDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DirDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DirDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DirStream-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1DirStream.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1File-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1File.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1HashDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1HashDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1HashDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1HashDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1IndexDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1IndexDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZMA-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZMA.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZMACompressor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZMACompressor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZO-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZO.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZOCompressor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LZOCompressor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LexicalComparator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LexicalComparator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LexicalDescendingComparator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LexicalDescendingComparator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LinkedHashMap-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LinkedHashMap.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LinkedHashMap_1_1Iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1LinkedHashMap_1_1Iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1MapReduce-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1MapReduce.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1MapReduce_1_1ReduceTaskQueue_1_1ReduceTask-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1MapReduce_1_1ReduceTaskQueue_1_1ReduceTask.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1MapReduce_1_1ValueIterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1MapReduce_1_1ValueIterator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Mutex-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Mutex.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PlantDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PlantDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PlantDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PlantDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PolyDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PolyDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PolyDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1PolyDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ProtoDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ProtoDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ProtoDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ProtoDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1RWLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1RWLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Regex-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Regex.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedMutex-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedMutex.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedRWLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedRWLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedSpinLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedSpinLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedSpinRWLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ScopedSpinRWLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedMutex-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedMutex.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedRWLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedRWLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedSpinLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedSpinLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedSpinRWLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SlottedSpinRWLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SpinLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SpinLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SpinRWLock-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1SpinRWLock.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1StashDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1StashDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1StashDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1StashDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TSD-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TSD.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TSDKey-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TSDKey.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TaskQueue-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TaskQueue.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TaskQueue_1_1Task-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TaskQueue_1_1Task.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TextDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TextDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TextDB_1_1Cursor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TextDB_1_1Cursor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Thread-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1Thread.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyArrayList-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyArrayList.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyHashMap-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyHashMap.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Sorter-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1TinyHashMap_1_1Sorter.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ZLIB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ZLIB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ZLIBCompressor-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyotocabinet_1_1ZLIBCompressor.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/closed.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/files.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x62.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x63.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x64.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x65.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x66.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x67.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x68.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6a.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6b.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6c.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6d.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6f.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x70.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x72.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x73.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x74.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x75.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x76.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x77.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x78.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x79.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_enum.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x62.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x63.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x64.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x65.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x66.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x67.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x68.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x69.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6a.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6b.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6c.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6d.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6f.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x70.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x72.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x73.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x74.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x75.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x76.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x77.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x79.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals_type.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/index.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kccachedb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kccommon_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kccompare_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kccompress_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcdb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcdbext_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcdirdb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcfile_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kchashdb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kclangc_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcmap_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcplantdb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcpolydb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcprotodb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcregex_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kctextdb_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcthread_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/kcutil_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacekyotocabinet.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_func.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_type.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/nav_f.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/nav_h.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/open.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCCUR-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCCUR.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCDB-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCDB.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCIDX-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCIDX.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCLIST-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCLIST.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCMAP-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCMAP.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCMAPITER-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCMAPITER.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCMAPSORT-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCMAPSORT.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCREC-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCREC.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCSTR-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structKCSTR.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyotocabinet_1_1File_1_1Status-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyotocabinet_1_1File_1_1Status.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_a.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_b.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_h.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_s.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/api/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/command.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/common.css
+%%PORTDOCS%%%%DOCSDIR%%/doc/icon16.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/index.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/index.ja.html
+%%PORTDOCS%%%%DOCSDIR%%/doc/logo.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/spex.html
+%%PORTDOCS%%%%DOCSDIR%%/kyotocabinet.idl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc/api
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/doc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%