aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-04-27 16:50:46 +0800
committermva <mva@FreeBSD.org>2013-04-27 16:50:46 +0800
commit79452c6dc80b634c3ef9c985a517d911cf038f4a (patch)
tree5b8de344e457d5da2cf746d56e495a2ce03e1d99 /databases
parent6901fd0c6d72632658ac11df799e604b6039ac64 (diff)
downloadfreebsd-ports-gnome-79452c6dc80b634c3ef9c985a517d911cf038f4a.tar.gz
freebsd-ports-gnome-79452c6dc80b634c3ef9c985a517d911cf038f4a.tar.zst
freebsd-ports-gnome-79452c6dc80b634c3ef9c985a517d911cf038f4a.zip
- Convert USE_ICONV=yes to USES=iconv
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig while here Reviewed by: bapt, kwm
Diffstat (limited to 'databases')
-rw-r--r--databases/drizzle/Makefile2
-rw-r--r--databases/freetds-devel/Makefile2
-rw-r--r--databases/freetds/Makefile2
-rw-r--r--databases/grass/Makefile3
-rw-r--r--databases/hk_classes/Makefile3
-rw-r--r--databases/libmongo-client/Makefile3
-rw-r--r--databases/mysql-proxy/Makefile3
-rw-r--r--databases/namazu2/Makefile3
-rw-r--r--databases/postgis/Makefile3
-rw-r--r--databases/postgis20/Makefile2
-rw-r--r--databases/pxlib/Makefile3
-rw-r--r--databases/qdbm/Makefile2
-rw-r--r--databases/ruby-sybct/Makefile2
-rw-r--r--databases/spatialite/Makefile2
-rw-r--r--databases/spatialite_gui/Makefile3
-rw-r--r--databases/unixODBC/Makefile2
16 files changed, 16 insertions, 24 deletions
diff --git a/databases/drizzle/Makefile b/databases/drizzle/Makefile
index 4b6e370fdbd8..fe5c6d27a832 100644
--- a/databases/drizzle/Makefile
+++ b/databases/drizzle/Makefile
@@ -20,7 +20,7 @@ USE_LDCONFIG= ${PREFIX}/lib/drizzle
BROKEN= fails to build
-USE_ICONV= yes
+USES= iconv
.if defined(MAINTAINER_MODE)
UID_FILES+= ../../UIDs
diff --git a/databases/freetds-devel/Makefile b/databases/freetds-devel/Makefile
index 94a815cff016..38a09d0f1bb3 100644
--- a/databases/freetds-devel/Makefile
+++ b/databases/freetds-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= Sybase/Microsoft TDS protocol library
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
TDS_VER?= 5.0
-USE_ICONV= yes
+USES= iconv
USE_GMAKE= yes
GNU_GONFIGURE= yes
USE_AUTOTOOLS= autoconf:env libtool
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 5af74936bc1a..9029df3f0a9c 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -14,7 +14,7 @@ COMMENT= Sybase/Microsoft TDS protocol library
TDS_VER?= 5.0
-USE_ICONV= yes
+USES= iconv
USE_GMAKE= yes
GNU_GONFIGURE= yes
USE_AUTOTOOLS= autoconf:env libtool
diff --git a/databases/grass/Makefile b/databases/grass/Makefile
index 7fe074581afa..5c8ad8086ff6 100644
--- a/databases/grass/Makefile
+++ b/databases/grass/Makefile
@@ -32,8 +32,7 @@ LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal \
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_GMAKE= yes
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
USE_READLINE= yes
USE_PERL5= yes
USE_XORG= sm ice xi x11 xt xmu xext
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index c0e16f4a5def..5c251ce9b079 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -13,9 +13,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
xml2.5:${PORTSDIR}/textproc/libxml2
-USES= pkgconfig gettext
+USES= pkgconfig gettext iconv
USE_BZIP2= yes
-USE_ICONV= yes
USE_PYTHON= yes
CXXFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
diff --git a/databases/libmongo-client/Makefile b/databases/libmongo-client/Makefile
index a26b5616ea97..1d6015db6bb8 100644
--- a/databases/libmongo-client/Makefile
+++ b/databases/libmongo-client/Makefile
@@ -17,9 +17,8 @@ GH_COMMIT= 13cc0ee
USE_AUTOTOOLS= automake autoconf libtool
GNU_CONFIGURE= yes
-USES= pkgconfig gettext
+USES= pkgconfig gettext iconv
USE_GMAKE= yes
-USE_ICONV= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
CONFIGURE_ENV+= PKG_CONFIG_DIR=${LOCALBASE}/libdata/pkgconfig
diff --git a/databases/mysql-proxy/Makefile b/databases/mysql-proxy/Makefile
index 5f874962c0ef..b9cb60e8fba4 100644
--- a/databases/mysql-proxy/Makefile
+++ b/databases/mysql-proxy/Makefile
@@ -22,8 +22,7 @@ CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= PKG_CONFIG_PATH="${LUA_PREFIX}/share/doc/${LUA_SUBDIR}/etc"
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
-USE_ICONV= yes
+USES= pkgconfig iconv
USE_LDCONFIG= yes
USE_LUA= 5.1+
USE_MYSQL= yes
diff --git a/databases/namazu2/Makefile b/databases/namazu2/Makefile
index 75e2ed465682..5eb0363a43fa 100644
--- a/databases/namazu2/Makefile
+++ b/databases/namazu2/Makefile
@@ -18,8 +18,7 @@ BUILD_DEPENDS= p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic
RUN_DEPENDS= p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic
USE_PERL5= yes
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-perl5="${PERL}" \
--with-libintl-prefix=${LOCALBASE} \
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 82e727e21443..73f1016c7216 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -17,11 +17,10 @@ RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
CONFLICTS= postgis-2.*
-USES= bison
+USES= bison iconv
USE_GNOME= libxml2
USE_PGSQL= yes
USE_GMAKE= yes
-USE_ICONV= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
index 1b6c7446722b..5f1d67ab4311 100644
--- a/databases/postgis20/Makefile
+++ b/databases/postgis20/Makefile
@@ -20,7 +20,7 @@ LATEST_LINK= postgis20
USE_GNOME= libxml2
USE_PGSQL= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
diff --git a/databases/pxlib/Makefile b/databases/pxlib/Makefile
index 7ddb617c6fe3..b12ed5b1e65e 100644
--- a/databases/pxlib/Makefile
+++ b/databases/pxlib/Makefile
@@ -14,8 +14,7 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USE_ICONV= yes
-USES= gettext
+USES= gettext iconv
USE_PERL5= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/databases/qdbm/Makefile b/databases/qdbm/Makefile
index 076fba711fed..b30334166730 100644
--- a/databases/qdbm/Makefile
+++ b/databases/qdbm/Makefile
@@ -17,7 +17,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
.if !defined(SLAVEPORT)
-USE_ICONV= yes
+USES+= iconv
CONFIGURE_ARGS= --enable-zlib \
--enable-iconv \
--enable-pthread
diff --git a/databases/ruby-sybct/Makefile b/databases/ruby-sybct/Makefile
index 712f2592e597..beb4c3125abe 100644
--- a/databases/ruby-sybct/Makefile
+++ b/databases/ruby-sybct/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= tds.5:${PORTSDIR}/databases/freetds
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_ICONV= yes
+USES= iconv
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index c832af392de1..a830933a0651 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/lib${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SQLITE= yes
-USE_ICONV= yes
+USES= iconv
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/databases/spatialite_gui/Makefile b/databases/spatialite_gui/Makefile
index be081f423e0a..4804083971fe 100644
--- a/databases/spatialite_gui/Makefile
+++ b/databases/spatialite_gui/Makefile
@@ -22,8 +22,7 @@ USE_WX= 2.8
WANT_UNICODE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_ICONV= yes
-USE_GNOME= pkgconfig
+USES= pkgconfig iconv
CPPFLAGS+= -I${LOCALBASE}/include `${WX_CONFIG} --cppflags`
LDFLAGS+= -L${LOCALBASE}/lib -liconv `${WX_CONFIG} --libs`
CONFIGURE_ARGS+=CFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/databases/unixODBC/Makefile b/databases/unixODBC/Makefile
index c265bbc608c4..58c2509367d6 100644
--- a/databases/unixODBC/Makefile
+++ b/databases/unixODBC/Makefile
@@ -15,7 +15,7 @@ COMMENT= ODBC library suite for Unix
CONFLICTS= libiodbc-[0-9]* virtuoso-*
-USE_ICONV= yes
+USES= iconv
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
--with-libiconv-prefix=${LOCALBASE}