aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2014-09-10 06:18:39 +0800
committerosa <osa@FreeBSD.org>2014-09-10 06:18:39 +0800
commit87be528372dca090319e47fdb606ad1ee501fff6 (patch)
treef063dfffa98ba51dd4b453d0b3307f4575f9b104 /databases
parente23fd3291cd01223e0c2b1cb7aa7c42f7850ad31 (diff)
downloadfreebsd-ports-gnome-87be528372dca090319e47fdb606ad1ee501fff6.tar.gz
freebsd-ports-gnome-87be528372dca090319e47fdb606ad1ee501fff6.tar.zst
freebsd-ports-gnome-87be528372dca090319e47fdb606ad1ee501fff6.zip
Upgrade from 2.8.11 to 2.8.14.
<ChangeLog> --[ Redis 2.8.14 ] Release date: 1 Sep 2014 # UPGRADE URGENCY: HIGH for Lua scripting users, the server could crash because of a bug introduced in Redis 2.8.10, otherwise LOW. LOW for Redis Sentinel. * [FIX] Don't prevent use of shared integers if maxmemory policy is non-LRU. (Salvatore Sanfilippo) * [FIX] Fail SYNC if background save child aborted due to a signal. (Yossi Gottlieb) * [FIX] Different small redis-cli fixes. (Dov Murik, Charsyam, cubicdaiya, Kashif Rasul, Jan-Erik Rediger, Matt Stancliff) * [FIX] AIX compilation fixes. (Siah Lyimo) * [FIX] A number of other smaller issues. * [FIX] Improved SIGINT handling (Matt Stancliff, Salvatore Sanfilippo) * [FIX] Use unsigned types in SDS header to raise limit to 4GB. (Matt Stancliff, Salvatore Sanfilippo) * [FIX] Handle signed/unsigned comparisons with more care around the code. (Salvatore Sanfilippo) * [FIX] Colorized test output fixed to don't change the background color. (Mariano Pérez Rodríguez) * [FIX] More Sentinel IPv6 fixes. (Eiichi Sato) * [FIX] Deny CLIENT command in scripts. (Matt Stancliff) * [FIX] Allow datasets with more than 2 billion of keys, initial work. * [FIX] Fix a Lua scripting crash by storing the length of the static argv when first allocated. (Paddy Byers) * [NEW] Pub/Sub PING. (Salvatore Sanfilippo) * [NEW] Much faster ZUNIONSTORE. (Kyle Hubert, Salvatore Sanfilippo) * [NEW] Faster ll2string() implementation. (Salvatore Sanfilippo) * [NEW] **WARNING, minor API change**: PUBSUB NUMSUB: return type modified to integer. (Matt Stancliff) * [NEW] redis-benchmark support for AUTH. (CharSyam) --[ Redis 2.8.13 ] Release date: 14 Jul 2014 # UPGRADE URGENCY: LOW for Redis and Sentinel, this is a features enhancement release mostly. Since this release introduces the latency monitoring feature, Redis 2.8 users experiencing latency issues are strongly encouraged to upgrade. * [FIX] CLIENT KILL minor backward compatibility fixes. (Salvatore Sanfilippo) * [FIX] Enable HAVE_ATOMIC for PowerPC. (Matt Stancliff) * [FIX] More robust PSYNC and AOF rewrites tests. (Salvatore Sanfilippo) * [FIX] Solaris build fixed. (Matt Stancliff, Salvatore Sanfilippo) * [NEW] The new latency monitoring feature, as documented at http://redis.io/topics/latency-monitor (Salvatore Sanfilippo) * [NEW] The COMMAND command, exposing the Redis command table as an API. (Matt Stancliff) * [NEW] Update used memory with C11 __atomic. (Matt Stancliff) --[ Redis 2.8.12 ] Release date: 23 Jun 2014 # UPGRADE URGENCY: HIGH for Redis, CRITICAL for Sentinel. # WARNING: This release contains a non backward compatible semantical change to Lua script that should affect an almost zero number of users. * [FIX / BREAKS BACKWARD COMPATIBILITY] Using SELECT inside Lua scripts no longer makes the selected DB to be set in the calling client. So Lua can still use SELECT, but the client calling the script will remain set to the original DB. Thix fixes an issue with Redis replication of Lua scripts that called SELECT without reverting the selected DB to the original one. (Salvatore Sanfilippo) * [FIX] Sentinel failover was instalbe if the master was detected as available during the failover (especially during manual failovers) because of an implementation error (lack of checking of SRI_PROMOTED flag). (Salvatore Sanfilippo) * [FIX] Cancel SHUTDOWN if initial AOF is being written. (Matt Stancliff) * [FIX] Sentinel: bind source address for outcoming connections. (Matt Stancliff). * [FIX] Less timing sensitive Sentinel tests. (Salvatore Sanfilippo). * [NEW] redis-cli --intrinsic-latency stopped with SIGINT still reports stats (Matt Stancliff) * [NEW] Sentinels broadcast an HELLO message ASAP after a failover in order to reach a consistent state faster (before it relied for periodic HELLO messages). (Salvatore Sanfilippo). * [NEW] Jemalloc updated to 3.6.0. (Salvatore Sanfilippo) * [NEW] CLIENT LIST speedup. (Salvatore Sanfilippo) * [NEW] CLIENT LIST new unique incremental ID to every client. (Salvatore Sanfilippo) * [NEW] ROLE command added. (Salvatore Sanfilippo) * [NEW] CLIENT KILL new form to kill by client type and ID (see doc at redis.io for more info). (Salvatore Sanfilippo) * [NEW] Sentinel now disconnects clients when instances are reconfigured (see http://redis.io/topics/sentinel-clients). (Salvatore Sanfilippo) * [NEW] Hiredis update to latest version. (Matt Stancliff) </ChangeLog>
Diffstat (limited to 'databases')
-rw-r--r--databases/redis/Makefile7
-rw-r--r--databases/redis/distinfo4
-rw-r--r--databases/redis/files/extra-patch-src-Makefile.lua14
-rw-r--r--databases/redis/files/extra-patch-src-Makefile.luajit14
-rw-r--r--databases/redis/files/patch-deps-Makefile15
-rw-r--r--databases/redis/files/patch-deps-hiredis-Makefile16
-rw-r--r--databases/redis/files/patch-src-Makefile31
7 files changed, 57 insertions, 44 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index dbaeda0a3145..cf3ff5019b3f 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redis
-DISTVERSION= 2.8.11
+DISTVERSION= 2.8.14
CATEGORIES= databases
MASTER_SITES= http://download.redis.io/releases/
@@ -25,13 +25,14 @@ TESTS_DESC= Install lang/tcl for redis unit tests
.if ${PORT_OPTIONS:MLUA}
USES+= lua:51
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-Makefile.lua
-CFLAGS+= -fPIC
-LDFLAGS+= -Wl,-E
.endif
.if ${PORT_OPTIONS:MLUAJIT}
LIB_DEPENDS+= libluajit-5.1.so:${PORTSDIR}/lang/luajit
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-Makefile.luajit
+.endif
+
+.if ${PORT_OPTIONS:MLUA} || ${PORT_OPTIONS:MLUAJIT}
CFLAGS+= -fPIC
LDFLAGS+= -Wl,-E
.endif
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index a3fa23812953..f377c5908bb8 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis-2.8.11.tar.gz) = 60f0310afb29bc3533d57c5805fb6a693eb1dee454a3a2ef51b07317f803f6d6
-SIZE (redis-2.8.11.tar.gz) = 1101257
+SHA256 (redis-2.8.14.tar.gz) = 593e4a882f81913373923389a8d49b39f230d69c9a1be50f883cdbecf7381763
+SIZE (redis-2.8.14.tar.gz) = 1231617
diff --git a/databases/redis/files/extra-patch-src-Makefile.lua b/databases/redis/files/extra-patch-src-Makefile.lua
index ebbc4fb9c8d2..51c7f5bb8aad 100644
--- a/databases/redis/files/extra-patch-src-Makefile.lua
+++ b/databases/redis/files/extra-patch-src-Makefile.lua
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2013-08-13 15:52:22.000000000 +0400
-+++ src/Makefile 2013-08-13 15:54:55.000000000 +0400
+--- src/Makefile.orig 2014-09-10 02:02:41.000000000 +0400
++++ src/Makefile 2014-09-10 02:05:34.000000000 +0400
@@ -15,7 +15,7 @@
release_hdr := $(shell sh -c './mkreleasehdr.sh')
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
@@ -17,8 +17,8 @@
+FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
- DEBUG=-g -ggdb
-@@ -85,6 +85,9 @@
+ #DEBUG=-g -ggdb
+@@ -98,6 +98,9 @@
FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
endif
@@ -28,15 +28,15 @@
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
REDIS_INSTALL=$(QUIET_INSTALL)$(INSTALL)
-@@ -105,6 +108,7 @@
+@@ -118,6 +121,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o migrate.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o
+ REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o migrate.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o hyperloglog.o latency.o sparkline.o
+REDIS_SERVER_OBJ+= lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
REDIS_CLI_NAME=redis-cli
REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
REDIS_BENCHMARK_NAME=redis-benchmark
-@@ -159,7 +163,7 @@
+@@ -172,7 +176,7 @@
# redis-server
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
diff --git a/databases/redis/files/extra-patch-src-Makefile.luajit b/databases/redis/files/extra-patch-src-Makefile.luajit
index a996b6fedfc8..b1737962cdfc 100644
--- a/databases/redis/files/extra-patch-src-Makefile.luajit
+++ b/databases/redis/files/extra-patch-src-Makefile.luajit
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2013-08-13 15:52:22.000000000 +0400
-+++ src/Makefile 2013-08-13 15:54:55.000000000 +0400
+--- src/Makefile.orig 2014-09-10 02:02:41.000000000 +0400
++++ src/Makefile 2014-09-10 02:05:34.000000000 +0400
@@ -15,7 +15,7 @@
release_hdr := $(shell sh -c './mkreleasehdr.sh')
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
@@ -17,8 +17,8 @@
+FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
- DEBUG=-g -ggdb
-@@ -85,6 +85,9 @@
+ #DEBUG=-g -ggdb
+@@ -98,6 +98,9 @@
FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
endif
@@ -28,15 +28,15 @@
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
REDIS_INSTALL=$(QUIET_INSTALL)$(INSTALL)
-@@ -105,6 +108,7 @@
+@@ -118,6 +121,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o migrate.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o
+ REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o migrate.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o hyperloglog.o latency.o sparkline.o
+REDIS_SERVER_OBJ+= lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
REDIS_CLI_NAME=redis-cli
REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
REDIS_BENCHMARK_NAME=redis-benchmark
-@@ -159,7 +163,7 @@
+@@ -172,7 +176,7 @@
# redis-server
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
diff --git a/databases/redis/files/patch-deps-Makefile b/databases/redis/files/patch-deps-Makefile
index 793a03c9bc61..120823e72b03 100644
--- a/databases/redis/files/patch-deps-Makefile
+++ b/databases/redis/files/patch-deps-Makefile
@@ -1,17 +1,20 @@
---- deps/Makefile.orig 2012-07-02 04:18:07.000000000 +0400
-+++ deps/Makefile 2012-07-02 04:18:56.000000000 +0400
-@@ -58,12 +58,12 @@
- LUA_CFLAGS= -D__C99FEATURES__=1
+--- deps/Makefile.orig 2014-09-01 19:00:38.000000000 +0400
++++ deps/Makefile 2014-09-09 05:33:10.000000000 +0400
+@@ -58,7 +58,7 @@
+ LUA_CFLAGS= -D__C99FEATURES__=1
endif
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
+LUA_CFLAGS+= -Wall -DLUA_ANSI $(CFLAGS)
LUA_LDFLAGS+= $(LDFLAGS)
+ # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
+ # challenging to cross-compile lua (and redis). These defines make it easier
+@@ -68,7 +68,7 @@
lua: .make-prerequisites
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
-- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
-+ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
+- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
++ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
.PHONY: lua
diff --git a/databases/redis/files/patch-deps-hiredis-Makefile b/databases/redis/files/patch-deps-hiredis-Makefile
index b0cfcd406885..579a02a9aade 100644
--- a/databases/redis/files/patch-deps-hiredis-Makefile
+++ b/databases/redis/files/patch-deps-hiredis-Makefile
@@ -1,6 +1,6 @@
---- deps/hiredis/Makefile.orig 2012-02-22 17:23:43.000000000 +0400
-+++ deps/hiredis/Makefile 2012-02-24 16:46:44.000000000 +0400
-@@ -12,10 +12,10 @@
+--- deps/hiredis/Makefile.orig 2014-06-27 05:00:12.000000000 +0400
++++ deps/hiredis/Makefile 2014-06-27 05:02:00.000000000 +0400
+@@ -25,10 +25,10 @@
# Fallback to gcc when $CC is not in $PATH.
CC:=$(shell sh -c 'type $(CC) >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
@@ -14,7 +14,7 @@
REAL_LDFLAGS=$(LDFLAGS) $(ARCH)
DYLIBSUFFIX=so
-@@ -34,6 +34,15 @@
+@@ -47,6 +47,15 @@
DYLIB_MAKE_CMD=$(CC) -G -o $(DYLIBNAME) -h $(DYLIB_MINOR_NAME) $(LDFLAGS)
INSTALL= cp -r
endif
@@ -30,12 +30,12 @@
ifeq ($(uname_S),Darwin)
DYLIBSUFFIX=dylib
DYLIB_MINOR_NAME=$(LIBNAME).$(HIREDIS_MAJOR).$(HIREDIS_MINOR).$(DYLIBSUFFIX)
-@@ -104,7 +113,7 @@
+@@ -124,7 +133,7 @@
$(CC) -MM *.c
# Installation related variables and target
-PREFIX?=/usr/local
+PREFIX?=${PREFIX}
- INCLUDE_PATH?=include/hiredis
- LIBRARY_PATH?=lib
- INSTALL_INCLUDE_PATH= $(PREFIX)/$(INCLUDE_PATH)
+ INSTALL_INCLUDE_PATH= $(PREFIX)/include/hiredis
+ INSTALL_LIBRARY_PATH= $(PREFIX)/lib
+
diff --git a/databases/redis/files/patch-src-Makefile b/databases/redis/files/patch-src-Makefile
index 8846533cdd23..c46535e86bd0 100644
--- a/databases/redis/files/patch-src-Makefile
+++ b/databases/redis/files/patch-src-Makefile
@@ -1,7 +1,7 @@
---- src/Makefile.orig 2014-01-14 14:17:43.000000000 +0400
-+++ src/Makefile 2014-01-14 14:19:31.000000000 +0400
+--- src/Makefile.orig 2014-09-01 19:00:38.000000000 +0400
++++ src/Makefile 2014-09-09 05:45:32.000000000 +0400
@@ -22,7 +22,7 @@
- WARN=-Wall
+ WARN=-Wall -W
OPT=$(OPTIMIZATION)
-PREFIX?=/usr/local
@@ -18,14 +18,23 @@
ifeq ($(uname_S),SunOS)
# SunOS
-@@ -63,6 +63,7 @@
--ifeq ($(uname_S),Darwin)
-- # Darwin (nothing to do)
--else
-+ifeq ($(uname_S),FreeBSD)
-+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
-+ FINAL_LDFLAGS= $(LDFLAGS)
+@@ -67,7 +67,10 @@
+ # AIX
+ FINAL_LDFLAGS+= -Wl,-bexpall
+ FINAL_LIBS+= -pthread -lcrypt -lbsd
+-
+else
++ifeq ($(uname_S),FreeBSD)
++ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
++ FINAL_LDFLAGS= $(LDFLAGS)
+ else
# All the other OSes (notably Linux)
FINAL_LDFLAGS+= -rdynamic
- FINAL_LIBS+= -pthread
+@@ -75,6 +78,7 @@
+ endif
+ endif
+ endif
++endif
+ # Include paths to dependencies
+ FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src
+