aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-11-29 05:55:24 +0800
committerclement <clement@FreeBSD.org>2004-11-29 05:55:24 +0800
commit8ca7bd2b3eac7f95b3de927f1d6c3195c2efed00 (patch)
tree53855f6723ed7aafb7af53870a1dc9172cf6802f /databases
parent635d435d9913b581cbff78c6bf423f050abe9f9b (diff)
downloadfreebsd-ports-gnome-8ca7bd2b3eac7f95b3de927f1d6c3195c2efed00.tar.gz
freebsd-ports-gnome-8ca7bd2b3eac7f95b3de927f1d6c3195c2efed00.tar.zst
freebsd-ports-gnome-8ca7bd2b3eac7f95b3de927f1d6c3195c2efed00.zip
Add databases/py-MySQLdb-devel 1.1.7, devel version of py-MySQLdb
PR: ports/73562 Submitted by: Marcus Grando <marcus@corp.grupos.com.br> Repo-copied by: marcus
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-MySQLdb-devel/Makefile35
-rw-r--r--databases/py-MySQLdb-devel/distinfo4
-rw-r--r--databases/py-MySQLdb-devel/files/patch-_mysql.c21
-rw-r--r--databases/py-MySQLdb-devel/pkg-plist3
5 files changed, 35 insertions, 29 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e37d6f8d3a41..b7bca56d6777 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -268,6 +268,7 @@
SUBDIR += pxtools
SUBDIR += py-MySQL
SUBDIR += py-MySQLdb
+ SUBDIR += py-MySQLdb-devel
SUBDIR += py-PyGreSQL
SUBDIR += py-PySQLite
SUBDIR += py-SQLDict
diff --git a/databases/py-MySQLdb-devel/Makefile b/databases/py-MySQLdb-devel/Makefile
index ea9e767dbbb1..4d25eda8a27a 100644
--- a/databases/py-MySQLdb-devel/Makefile
+++ b/databases/py-MySQLdb-devel/Makefile
@@ -6,19 +6,48 @@
#
PORTNAME= py-MySQLdb
-PORTVERSION= 1.0.0
+PORTVERSION= 1.1.7
+PORTREVISION= 0
CATEGORIES= databases python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mysql-python
DISTNAME= MySQL-python-${PORTVERSION}
-MAINTAINER= clement@FreeBSD.org
+MAINTAINER= marcus@corp.grupos.com.br
COMMENT= Access a MySQL database through Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_MYSQL= yes
+CONFLICTS= py-MySQLdb-0.* py-MySQLdb-1.[0,2-9].*
+
+OPTIONS= MYSQLCLIENT_R "Use mysqlclient_r lib" off \
+ MYSQLSSL "Use SSL support" off \
+ MYSQLCRYPTO "Use CRYPTO support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MYSQLCLIENT_R)
+MAKE_ENV+= mysqlclient="mysqlclient_r"
+.else
+MAKE_ENV+= mysqlclient="mysqlclient"
+.endif
+
+.if defined(WITH_MYSQLSSL)
+.if defined(WITH_MYSQLCRYPTO)
+MAKE_ENV+= mysqloptlibs="ssl crypto"
+.else
+MAKE_ENV+= mysqloptlibs="ssl"
+.endif
+.else
+.if defined(WITH_MYSQLCRYPTO)
+MAKE_ENV+= mysqloptlibs="crypto"
+.else
+MAKE_ENV+= mysqloptlibs=""
+.endif
+.endif
+
PORTDOCS= MANIFEST README
.if !defined(NOPORTDOCS)
@@ -29,4 +58,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/py-MySQLdb-devel/distinfo b/databases/py-MySQLdb-devel/distinfo
index aee6b2980af4..6234367b0550 100644
--- a/databases/py-MySQLdb-devel/distinfo
+++ b/databases/py-MySQLdb-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (MySQL-python-1.0.0.tar.gz) = 0f9527a3aa4111802f376cc6816cc7cf
-SIZE (MySQL-python-1.0.0.tar.gz) = 53708
+MD5 (MySQL-python-1.1.7.tar.gz) = 765bdeaeae06567da8713bb49f3c2a40
+SIZE (MySQL-python-1.1.7.tar.gz) = 77941
diff --git a/databases/py-MySQLdb-devel/files/patch-_mysql.c b/databases/py-MySQLdb-devel/files/patch-_mysql.c
deleted file mode 100644
index f5f7121e0259..000000000000
--- a/databases/py-MySQLdb-devel/files/patch-_mysql.c
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: MySQLdb/_mysql.c
-===================================================================
-RCS file: /cvsroot/mysql-python/MySQLdb/_mysql.c,v
-retrieving revision 1.49
-diff -u -r1.49 _mysql.c
---- _mysql.c 7 Jun 2004 03:44:38 -0000 1.49
-+++ _mysql.c 26 Jul 2004 16:58:29 -0000
-@@ -1542,7 +1542,13 @@
- if (!PyArg_ParseTuple(args, "")) return NULL;
- check_connection(self);
- Py_BEGIN_ALLOW_THREADS
-+
-+#if MYSQL_VERSION_ID >= 40103
-+ r = mysql_shutdown(&(self->connection),
-+ SHUTDOWN_DEFAULT);
-+#else
- r = mysql_shutdown(&(self->connection));
-+#endif
- Py_END_ALLOW_THREADS
- if (r) return _mysql_Exception(self);
- Py_INCREF(Py_None);
diff --git a/databases/py-MySQLdb-devel/pkg-plist b/databases/py-MySQLdb-devel/pkg-plist
index 76303cb1df5b..ac609b618e15 100644
--- a/databases/py-MySQLdb-devel/pkg-plist
+++ b/databases/py-MySQLdb-devel/pkg-plist
@@ -1,6 +1,3 @@
-lib/%%PYTHON_VERSION%%/site-packages/CompatMysqldb.py
-lib/%%PYTHON_VERSION%%/site-packages/CompatMysqldb.pyc
-lib/%%PYTHON_VERSION%%/site-packages/CompatMysqldb.pyo
lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/MySQLdb/__init__.pyo