aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-05-16 14:34:32 +0800
committerpi <pi@FreeBSD.org>2016-05-16 14:34:32 +0800
commit96fb9701023a9ae665aec06eb0169abac5794ba9 (patch)
treea3f3b72f5c7442a89029055725a2c2f06dd7a8a8 /databases
parent85fdc7250a88185afc609a5804a3fd3369cdf2b9 (diff)
downloadfreebsd-ports-gnome-96fb9701023a9ae665aec06eb0169abac5794ba9.tar.gz
freebsd-ports-gnome-96fb9701023a9ae665aec06eb0169abac5794ba9.tar.zst
freebsd-ports-gnome-96fb9701023a9ae665aec06eb0169abac5794ba9.zip
databases/mongodb32: use clang from base in 11-CURRENT
Clang has been upgrade to 3.8 in 11-CURRENT, so use it. PR: 208276 Submitted by: Eric Camachat <eric@camachat.org> Approved by: brendan+freebsd@bbqsrc.net (maintainer)
Diffstat (limited to 'databases')
-rw-r--r--databases/mongodb32/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/databases/mongodb32/Makefile b/databases/mongodb32/Makefile
index 4954b0f4481b..7a669a195edf 100644
--- a/databases/mongodb32/Makefile
+++ b/databases/mongodb32/Makefile
@@ -17,18 +17,11 @@ COMMENT= Distributed document-oriented "NoSQL" database
LICENSE= AGPLv3 APACHE20
LICENSE_COMB= multi
-# Bugs when compiled with < Clang 3.7
-# - https://jira.mongodb.org/browse/SERVER-21217
-# - https://jira.mongodb.org/browse/SERVER-22740
-BUILD_DEPENDS= ${LOCALBASE}/bin/clang37:lang/clang37
LIB_DEPENDS= libpcre.so:devel/pcre \
libsnappy.so:archivers/snappy
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}pymongo>=3.0:databases/pymongo
-CPP= ${LOCALBASE}/bin/clang-cpp37
-CC= ${LOCALBASE}/bin/clang37
-CXX= ${LOCALBASE}/bin/clang++37
CHOSEN_COMPILER_TYPE= clang
ONLY_FOR_ARCHS= amd64
@@ -41,10 +34,10 @@ OPTIONS_DEFAULT= SASL SSL
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_MAKE_ARGS= --use-sasl-client
-SSL_USE= openssl=yes
+SSL_USE= yes
SSL_MAKE_ARGS= --ssl
-USES= cpe execinfo python:build scons
+USES= compiler cpe execinfo python:build scons
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
--use-system-pcre --use-system-snappy \
@@ -64,6 +57,15 @@ TEST_TARGET= unittests
# Cannot be built
IGNORE= unsupported on FreeBSD 10.1 or older
.endif
+# Bugs when compiled with < Clang 3.7
+# - https://jira.mongodb.org/browse/SERVER-21217
+# - https://jira.mongodb.org/browse/SERVER-22740
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 37
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang37:${PORTSDIR}/lang/clang37
+CPP= ${LOCALBASE}/bin/clang-cpp37
+CC= ${LOCALBASE}/bin/clang37
+CXX= ${LOCALBASE}/bin/clang++37
+.endif
post-install:
.for f in mongo mongod mongoperf mongos mongosniff