aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-09-21 15:56:43 +0800
committermm <mm@FreeBSD.org>2010-09-21 15:56:43 +0800
commita447d3207d987ddc5b4cb16345ffd07b474aea9c (patch)
tree740d2c4dbf9c6b5d7e0a621cb113b01436081f94 /databases
parent755a0561c300f159d88d880440dc70a9ae0425e2 (diff)
downloadfreebsd-ports-gnome-a447d3207d987ddc5b4cb16345ffd07b474aea9c.tar.gz
freebsd-ports-gnome-a447d3207d987ddc5b4cb16345ffd07b474aea9c.tar.zst
freebsd-ports-gnome-a447d3207d987ddc5b4cb16345ffd07b474aea9c.zip
Change dependency on old p5-Compress-Zlib, p5-IO-Compress-Base,
p5-IO-Compress-Zlib and p5-IO-Compress-Bzip2 modules to p5-IO-Compress. Explicitly depend on p5-IO-Compress only if PERL_LEVEL < 500903 Bump PORTREVISION
Diffstat (limited to 'databases')
-rw-r--r--databases/maatkit/Makefile14
-rw-r--r--databases/p5-Cache-Memcached-Fast/Makefile13
2 files changed, 19 insertions, 8 deletions
diff --git a/databases/maatkit/Makefile b/databases/maatkit/Makefile
index d6b3a3edfd86..33170f707eab 100644
--- a/databases/maatkit/Makefile
+++ b/databases/maatkit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= maatkit
PORTVERSION= 6839
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -15,9 +16,7 @@ COMMENT= Collection of essential command-line utilities for MySQL
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- p5-IO-Compress-Zlib>=2.015:${PORTSDIR}/archivers/p5-IO-Compress-Zlib
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
PERL_CONFIGURE= yes
@@ -54,4 +53,11 @@ MAN1= maatkit.1p \
mk-variable-advisor.1p \
mk-visual-explain.1p
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Cache-Memcached-Fast/Makefile b/databases/p5-Cache-Memcached-Fast/Makefile
index e6d9619972da..d57377308d95 100644
--- a/databases/p5-Cache-Memcached-Fast/Makefile
+++ b/databases/p5-Cache-Memcached-Fast/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Cache-Memcached-Fast
PORTVERSION= 0.19
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,11 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Fast Perl client for memcached, a distributed memory cache daemon
-BUILD_DEPENDS= p5-Compress-Zlib>0:${PORTSDIR}/archivers/p5-Compress-Zlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= 5.8.2+
MAN3= Cache::Memcached::Fast.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>