aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-12-27 04:00:32 +0800
committerpawel <pawel@FreeBSD.org>2011-12-27 04:00:32 +0800
commita486c12176fc683e914b297ac690dfaa6bcd59c5 (patch)
treefaf788df9ffa5af481b619935f9e113f3d4b5d0c /databases
parentcbc5058a438bff9adfd6135368f9c0eb54843042 (diff)
downloadfreebsd-ports-gnome-a486c12176fc683e914b297ac690dfaa6bcd59c5.tar.gz
freebsd-ports-gnome-a486c12176fc683e914b297ac690dfaa6bcd59c5.tar.zst
freebsd-ports-gnome-a486c12176fc683e914b297ac690dfaa6bcd59c5.zip
pg_reorg allows you to reorganize your tables online,
for example, do online vacuum full or cluster. WWW: http://pgfoundry.org/projects/reorg/ PR: ports/160313 Submitted by: alp@sfedu.ru, improvements by rm@
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pg_reorg/Makefile28
-rw-r--r--databases/pg_reorg/distinfo2
-rw-r--r--databases/pg_reorg/pkg-descr4
-rw-r--r--databases/pg_reorg/pkg-plist11
5 files changed, 46 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 1eea07ef85cf..be19332f5b1f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -522,6 +522,7 @@
SUBDIR += pecl-tokyo_tyrant
SUBDIR += percona-toolkit
SUBDIR += pg_filedump
+ SUBDIR += pg_reorg
SUBDIR += pg_rman
SUBDIR += pgaccess
SUBDIR += pgadmin3
diff --git a/databases/pg_reorg/Makefile b/databases/pg_reorg/Makefile
new file mode 100644
index 000000000000..5e46973cf546
--- /dev/null
+++ b/databases/pg_reorg/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pg_reorg
+# Date created: January 15, 2011
+# Whom: alp@sfedu.ru
+# $FreeBSD$
+
+PORTNAME= pg_reorg
+PORTVERSION= 1.1.7
+CATEGORIES= databases
+MASTER_SITES= http://pgfoundry.org/frs/download.php/3104/
+
+MAINTAINER= alp@sfedu.ru
+COMMENT= PostgreSQL utility to reorganize tables
+
+LICENSE= BSD
+
+MAKE_ENV= USE_PGXS=0
+USE_GMAKE= yes
+USE_PGSQL= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR}/)
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/pg_reorg/distinfo b/databases/pg_reorg/distinfo
new file mode 100644
index 000000000000..361060ebc2bc
--- /dev/null
+++ b/databases/pg_reorg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pg_reorg-1.1.7.tar.gz) = 5ca0b75ee3136e85768621e2e9fd1e0969588bffe7ddbeba69b292226bd2cf21
+SIZE (pg_reorg-1.1.7.tar.gz) = 56686
diff --git a/databases/pg_reorg/pkg-descr b/databases/pg_reorg/pkg-descr
new file mode 100644
index 000000000000..d591bac95cc5
--- /dev/null
+++ b/databases/pg_reorg/pkg-descr
@@ -0,0 +1,4 @@
+pg_reorg allows you to reorganize your tables online,
+for example, do online vacuum full or cluster.
+
+WWW: http://pgfoundry.org/projects/reorg/
diff --git a/databases/pg_reorg/pkg-plist b/databases/pg_reorg/pkg-plist
new file mode 100644
index 000000000000..14ca2271f2f9
--- /dev/null
+++ b/databases/pg_reorg/pkg-plist
@@ -0,0 +1,11 @@
+bin/pg_reorg
+lib/postgresql/pg_reorg.so
+share/postgresql/contrib/pg_reorg.sql
+share/postgresql/contrib/uninstall_pg_reorg.sql
+%%PORTDOCS%%%%DOCSDIR%%/index-ja.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/pg_reorg-ja.html
+%%PORTDOCS%%%%DOCSDIR%%/pg_reorg.html
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/postgresql/contrib