aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-07-02 01:06:41 +0800
committerade <ade@FreeBSD.org>2004-07-02 01:06:41 +0800
commitb306cc5dcbefc30382f9f527a93cd80e0908854b (patch)
treecc39079ab42fe134d866eb0cad7648e1cb765ba7 /databases
parentd3dd320adf5a5916ddf9bae7e3a50a66da9764ab (diff)
downloadfreebsd-ports-gnome-b306cc5dcbefc30382f9f527a93cd80e0908854b.tar.gz
freebsd-ports-gnome-b306cc5dcbefc30382f9f527a93cd80e0908854b.tar.zst
freebsd-ports-gnome-b306cc5dcbefc30382f9f527a93cd80e0908854b.zip
Autotools cleanup. Remove autoconf257 (259), automake17 (18), and
libtool14 (13/15). PR: 67768 Submitted by: ade Approved by: 4-exp bento runs (thanks, kris!)
Diffstat (limited to 'databases')
-rw-r--r--databases/dbconnect/Makefile2
-rw-r--r--databases/firebird-devel/Makefile7
-rw-r--r--databases/firebird-devel/files/patch-autogen.sh6
-rw-r--r--databases/freetds-devel/Makefile2
-rw-r--r--databases/freetds-devel/files/patch-aclocal-m411
-rw-r--r--databases/freetds/Makefile2
-rw-r--r--databases/freetds/files/patch-aclocal-m411
-rw-r--r--databases/mysql-administrator/Makefile2
-rw-r--r--databases/pgcluster/Makefile6
9 files changed, 12 insertions, 37 deletions
diff --git a/databases/dbconnect/Makefile b/databases/dbconnect/Makefile
index d8ce695345c0..c1cb4b4e90c9 100644
--- a/databases/dbconnect/Makefile
+++ b/databases/dbconnect/Makefile
@@ -17,7 +17,7 @@ COMMENT= Use C++ object API to allow applications to connect to databases
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 257
+USE_AUTOCONF_VER= 259
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/databases/firebird-devel/Makefile b/databases/firebird-devel/Makefile
index 8a37a1250a7e..fc71d908a6dd 100644
--- a/databases/firebird-devel/Makefile
+++ b/databases/firebird-devel/Makefile
@@ -19,9 +19,9 @@ COMMENT= The open-source InterBase(tm) 6.0 spin-off (Classic version)
USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+WANT_LIBTOOL_VER= 13
GNU_CONFIGURE= yes
-USE_AUTOCONF_VER= 257
+WANT_AUTOCONF_VER= 259
USE_GCC= 3.3
CONFLICTS= firebird-1.*
@@ -52,9 +52,6 @@ pre-everything::
@sleep 10
.endif
-patch-autotools:
- @${DO_NADA}
-
do-configure:
@(cd ${WRKSRC} && ${ENV} CC=${CC} CXX=${CXX} MAKE=${GMAKE} ./autogen.sh --prefix=${PREFIX}/firebird --with-lock-manager --with-editline)
diff --git a/databases/firebird-devel/files/patch-autogen.sh b/databases/firebird-devel/files/patch-autogen.sh
index 509fba8c7bae..4fc68f20e112 100644
--- a/databases/firebird-devel/files/patch-autogen.sh
+++ b/databases/firebird-devel/files/patch-autogen.sh
@@ -5,7 +5,7 @@
DIE=0
-VER=`autoconf --version|grep '^[Aa]utoconf'|sed 's/^[^0-9]*//'`
-+VER=`autoconf257 --version|grep '^[Aa]utoconf'|sed 's/^[^0-9]*//'`
++VER=`autoconf259 --version|grep '^[Aa]utoconf'|sed 's/^[^0-9]*//'`
case "$VER" in
0* | 1\.* | 2\.[0-9] | 2\.[0-9][a-z]* | \
2\.[1-4][0-9] | 2\.5[0-6][a-z]* )
@@ -33,11 +33,11 @@
echo "Running autoheader ..."
-autoheader || exit 1
-+autoheader257 || exit 1
++autoheader259 || exit 1
echo "Running autoconf ..."
-autoconf || exit 1
-+autoconf257 || exit 1
++autoconf259 || exit 1
# If NOCONFIGURE is set, skip the call to configure
if test "x$NOCONFIGURE" = "x"; then
diff --git a/databases/freetds-devel/Makefile b/databases/freetds-devel/Makefile
index 2f946684b883..600fc09ef212 100644
--- a/databases/freetds-devel/Makefile
+++ b/databases/freetds-devel/Makefile
@@ -18,7 +18,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_GONFIGURE= yes
USE_LIBTOOL_VER= 13
-WANT_AUTOCONF_VER= 257
+WANT_AUTOCONF_VER= 259
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-tdsver=5.0
diff --git a/databases/freetds-devel/files/patch-aclocal-m4 b/databases/freetds-devel/files/patch-aclocal-m4
index 4538fd1e29b7..e69de29bb2d1 100644
--- a/databases/freetds-devel/files/patch-aclocal-m4
+++ b/databases/freetds-devel/files/patch-aclocal-m4
@@ -1,11 +0,0 @@
---- aclocal.m4.orig Wed Aug 6 07:55:55 2003
-+++ aclocal.m4 Wed Aug 6 07:56:00 2003
-@@ -441,7 +441,7 @@
- # CC etc. in the Makefile, will ask for an AC_PROG_CC use...
-
-
--AC_PREREQ([2.54])
-+AC_PREREQ([2.53])
-
- # Autoconf 2.50 wants to disallow AM_ names. We explicitly allow
- # the ones we care about.
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 2f946684b883..600fc09ef212 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -18,7 +18,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_GONFIGURE= yes
USE_LIBTOOL_VER= 13
-WANT_AUTOCONF_VER= 257
+WANT_AUTOCONF_VER= 259
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-tdsver=5.0
diff --git a/databases/freetds/files/patch-aclocal-m4 b/databases/freetds/files/patch-aclocal-m4
index 4538fd1e29b7..e69de29bb2d1 100644
--- a/databases/freetds/files/patch-aclocal-m4
+++ b/databases/freetds/files/patch-aclocal-m4
@@ -1,11 +0,0 @@
---- aclocal.m4.orig Wed Aug 6 07:55:55 2003
-+++ aclocal.m4 Wed Aug 6 07:56:00 2003
-@@ -441,7 +441,7 @@
- # CC etc. in the Makefile, will ask for an AC_PROG_CC use...
-
-
--AC_PREREQ([2.54])
-+AC_PREREQ([2.53])
-
- # Autoconf 2.50 wants to disallow AM_ names. We explicitly allow
- # the ones we care about.
diff --git a/databases/mysql-administrator/Makefile b/databases/mysql-administrator/Makefile
index 7ec5508a2c92..6a4f7133b54c 100644
--- a/databases/mysql-administrator/Makefile
+++ b/databases/mysql-administrator/Makefile
@@ -28,7 +28,7 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
WANT_AUTOMAKE_VER= 14
-WANT_AUTOCONF_VER= 257
+WANT_AUTOCONF_VER= 259
CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" \
CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
USE_ICONV= yes
diff --git a/databases/pgcluster/Makefile b/databases/pgcluster/Makefile
index bc1613dd4628..3e68c7f683c3 100644
--- a/databases/pgcluster/Makefile
+++ b/databases/pgcluster/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
WRKSRC?= ${WRKDIR}/postgresql-${BASEPGSQL}
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOCONF_VER= 257
+USE_AUTOCONF_VER= 259
MAKE_FLAGS= # empty
MAKEFILE= # empty
CONFLICTS= postgresql-*
@@ -80,11 +80,11 @@ post-patch:
post-build:
.if !defined(WITHOUT_PGCLUSTER_REPLICATION)
${MAKE} WRKSRC=${WRKSRC}/src/pgcluster/pgrp run-autotools do-configure
- ${MAKE} WRKSRC=${WRKSRC}/src/pgcluster/pgrp AUTOCONF=autoconf257 do-build
+ ${MAKE} WRKSRC=${WRKSRC}/src/pgcluster/pgrp AUTOCONF=${AUTOCONF} do-build
.endif
.if !defined(WITHOUT_PGCLUSTER_LOADBALANCER)
${MAKE} WRKSRC=${WRKSRC}/src/pgcluster/pglb run-autotools do-configure
- ${MAKE} WRKSRC=${WRKSRC}/src/pgcluster/pglb AUTOCONF=autconf257 do-build
+ ${MAKE} WRKSRC=${WRKSRC}/src/pgcluster/pglb AUTOCONF=${AUTOCONF} do-build
.endif
pre-install: