aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-06 21:07:07 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-06 21:07:07 +0800
commitde0bc572bce08d8d9ee410f2131333fff01de746 (patch)
tree387bd29f188c3bef423babe70be84a8310ad058e /databases
parent9f16a4e58a80e0bb4b5a0fff030ff416dba10992 (diff)
downloadfreebsd-ports-gnome-de0bc572bce08d8d9ee410f2131333fff01de746.tar.gz
freebsd-ports-gnome-de0bc572bce08d8d9ee410f2131333fff01de746.tar.zst
freebsd-ports-gnome-de0bc572bce08d8d9ee410f2131333fff01de746.zip
Fix build after iconv conversion on head.
Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'databases')
-rw-r--r--databases/pyspatialite/Makefile14
-rw-r--r--databases/pyspatialite/files/patch-setup.py2
2 files changed, 13 insertions, 3 deletions
diff --git a/databases/pyspatialite/Makefile b/databases/pyspatialite/Makefile
index 819bdf067cfd..51036a6f0a0e 100644
--- a/databases/pyspatialite/Makefile
+++ b/databases/pyspatialite/Makefile
@@ -15,15 +15,25 @@ COMMENT= DB-API 2.0 interface for SQLite 3.x with Spatialite 3.x
LIB_DEPENDS= spatialite:${PORTSDIR}/databases/spatialite
+USES= iconv
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= pyspatialite
AMALGAMATION_NAME= libspatialite-amalgamation-${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+ICONV_APPEND=
+.else
+ICONV_APPEND= ,'iconv'
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|pyspatialite-doc|${DOCSDIR}|g" \
- -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/setup.py
+ -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ -e "s|%%ICONV%%|${ICONV_APPEND}|" ${WRKSRC}/setup.py
@${MV} ${WRKDIR}/${AMALGAMATION_NAME} ${WRKSRC}/amalgamation
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/pyspatialite/files/patch-setup.py b/databases/pyspatialite/files/patch-setup.py
index beb65587af07..6aacefabb73d 100644
--- a/databases/pyspatialite/files/patch-setup.py
+++ b/databases/pyspatialite/files/patch-setup.py
@@ -5,7 +5,7 @@
include_dirs = []
library_dirs = []
-libraries = ['geos','geos_c','proj']
-+libraries = ['geos','geos_c','proj','iconv']
++libraries = ['geos','geos_c','proj'%%ICONV%%]
runtime_library_dirs = []
extra_objects = []
define_macros = []