aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-10-13 09:18:18 +0800
committeredwin <edwin@FreeBSD.org>2005-10-13 09:18:18 +0800
commite51d5515150c8192569811124ecf2be3e46528de (patch)
tree23d92a48b72a2e81925af6e2b688da1d3a2d051d /databases
parenteab4b56629503f1a76c1fb98352eb3e844490063 (diff)
downloadfreebsd-ports-gnome-e51d5515150c8192569811124ecf2be3e46528de.tar.gz
freebsd-ports-gnome-e51d5515150c8192569811124ecf2be3e46528de.tar.zst
freebsd-ports-gnome-e51d5515150c8192569811124ecf2be3e46528de.zip
[new] databases/pecl-PDO_OCI: PHP PDO Oracle OCI8 driver
This is PDO Oracle OCI8 driver for PHP 5. Unlike PDO_ODBC driver which segfaults when used from apache 2.0, it works. Tested with Oracle 9 Database Server. It should work with versions 7, 8 and 10 also. PR: ports/87197 Submitted by: Simun Mikecin <numisemis@yahoo.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pecl-PDO_OCI/Makefile47
-rw-r--r--databases/pecl-PDO_OCI/distinfo2
-rw-r--r--databases/pecl-PDO_OCI/files/patch-config.m411
-rw-r--r--databases/pecl-PDO_OCI/pkg-descr3
5 files changed, 64 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index a6ae426cfc24..361014aa6d6a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -251,6 +251,7 @@
SUBDIR += pecl-PDO
SUBDIR += pecl-PDO_DBLIB
SUBDIR += pecl-PDO_MYSQL
+ SUBDIR += pecl-PDO_OCI
SUBDIR += pecl-PDO_ODBC
SUBDIR += pecl-PDO_PGSQL
SUBDIR += pecl-PDO_SQLITE
diff --git a/databases/pecl-PDO_OCI/Makefile b/databases/pecl-PDO_OCI/Makefile
new file mode 100644
index 000000000000..32844aa48b94
--- /dev/null
+++ b/databases/pecl-PDO_OCI/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: pecl-PDO_OCI
+# Date created: 2005-10-10
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PDO_OCI
+DISTVERSION= 1.0RC1
+CATEGORIES= databases www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Oracle OCI 8 Interface driver for PDO
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo.so:${PORTSDIR}/databases/pecl-PDO
+BUILD_DEPENDS+= ${LOCALBASE}/oracle8-client/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER=5
+PHP_MODNAME= pdo_oci
+
+CONFIGURE_ARGS+= --with-pdo-oci=${LOCALBASE}/oracle8-client
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+PTHREAD_STATIC= /usr/lib/libc_r
+.else
+PTHREAD_STATIC= /usr/lib/libpthread
+.endif
+
+pre-configure:
+ @cd ${WRKSRC}; \
+ for lib in ${LOCALBASE}/oracle8-client/lib/libclntsh ${PTHREAD_STATIC}; do \
+ /usr/bin/ar x $${lib}.a; \
+ done; \
+ /usr/bin/ar rcs liboci8.a *.o
+
+.include <bsd.port.post.mk>
diff --git a/databases/pecl-PDO_OCI/distinfo b/databases/pecl-PDO_OCI/distinfo
new file mode 100644
index 000000000000..12f237f07229
--- /dev/null
+++ b/databases/pecl-PDO_OCI/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/PDO_OCI-1.0RC1.tgz) = 51e937c2eabbefaf3d68abff87e82a6e
+SIZE (PECL/PDO_OCI-1.0RC1.tgz) = 12083
diff --git a/databases/pecl-PDO_OCI/files/patch-config.m4 b/databases/pecl-PDO_OCI/files/patch-config.m4
new file mode 100644
index 000000000000..2f50b5d03e57
--- /dev/null
+++ b/databases/pecl-PDO_OCI/files/patch-config.m4
@@ -0,0 +1,11 @@
+--- config.m4.orig Wed Jul 27 05:48:08 2005
++++ config.m4 Mon Oct 10 10:56:17 2005
+@@ -106,7 +106,7 @@
+ ;;
+
+ 8.1)
+- PHP_ADD_LIBRARY(clntsh, 1, PDO_OCI_SHARED_LIBADD)
++ PHP_ADD_LIBRARY_WITH_PATH(oci8, ., PDO_OCI_SHARED_LIBADD)
+ ;;
+
+ 9.0)
diff --git a/databases/pecl-PDO_OCI/pkg-descr b/databases/pecl-PDO_OCI/pkg-descr
new file mode 100644
index 000000000000..61a4cb86bb8b
--- /dev/null
+++ b/databases/pecl-PDO_OCI/pkg-descr
@@ -0,0 +1,3 @@
+This extension provides an Oracle OCI 8 driver for PDO.
+
+WWW: http://pecl.php.net/package/PDO_OCI