aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-03-18 23:10:46 +0800
committerdemon <demon@FreeBSD.org>2014-03-18 23:10:46 +0800
commite8f9a383c34f69a6baf543f620eedb96446903a3 (patch)
tree9cb32ae4b3ee893aab023276e0f89176b15a0bf2 /databases
parent2a2a3ae9a608250ffc081755873fa339fe1fd05f (diff)
downloadfreebsd-ports-gnome-e8f9a383c34f69a6baf543f620eedb96446903a3.tar.gz
freebsd-ports-gnome-e8f9a383c34f69a6baf543f620eedb96446903a3.tar.zst
freebsd-ports-gnome-e8f9a383c34f69a6baf543f620eedb96446903a3.zip
Fix SSL support.
PR: 187666 Submitted by: Michael Gmelin <freebsd@grem.de>
Diffstat (limited to 'databases')
-rw-r--r--databases/py-MySQLdb/Makefile2
-rw-r--r--databases/py-MySQLdb/files/patch-_mysql.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/databases/py-MySQLdb/Makefile b/databases/py-MySQLdb/Makefile
index 53bcb97b18c5..348c5099d31b 100644
--- a/databases/py-MySQLdb/Makefile
+++ b/databases/py-MySQLdb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= MySQLdb
DISTVERSION= 1.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases python
MASTER_SITES= SF/mysql-python/mysql-python/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/databases/py-MySQLdb/files/patch-_mysql.c b/databases/py-MySQLdb/files/patch-_mysql.c
new file mode 100644
index 000000000000..2f28da8facf4
--- /dev/null
+++ b/databases/py-MySQLdb/files/patch-_mysql.c
@@ -0,0 +1,13 @@
+--- _mysql.c.orig 2014-03-18 19:07:07.000000000 +0400
++++ _mysql.c 2014-03-18 19:07:40.000000000 +0400
+@@ -102,6 +102,10 @@ static int _mysql_server_init_done = 0;
+ #define check_server_init(x) if (!_mysql_server_init_done) _mysql_server_init_done = 1
+ #endif
+
++#if MYSQL_VERSION_ID >= 50500
++#define HAVE_OPENSSL 1
++#endif
++
+ PyObject *
+ _mysql_Exception(_mysql_ConnectionObject *c)
+ {