aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-08 08:45:08 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-08 08:45:08 +0800
commit07d9e093a64a0c7f96ed0775d50e0f818d98fd80 (patch)
tree02dbbd994569afd4c5091886b42b9fc57a56da98 /databases
parent19b5365f6b139c7191946e258da022ec68b68aae (diff)
downloadfreebsd-ports-gnome-07d9e093a64a0c7f96ed0775d50e0f818d98fd80.tar.gz
freebsd-ports-gnome-07d9e093a64a0c7f96ed0775d50e0f818d98fd80.tar.zst
freebsd-ports-gnome-07d9e093a64a0c7f96ed0775d50e0f818d98fd80.zip
Remove support for antique perl.
Hat: portmgr
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-Class-DBI-Loader-Relationship/Makefile11
-rw-r--r--databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm33
-rw-r--r--databases/p5-Search-Namazu/Makefile8
-rw-r--r--databases/p5-Search-Namazu/files/extrapatch-Namazu.xs18
4 files changed, 2 insertions, 68 deletions
diff --git a/databases/p5-Class-DBI-Loader-Relationship/Makefile b/databases/p5-Class-DBI-Loader-Relationship/Makefile
index a2ca90f32aa4..e3dd0e75f13f 100644
--- a/databases/p5-Class-DBI-Loader-Relationship/Makefile
+++ b/databases/p5-Class-DBI-Loader-Relationship/Makefile
@@ -22,13 +22,4 @@ PERL_CONFIGURE= yes
MAN3= Class::DBI::Loader::Relationship.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${PATCHDIR}/500503-Relationship.pm
-
-post-configure:
- ${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm b/databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm
deleted file mode 100644
index 8d39fa246dea..000000000000
--- a/databases/p5-Class-DBI-Loader-Relationship/files/500503-Relationship.pm
+++ /dev/null
@@ -1,33 +0,0 @@
---- Relationship.pm.orig Wed Nov 9 02:28:38 2005
-+++ Relationship.pm Wed Nov 9 14:27:27 2005
-@@ -1,9 +1,8 @@
- package Class::DBI::Loader::Relationship;
--use 5.006;
- use strict;
--use warnings;
--our $VERSION = '1.3';
--our $DEBUG = 0;
-+use vars qw($VERSION $DEBUG);
-+$VERSION = '1.3';
-+$DEBUG = 0;
-
- 1;
-
-@@ -96,7 +95,7 @@
- "$via_c->has_a(".to_S($to)." => $to_c)\n".
- "$from_c->$method($mapper => [ $via_c => ".to_S($to)." ])\n".
- "$to_c->has_many(".to_PL($from)." => [ $via_c => ".to_S($from)." ])\n"
-- if $DEBUG;
-+ if $Class::DBI::Loader::Relationship::DEBUG;
-
- $via_c->has_a(to_S($from) => $from_c);
- $via_c->has_a(to_S($to) => $to_c);
-@@ -106,7 +105,7 @@
- }
- return "$from_c->$method($mapper => $to_c);\n".
- ($method ne "has_a" && "$to_c->has_a(".to_S($from)." => $from_c);\n")
-- if $DEBUG;
-+ if $Class::DBI::Loader::Relationship::DEBUG;
- $from_c->$method($mapper => $to_c);
- $to_c->has_a(to_S($from) => $from_c) unless $method eq "has_a";
- }
diff --git a/databases/p5-Search-Namazu/Makefile b/databases/p5-Search-Namazu/Makefile
index f3f562a5010e..7a946024e4db 100644
--- a/databases/p5-Search-Namazu/Makefile
+++ b/databases/p5-Search-Namazu/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= YES
MAN3= Search::Namazu.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Namazu.xs
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-Search-Namazu/files/extrapatch-Namazu.xs b/databases/p5-Search-Namazu/files/extrapatch-Namazu.xs
deleted file mode 100644
index 0675c90f6983..000000000000
--- a/databases/p5-Search-Namazu/files/extrapatch-Namazu.xs
+++ /dev/null
@@ -1,18 +0,0 @@
---- Namazu.xs.orig Fri Jun 2 21:58:37 2006
-+++ Namazu.xs Fri Jun 2 21:59:07 2006
-@@ -46,6 +46,15 @@
- }
- #endif
-
-+/* try to be compatible with older perls */
-+/* SvPV_nolen() macro first defined in 5.005_55 */
-+/* this is slow, not threadsafe, but works */
-+#include "patchlevel.h"
-+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
-+static STRLEN nolen_na;
-+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
-+#endif
-+
- /* for old perl (< 5.004_04?) */
- #if !defined(PL_na) && defined(na)
- #define PL_na na