aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
committeraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
commit0a9e5efb9de6b8811964b263c03b83ec89719f71 (patch)
treeaf6266e338105f6caa968f90afd0c4e98288d6f5 /databases
parent161ee4e405ddee7d6c945754c827684829ef8e90 (diff)
downloadfreebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.gz
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.zst
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBD-InterBase/Makefile10
-rw-r--r--databases/p5-DBIx-Class-TimeStamp/Makefile8
-rw-r--r--databases/p5-DBIx-MySQLSequence/Makefile8
3 files changed, 7 insertions, 19 deletions
diff --git a/databases/p5-DBD-InterBase/Makefile b/databases/p5-DBD-InterBase/Makefile
index d9defc6c670c..bf8ed56cad98 100644
--- a/databases/p5-DBD-InterBase/Makefile
+++ b/databases/p5-DBD-InterBase/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBD::InterBase
-# Date created: 15 Oct 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= DBD-InterBase
PORTVERSION= 0.48
@@ -22,8 +18,8 @@ PERL_CONFIGURE= yes
USE_FIREBIRD= yes
post-patch:
- @${PERL} -pi -e 's,%%IB_BASE%%,${LOCALBASE},g' \
- ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' -e 's|%%IB_BASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/Makefile.PL
MAN3= DBD::InterBase.3
diff --git a/databases/p5-DBIx-Class-TimeStamp/Makefile b/databases/p5-DBIx-Class-TimeStamp/Makefile
index 1cbafe9e5b5c..5df2def9b180 100644
--- a/databases/p5-DBIx-Class-TimeStamp/Makefile
+++ b/databases/p5-DBIx-Class-TimeStamp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBIx-Class-TimeStamp
-# Date created: 28 April 2009
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBIx-Class-TimeStamp
PORTVERSION= 0.14
@@ -30,6 +26,6 @@ PERL_CONFIGURE= yes
MAN3= DBIx::Class::TimeStamp.3
post-patch:
- ${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/auto_install/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-MySQLSequence/Makefile b/databases/p5-DBIx-MySQLSequence/Makefile
index 856ebe5144a6..e9e4557ef3d8 100644
--- a/databases/p5-DBIx-MySQLSequence/Makefile
+++ b/databases/p5-DBIx-MySQLSequence/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-DBIx-MySQLSequence
-# Date created: 18 March 2006
-# Whom: Lars Thegler <lth@FreeBSD.org>
-#
+# Created by: Lars Thegler <lth@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBIx-MySQLSequence
PORTVERSION= 1.04
@@ -27,6 +23,6 @@ PERL_CONFIGURE= yes
MAN3= DBIx::MySQLSequence.3
post-patch:
- @${PERL} -pi -e '$$_="" if m/Test::More/' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '/Test::More/d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>