aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-05-14 14:01:22 +0800
committerpi <pi@FreeBSD.org>2015-05-14 14:01:22 +0800
commit107b0978de232816b93f7d7c00a53182a17fef9c (patch)
treeae53d5fc551a85cdf1cfc6396f8483944ad53caf /databases
parent312168bee505d89e5b1031e3510bb5254e7355ee (diff)
downloadfreebsd-ports-gnome-107b0978de232816b93f7d7c00a53182a17fef9c.tar.gz
freebsd-ports-gnome-107b0978de232816b93f7d7c00a53182a17fef9c.tar.zst
freebsd-ports-gnome-107b0978de232816b93f7d7c00a53182a17fef9c.zip
databases/cego: 2.22.0 -> 2.23.0
- Introduced CegoDatabaseFormater. Since the API has changed (proagation of database formatting methods), this is 2.23.0 Submitted by: Björn Lemke <lemke@lemke-it.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/cego/Makefile6
-rw-r--r--databases/cego/distinfo4
-rw-r--r--databases/cego/pkg-plist101
3 files changed, 101 insertions, 10 deletions
diff --git a/databases/cego/Makefile b/databases/cego/Makefile
index 7597e25b5deb..07dfd9a82935 100644
--- a/databases/cego/Makefile
+++ b/databases/cego/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cego
-PORTVERSION= 2.22.0
+PORTVERSION= 2.23.0
CATEGORIES= databases
MASTER_SITES= http://www.lemke-it.com/
@@ -40,7 +40,7 @@ post-install:
${CP} ${WRKSRC}/samples/rc/cego ${STAGEDIR}${PREFIX}/etc/rc.d/
post-stage:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcego.so.1.0.0
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcgwrap.so.1.0.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcego.so.2.0.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcgwrap.so.2.0.0
.include <bsd.port.mk>
diff --git a/databases/cego/distinfo b/databases/cego/distinfo
index 7cfd8488d2b7..19ea525c182a 100644
--- a/databases/cego/distinfo
+++ b/databases/cego/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cego-2.22.0.tar.gz) = c0d9791aa32dd94fd0bfa684430b7aea6bc0fcc3868c9c01d8d72fec44a6ca1c
-SIZE (cego-2.22.0.tar.gz) = 960368
+SHA256 (cego-2.23.0.tar.gz) = 02303f229da3f13d989522c67008446dd1d95c056a1c432e562f8d3da85cbe24
+SIZE (cego-2.23.0.tar.gz) = 964238
diff --git a/databases/cego/pkg-plist b/databases/cego/pkg-plist
index 75e214401389..64919e6ce9c5 100644
--- a/databases/cego/pkg-plist
+++ b/databases/cego/pkg-plist
@@ -4,37 +4,128 @@ bin/cgblow
bin/cgclt
bin/cglog
etc/rc.d/cego
+include/cego/Cego.h
+include/cego/CegoAVLIndexCursor.h
+include/cego/CegoAVLIndexEntry.h
+include/cego/CegoAVLIndexManager.h
+include/cego/CegoAction.h
+include/cego/CegoAdm.h
+include/cego/CegoAdmAction.h
include/cego/CegoAdmNet.h
include/cego/CegoAdminHandler.h
+include/cego/CegoAdminThread.h
+include/cego/CegoAdminThreadPool.h
+include/cego/CegoAggregation.h
+include/cego/CegoAlterDesc.h
+include/cego/CegoAttrComp.h
+include/cego/CegoAttrCond.h
+include/cego/CegoAttrDesc.h
+include/cego/CegoBTreeCursor.h
+include/cego/CegoBTreeManager.h
+include/cego/CegoBTreeNode.h
+include/cego/CegoBTreeObject.h
+include/cego/CegoBTreeValue.h
+include/cego/CegoBeatConnection.h
+include/cego/CegoBeatThread.h
include/cego/CegoBlob.h
+include/cego/CegoBufferPage.h
+include/cego/CegoBufferPool.h
+include/cego/CegoBufferPoolEntry.h
+include/cego/CegoCaseCond.h
include/cego/CegoCheckObject.h
+include/cego/CegoCheckpoint.h
+include/cego/CegoCondDesc.h
include/cego/CegoContentObject.h
include/cego/CegoDataPointer.h
-include/cego/CegoDataType.h
+include/cego/CegoDatabaseFormater.h
+include/cego/CegoDatabaseManager.h
include/cego/CegoDbHandler.h
+include/cego/CegoDbThread.h
+include/cego/CegoDbThreadPool.h
include/cego/CegoDecodableObject.h
+include/cego/CegoDistCursor.h
+include/cego/CegoDistDbHandler.h
+include/cego/CegoDistManager.h
+include/cego/CegoExpOutStream.h
+include/cego/CegoExpr.h
+include/cego/CegoFactor.h
include/cego/CegoField.h
include/cego/CegoFieldValue.h
+include/cego/CegoFileHandler.h
+include/cego/CegoFunction.h
+include/cego/CegoGroupCursor.h
+include/cego/CegoGroupNode.h
+include/cego/CegoGroupSpace.h
+include/cego/CegoHavingDesc.h
+include/cego/CegoImpInStream.h
+include/cego/CegoJDBCInfo.h
include/cego/CegoJoinObject.h
include/cego/CegoKeyObject.h
+include/cego/CegoLockHandler.h
+include/cego/CegoLogHandler.h
+include/cego/CegoLogManager.h
+include/cego/CegoLogRecord.h
+include/cego/CegoLogThread.h
+include/cego/CegoLogThreadPool.h
+include/cego/CegoMediatorThread.h
include/cego/CegoModule.h
include/cego/CegoNet.h
include/cego/CegoObject.h
+include/cego/CegoObjectCursor.h
+include/cego/CegoObjectManager.h
+include/cego/CegoOrderCursor.h
+include/cego/CegoOrderNode.h
+include/cego/CegoOrderSpace.h
include/cego/CegoOutput.h
+include/cego/CegoPredDesc.h
+include/cego/CegoProcAssignStmt.h
+include/cego/CegoProcBlock.h
+include/cego/CegoProcBlockStmt.h
+include/cego/CegoProcCond.h
+include/cego/CegoProcCursor.h
+include/cego/CegoProcCursorCloseStmt.h
+include/cego/CegoProcCursorCreateStmt.h
+include/cego/CegoProcException.h
+include/cego/CegoProcFetch.h
+include/cego/CegoProcIfStmt.h
+include/cego/CegoProcNoopStmt.h
include/cego/CegoProcObject.h
+include/cego/CegoProcPred.h
+include/cego/CegoProcQueryStmt.h
+include/cego/CegoProcReturnStmt.h
+include/cego/CegoProcStmt.h
include/cego/CegoProcVar.h
+include/cego/CegoProcWhileStmt.h
+include/cego/CegoProcedure.h
+include/cego/CegoQuery.h
+include/cego/CegoQueryException.h
+include/cego/CegoQueryHelper.h
+include/cego/CegoRecoveryManager.h
+include/cego/CegoReturnVar.h
+include/cego/CegoSelect.h
include/cego/CegoSerial.h
+include/cego/CegoSystemObject.h
+include/cego/CegoTableCursor.h
+include/cego/CegoTableDesc.h
+include/cego/CegoTableManager.h
include/cego/CegoTableObject.h
+include/cego/CegoTerm.h
+include/cego/CegoTransactionManager.h
+include/cego/CegoTypeConverter.h
+include/cego/CegoView.h
include/cego/CegoViewObject.h
+include/cego/CegoXMLHelper.h
+include/cego/CegoXMLSpace.h
+include/cego/CegoXPorter.h
include/cego/cgwrap.h
lib/libcego.a
lib/libcego.so
-lib/libcego.so.1
-lib/libcego.so.1.0.0
+lib/libcego.so.2
+lib/libcego.so.2.0.0
lib/libcgwrap.a
lib/libcgwrap.so
-lib/libcgwrap.so.1
-lib/libcgwrap.so.1.0.0
+lib/libcgwrap.so.2
+lib/libcgwrap.so.2.0.0
%%DATADIR%%/cgbackup
%%DATADIR%%/cgmkdb
%%DATADIR%%/cgrecover