aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-07-01 03:28:32 +0800
committerswills <swills@FreeBSD.org>2015-07-01 03:28:32 +0800
commit117ffbf61a1851977c625c4314230ef25451def4 (patch)
tree9201b4ee48ae45b704684001bcce0be352d1d0b5 /databases
parentc46d41adf988432f56f6ab096ed590da76968382 (diff)
downloadfreebsd-ports-gnome-117ffbf61a1851977c625c4314230ef25451def4.tar.gz
freebsd-ports-gnome-117ffbf61a1851977c625c4314230ef25451def4.tar.zst
freebsd-ports-gnome-117ffbf61a1851977c625c4314230ef25451def4.zip
databases/p5-Memcached-libmemcached: update to 1.001801
While here, patch out the bundled libmemcached and use the one from ports
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-Memcached-libmemcached/Makefile23
-rw-r--r--databases/p5-Memcached-libmemcached/distinfo4
-rw-r--r--databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-1029
-rw-r--r--databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-920
-rw-r--r--databases/p5-Memcached-libmemcached/files/patch-src__libmemcached__docs__memslap.pod7
5 files changed, 67 insertions, 16 deletions
diff --git a/databases/p5-Memcached-libmemcached/Makefile b/databases/p5-Memcached-libmemcached/Makefile
index 37e456309b59..743f18061e50 100644
--- a/databases/p5-Memcached-libmemcached/Makefile
+++ b/databases/p5-Memcached-libmemcached/Makefile
@@ -2,22 +2,31 @@
# $FreeBSD$
PORTNAME= Memcached-libmemcached
-PORTVERSION= 0.44.06
-PORTREVISION= 1
+PORTVERSION= 1.001801
CATEGORIES= databases devel perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:TIMB
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= swills@FreeBSD.org
COMMENT= Thin fast full interface to the libmemcached client API
+LIB_DEPENDS= libmemcached.so:${PORTSDIR}/databases/libmemcached
+
USES= perl5
USE_PERL5= configure
USE_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -e '/my $$configure_args/ s|--disable-shared|& --without-memcached --disable-dtrace|' ${WRKSRC}/Makefile.PL
+post-extract:
+ @${RM} -r ${WRKDIR}/src
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD
+.if ${OSVERSION} > 1000000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.PL-10
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.PL-9
+.endif
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Memcached-libmemcached/distinfo b/databases/p5-Memcached-libmemcached/distinfo
index f3568c1fd4ec..00dd3f923d98 100644
--- a/databases/p5-Memcached-libmemcached/distinfo
+++ b/databases/p5-Memcached-libmemcached/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Memcached-libmemcached-0.4406.tar.gz) = def5f5c43ebcf49bd60b7b8cebe67c20ca21e03328fe5854f36d7f539bed21e3
-SIZE (Memcached-libmemcached-0.4406.tar.gz) = 837725
+SHA256 (Memcached-libmemcached-1.001801.tar.gz) = aa07972fdb74cffde6b7fee648a3a58d3129af22e06a073d1388d778f6e8dca5
+SIZE (Memcached-libmemcached-1.001801.tar.gz) = 1162993
diff --git a/databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-10 b/databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-10
new file mode 100644
index 000000000000..a0858407fe18
--- /dev/null
+++ b/databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-10
@@ -0,0 +1,29 @@
+--- Makefile.PL.orig 2015-05-07 17:56:22 UTC
++++ Makefile.PL
+@@ -30,7 +30,7 @@ $Data::Dumper::Indent = 1;
+ $Data::Dumper::Sortkeys = 1;
+
+ my $lmcd_api_ver = "1.0"; # eg $lmcd_src/libmemcached-$lmcd_api_ver/
+-my $lmcd_inst = getcwd()."/src_inst";
++my $lmcd_inst = "/usr/local";
+ my $lmcd_built_lib = "$lmcd_inst/lib/libmemcached$Config{lib_ext}";
+ my $is_developer = (-d ".svn" || -d ".git");
+
+@@ -54,7 +54,7 @@ if (my $gccversion = $Config{gccversion}
+ $opts{DEFINE} .= ' -Wmissing-prototypes';
+ }
+ }
+-$opts{LIBS} = ["-lstdc++"]; # else error: libmemcached.so: undefined symbol: __gxx_personality_v0
++$opts{LIBS} = ["-lc++"]; # else error: libmemcached.so: undefined symbol: __gxx_personality_v0
+ $opts{OPTIMIZE} = "-g" if $opt_g;
+ $opts{CCFLAGS} = "-pg" if $opt_pg;
+ my $coverage_flags = "";
+@@ -76,7 +76,7 @@ WriteMakefile(
+ AUTHOR => 'Tim Bunce <Tim.Bunce@pobox.com>',
+ VERSION_FROM => 'libmemcached.pm',
+ ABSTRACT_FROM => 'libmemcached.pm',
+- INC => "-I$lmcd_inst/include",
++ INC => "-I$lmcd_inst/include/",
+ # We want to link to *our* private libmemcached and not one that
+ # might already be installed on the system. The LIBS config gets
+ # appended to the link command line, so if we used "-L$dir -lmemcached"
diff --git a/databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-9 b/databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-9
new file mode 100644
index 000000000000..3143aca52828
--- /dev/null
+++ b/databases/p5-Memcached-libmemcached/files/extra-patch-Makefile.PL-9
@@ -0,0 +1,20 @@
+--- Makefile.PL.orig 2015-05-07 17:56:22 UTC
++++ Makefile.PL
+@@ -30,7 +30,7 @@ $Data::Dumper::Indent = 1;
+ $Data::Dumper::Sortkeys = 1;
+
+ my $lmcd_api_ver = "1.0"; # eg $lmcd_src/libmemcached-$lmcd_api_ver/
+-my $lmcd_inst = getcwd()."/src_inst";
++my $lmcd_inst = "/usr/local";
+ my $lmcd_built_lib = "$lmcd_inst/lib/libmemcached$Config{lib_ext}";
+ my $is_developer = (-d ".svn" || -d ".git");
+
+@@ -76,7 +76,7 @@ WriteMakefile(
+ AUTHOR => 'Tim Bunce <Tim.Bunce@pobox.com>',
+ VERSION_FROM => 'libmemcached.pm',
+ ABSTRACT_FROM => 'libmemcached.pm',
+- INC => "-I$lmcd_inst/include",
++ INC => "-I$lmcd_inst/include/",
+ # We want to link to *our* private libmemcached and not one that
+ # might already be installed on the system. The LIBS config gets
+ # appended to the link command line, so if we used "-L$dir -lmemcached"
diff --git a/databases/p5-Memcached-libmemcached/files/patch-src__libmemcached__docs__memslap.pod b/databases/p5-Memcached-libmemcached/files/patch-src__libmemcached__docs__memslap.pod
deleted file mode 100644
index fe83b6e98bc8..000000000000
--- a/databases/p5-Memcached-libmemcached/files/patch-src__libmemcached__docs__memslap.pod
+++ /dev/null
@@ -1,7 +0,0 @@
---- ./src/libmemcached/docs/memslap.pod.orig 2014-09-19 23:41:45.618347308 +0400
-+++ ./src/libmemcached/docs/memslap.pod 2014-09-19 23:41:57.086346149 +0400
-@@ -1,3 +1,4 @@
-+=encoding utf8
- =head1 NAME
-
- memslap - Load testing and benchmarking tool for memcached