aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2012-06-05 03:25:56 +0800
committermatthew <matthew@FreeBSD.org>2012-06-05 03:25:56 +0800
commit239cc6b573a3bef44f2c6837774e97090bad2696 (patch)
tree077db2d3ea76af1a91dc2fdf5653d9a1414472d8 /databases
parent10056f05563e6fe74b77b9d16ae38c4dea1c82b9 (diff)
downloadfreebsd-ports-gnome-239cc6b573a3bef44f2c6837774e97090bad2696.tar.gz
freebsd-ports-gnome-239cc6b573a3bef44f2c6837774e97090bad2696.tar.zst
freebsd-ports-gnome-239cc6b573a3bef44f2c6837774e97090bad2696.zip
- Convert all my remaining ports to OPTIONSng
Files affected: databases/mysql-connector-java/Makefile databases/phpmyadmin/Makefile mail/sa-utils/Makefile net/phpldapadmin/Makefile security/apg/Makefile textproc/sphinxsearch/Makefile www/p5-RT-Authen-ExternalAuth/Makefile www/p5-RT-Extension-LDAPImport/Makefile www/p5-RT-Extension-SLA/Makefile www/p5-RTx-Calendar/Makefile www/rt40/Makefile www/rt40/Makefile.cpan x11-fonts/gentium/Makefile x11-fonts/gentium-basic/Makefile Approved by: shaun (mentor)
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql-connector-java/Makefile8
-rw-r--r--databases/phpmyadmin/Makefile52
2 files changed, 29 insertions, 31 deletions
diff --git a/databases/mysql-connector-java/Makefile b/databases/mysql-connector-java/Makefile
index 18f2baa6db3a..cdc0fa985aea 100644
--- a/databases/mysql-connector-java/Makefile
+++ b/databases/mysql-connector-java/Makefile
@@ -35,12 +35,14 @@ JDCLASSPATH= ${SRCDIR}:${CLASSPATH}
PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
do-build:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${JAVADOCDIR} && (cd ${SRCDIR}; \
${JAVADOC} -quiet -breakiterator -encoding utf8 \
-d ${JAVADOCDIR} -package -classpath ${JDCLASSPATH} \
@@ -55,7 +57,7 @@ do-install-jar:
@${ECHO_MSG} " [ DONE ]"
do-install-apidocs:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@${MKDIR} ${APIDOCSDIR}
@cd ${JAVADOCDIR} && for src in $$( ${FIND} . ) ; do \
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 3f12b927a54c..546ce31e7574 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -27,25 +27,28 @@ USE_PHP= ctype session filter mbstring json spl
# want this, either turn off GD in the config dialog, or else turn off
# FONTCONFIG in the graphics/gd port options.
-OPTIONS= SUPHP "suPHP support" off \
- BZ2 "bzip2 library support" on \
- GD "GD library support (requires X11)" on \
- MYSQL "MySQL support via mysql client" off \
- MYSQLI "Improved MySQL client support" on \
- OPENSSL "OpenSSL support" on \
- PDF "PDFlib support" on \
- ZLIB "ZLIB support" on \
- MCRYPT "MCrypt library support" on \
- ZIP "Zip compression support" on \
- APC "APC (animated progress bar) support" on
+PHP_MODULE_OPTIONS= APC BZ2 GD MCRYPT OPENSSL PDF ZIP ZLIB
+OPTIONS_DEFINE= SUPHP ${PHP_MODULE_OPTIONS}
+OPTIONS_DEFAULT= APC BZ2 GD MCRYPT MYSQLI OPENSSL PDF ZIP ZLIB
+
+OPTIONS_MULTI= DB_connect
+OPTIONS_MULTI_DB_connect= MYSQL MYSQLI
+
+APC_DESC= PHP APC (animated progress bar) support
+BZ2_DESC= PHP bzip2 library support
+GD_DESC= PHP GD library support (requires X11)
+MCRYPT_DESC= PHP MCrypt library support
+MYSQLI_DESC= PHP Improved MySQL client support
+MYSQL_DESC= PHP MySQL support via mysql client
+OPENSSL_DESC= PHP OpenSSL support
+PDF_DESC= PHP PDFlib support
+SUPHP_DESC= suPHP support
+ZIP_DESC= PHP Zip compression support
+ZLIB_DESC= PHP ZLIB support
.include <bsd.port.options.mk>
-.if !defined(WITH_MYSQL) && !defined(WITH_MYSQLI)
-BROKEN= ${PKGNAME} needs at least one of WITH_MYSQL or WITH_MYSQLI in order to work
-.endif
-
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
PKGNAMESUFFIX= -suphp
RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
@@ -57,14 +60,14 @@ WANT_PHP_WEB= yes
.endif
-# USERS is only used WITH_SUPHP
+# USERS is only used with the SUPHP option
GROUPS?= ${WWWGRP}
CFGFILE= config.inc.php
PLIST= ${WRKDIR}/plist
PLIST_SUB+= PMA_GRP=${GROUPS}
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
USERS?= _pma
@@ -81,19 +84,12 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
.if !defined(WITHOUT_PHP_DEPENDS)
-# Options that default to on:
-.for opt in BZ2 GD OPENSSL PDF ZLIB MCRYPT MBSTRING ZIP APC
-. if !defined(WITHOUT_${opt}) || defined(WITH_${opt})
+.for opt in ${PHP_MODULE_OPTIONS} ${OPTIONS_MULTI_DB_connect}
+. if ${PORT_OPTIONS:M${opt}}
USE_PHP+= ${opt:L}
. endif
.endfor
-# Options that default to off:
-.for opt in MYSQLI
-. if defined(WITH_${opt}) && !defined(WITHOUT_${opt})
-USE_PHP+= ${opt:L}
-. endif
-.endfor
.endif
.SILENT:
@@ -136,7 +132,7 @@ install-conf: install-app
fi
post-install:
-.if defined(WITH_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
${CAT} ${PKGMESSAGE}