aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2015-07-10 18:59:40 +0800
committervg <vg@FreeBSD.org>2015-07-10 18:59:40 +0800
commit24890ccf15c95ec7b25d78de49f761e951be44cd (patch)
treeda26adb92e25e0d75da97dd33b10686e917e51e8 /databases
parent74b68db7216f5c694e3ed242713bd7a4c96ff2f2 (diff)
downloadfreebsd-ports-gnome-24890ccf15c95ec7b25d78de49f761e951be44cd.tar.gz
freebsd-ports-gnome-24890ccf15c95ec7b25d78de49f761e951be44cd.tar.zst
freebsd-ports-gnome-24890ccf15c95ec7b25d78de49f761e951be44cd.zip
- Fixed bug with run as daemon
- Updated description of port - Added extra patches to change group - Bump port revision - Added gettext depend
Diffstat (limited to 'databases')
-rw-r--r--databases/tarantool/Makefile5
-rw-r--r--databases/tarantool/files/patch-extra_dist_default_tarantool.in13
-rw-r--r--databases/tarantool/files/patch-extra_dist_tarantoolctl44
-rw-r--r--databases/tarantool/files/patch-src_box_lua_load__cfg.lua20
-rw-r--r--databases/tarantool/files/patch-third__party_libev_ev.c11
-rw-r--r--databases/tarantool/pkg-descr20
6 files changed, 108 insertions, 5 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 00be795150c4..fb7462523bc5 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -3,18 +3,19 @@
PORTNAME= tarantool
PORTVERSION= 1.6.5
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://tarantool.org/dist/master/
DISTNAME= ${PORTNAME}-${PORTVERSION}-${TR_REV}-src
MAINTAINER= vg@FreeBSD.org
-COMMENT= High performance key/value storage server
+COMMENT= NoSQL database running in a Lua application server
LICENSE= BSD2CLAUSE
TR_REV= 238-g74f3d65
MAKE_JOBS_UNSAFE=yes
-USES= cmake compiler:c++11-lang gmake perl5 readline
+USES= cmake compiler:c++11-lang gettext gmake perl5 readline
USE_GCC= 4.9+ # clang bug PR/201270
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
diff --git a/databases/tarantool/files/patch-extra_dist_default_tarantool.in b/databases/tarantool/files/patch-extra_dist_default_tarantool.in
new file mode 100644
index 000000000000..dbf140e30408
--- /dev/null
+++ b/databases/tarantool/files/patch-extra_dist_default_tarantool.in
@@ -0,0 +1,13 @@
+--- extra/dist/default/tarantool.in.orig 2015-07-07 14:38:20 UTC
++++ extra/dist/default/tarantool.in
+@@ -6,8 +6,9 @@ default_cfg = {
+ sophia_dir = "@TARANTOOL_DATADIR@", -- will become sophia_dir/sophia/instance/
+ logger = "/var/log/tarantool", -- logger/instance .. '.log'
+ username = "tarantool",
++ groupname = "tarantool",
+ }
+
+-instance_dir = "@CMAKE_INSTALL_SYSCONFDIR@/tarantool/instances.enabled"
++instance_dir = "@CMAKE_INSTALL_SYSCONFDIR@/instances.enabled"
+
+ -- vim: set ft=lua :
diff --git a/databases/tarantool/files/patch-extra_dist_tarantoolctl b/databases/tarantool/files/patch-extra_dist_tarantoolctl
new file mode 100644
index 000000000000..509da0634cfd
--- /dev/null
+++ b/databases/tarantool/files/patch-extra_dist_tarantoolctl
@@ -0,0 +1,44 @@
+--- extra/dist/tarantoolctl.orig 2015-07-07 14:38:20 UTC
++++ extra/dist/tarantoolctl
+@@ -39,6 +39,7 @@ The file contains common default instanc
+ logger = "/var/log/tarantool",
+
+ username = "tarantool",
++ groupname = "tarantool",
+ }
+
+ instance_dir = "/etc/tarantool/instances.enabled"
+@@ -259,7 +260,8 @@ function load_default_file(default_file)
+
+ if not usermode then
+ -- change user name only if not running locally
+- d.username = d.username and d.username or "tarantool"
++ d.username = d.username and d.username or "tarantool"
++ d.groupname = d.groupname and d.groupname or "tarantool"
+ --
+ -- instance_dir must be set in the defaults file,
+ -- but don't try to set it to the global instance dir
+@@ -310,9 +312,9 @@ local function mkdir(dirname)
+ os.exit(-1)
+ end
+
+- if not usermode and not fio.chown(dirname, default_cfg.username, default_cfg.username) then
++ if not usermode and not fio.chown(dirname, default_cfg.username, default_cfg.groupname) then
+ log.error("Can't chown(%s, %s, %s): %s",
+- default_cfg.username, default_cfg.username, dirname, errno.strerror())
++ default_cfg.username, default_cfg.groupname, dirname, errno.strerror())
+ end
+ end
+
+@@ -367,8 +369,9 @@ local function wrapper_cfg(cfg)
+ --
+ -- force these startup options
+ --
+- cfg.pid_file = default_cfg.pid_file
+- cfg.username = default_cfg.username
++ cfg.pid_file = default_cfg.pid_file
++ cfg.username = default_cfg.username
++ cfg.groupname = default_cfg.groupname
+ if cfg.background == nil then
+ cfg.background = true
+ end
diff --git a/databases/tarantool/files/patch-src_box_lua_load__cfg.lua b/databases/tarantool/files/patch-src_box_lua_load__cfg.lua
new file mode 100644
index 000000000000..0511c73d656d
--- /dev/null
+++ b/databases/tarantool/files/patch-src_box_lua_load__cfg.lua
@@ -0,0 +1,20 @@
+--- src/box/lua/load_cfg.lua.orig 2015-05-28 22:07:40 UTC
++++ src/box/lua/load_cfg.lua
+@@ -54,7 +54,8 @@ local default_cfg = {
+ custom_proc_title = nil,
+ pid_file = nil,
+ background = false,
+- username = nil ,
++ username = nil,
++ groupname = nil,
+ coredump = false,
+
+ -- snapshot_daemon
+@@ -101,6 +102,7 @@ local template_cfg = {
+ pid_file = 'string',
+ background = 'boolean',
+ username = 'string',
++ groupname = 'string',
+ coredump = 'boolean',
+ snapshot_period = 'number',
+ snapshot_count = 'number',
diff --git a/databases/tarantool/files/patch-third__party_libev_ev.c b/databases/tarantool/files/patch-third__party_libev_ev.c
new file mode 100644
index 000000000000..a1c48c7ecd35
--- /dev/null
+++ b/databases/tarantool/files/patch-third__party_libev_ev.c
@@ -0,0 +1,11 @@
+--- third_party/libev/ev.c.orig 2015-07-10 10:15:23 UTC
++++ third_party/libev/ev.c
+@@ -2225,7 +2225,7 @@ ev_recommended_backends (void) EV_THROW
+ {
+ unsigned int flags = ev_supported_backends ();
+
+-#if !defined(__NetBSD__) && !defined(__FreeBSD__)
++#if !defined(__NetBSD__)
+ /* kqueue is borked on everything but netbsd apparently */
+ /* it usually doesn't work correctly on anything but sockets and pipes */
+ flags &= ~EVBACKEND_KQUEUE;
diff --git a/databases/tarantool/pkg-descr b/databases/tarantool/pkg-descr
index 5aa8eae50970..e183e661eee6 100644
--- a/databases/tarantool/pkg-descr
+++ b/databases/tarantool/pkg-descr
@@ -1,5 +1,19 @@
-Tarantool/Box, or simply Tarantool, is a high performance key/value
-storage server. The code is available for free under the terms of
-BSD license. Supported platforms are GNU/Linux and FreeBSD.
+Tarantool is an efficient NoSQL database and a Lua application server.
+
+Key features of the Lua application server:
+* 100% compatible drop-in replacement for Lua 5.1, based on LuaJIT 2.0.
+Simply use #!/usr/bin/tarantool instead of #!/usr/bin/lua in your script.
+* full support for Lua modules and a rich set of own modules, including
+cooperative multitasking, non-blocking I/O, access to external databases,
+etc.
+
+Key features of the database:
+* MsgPack data format and MsgPack based client-server protocol
+* two data engines: 100% in-memory with optional persistence and a 2-level
+disk-based B-tree, to use with large data sets
+* multiple index types: HASH, TREE, BITSET
+* asynchronous master-master replication
+* authentication and access control
+* the database is just a C extension to the app server and can be turned off
WWW: http://tarantool.org/