aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2011-02-25 03:48:19 +0800
committerosa <osa@FreeBSD.org>2011-02-25 03:48:19 +0800
commit35ba10b704d621622d70a1fd5255a1fc0294a3a6 (patch)
treeae03cc7b2b246368018f42c05df0e21f7e270f52 /databases
parent73f199deb87bf39620147b0d50849aa0a8e1255a (diff)
downloadfreebsd-ports-gnome-35ba10b704d621622d70a1fd5255a1fc0294a3a6.tar.gz
freebsd-ports-gnome-35ba10b704d621622d70a1fd5255a1fc0294a3a6.tar.zst
freebsd-ports-gnome-35ba10b704d621622d70a1fd5255a1fc0294a3a6.zip
Remove deprecated and unsupported databases/redis1.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/redis1/Makefile69
-rw-r--r--databases/redis1/distinfo3
-rw-r--r--databases/redis1/pkg-descr14
-rw-r--r--databases/redis1/pkg-plist6
5 files changed, 0 insertions, 93 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3343f553b04a..cad783945cbb 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -702,7 +702,6 @@
SUBDIR += rdb
SUBDIR += rdfdb
SUBDIR += redis
- SUBDIR += redis1
SUBDIR += redis2
SUBDIR += rrdman
SUBDIR += rrdtool
diff --git a/databases/redis1/Makefile b/databases/redis1/Makefile
deleted file mode 100644
index d98f8cc8c9a4..000000000000
--- a/databases/redis1/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-# New ports collection makefile for: redis
-# Date created: 03 Jul 2009
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
-# $FreeBSD$
-#
-
-PORTNAME= redis
-PORTVERSION= 1.2.6
-PORTREVISION= 2
-CATEGORIES= databases
-MASTER_SITES= GOOGLE_CODE
-
-MAINTAINER= osa@FreeBSD.org
-COMMENT= A persistent key-value database with built-in net interface
-
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-
-CFLAGS+= -I${LOCALBASE}/include
-
-CONFLICTS?= redis-2.*
-
-USE_GMAKE= yes
-USE_RC_SUBR= redis.sh
-NO_LATEST_LINK= yes
-BIN_FILES= redis-server redis-benchmark redis-cli
-
-PKGINSTALL= ${WRKDIR}/pkg-install
-PKGDEINSTALL= ${WRKDIR}/pkg-install
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-REDIS_USER?= redis
-REDIS_UID?= 535
-REDIS_GROUP?= redis
-REDIS_GID?= 535
-
-REDIS_DBDIR?= /var/db/redis
-REDIS_RUNDIR?= /var/run/redis
-REDIS_LOGDIR?= /var/log/redis
-
-SUB_FILES= pkg-message pkg-install
-SUB_LIST+= PORTNAME="${PORTNAME}" \
- REDIS_USER="${REDIS_USER}" \
- REDIS_UID="${REDIS_UID}" \
- REDIS_GROUP="${REDIS_GROUP}" \
- REDIS_GID="${REDIS_GID}" \
- REDIS_LOGDIR="${REDIS_LOGDIR}" \
- REDIS_DBDIR="${REDIS_DBDIR}" \
- REDIS_RUNDIR="${REDIS_RUNDIR}"
-
-PATTERN= '10d;13s|$$$$(ARCH) ||'
-.if !defined(WITH_DEBUG)
-PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
-.endif
-
-post-patch:
- ${REINPLACE_CMD} ${PATTERN} ${WRKSRC}/Makefile
-
-post-build:
- ${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${WRKSRC}/redis.conf > ${WRKDIR}/redis.conf
-
-do-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- ${INSTALL_PROGRAM} ${BIN_FILES:C!^!${WRKSRC}/!} ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKDIR}/redis.conf ${PREFIX}/etc/redis.conf.sample
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
-.include <bsd.port.mk>
diff --git a/databases/redis1/distinfo b/databases/redis1/distinfo
deleted file mode 100644
index 9a3389d30aac..000000000000
--- a/databases/redis1/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (redis-1.2.6.tar.gz) = 0c5355e57606523f9e8ce816db5e542f
-SHA256 (redis-1.2.6.tar.gz) = bed0641225f786f225a2c4897ffbec1e6573a3c31e9f899884ee3041eab96873
-SIZE (redis-1.2.6.tar.gz) = 213341
diff --git a/databases/redis1/pkg-descr b/databases/redis1/pkg-descr
deleted file mode 100644
index 81dd3e5bdd3b..000000000000
--- a/databases/redis1/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-Redis is a key-value database. It is similar to memcached but the
-dataset is not volatile, and values can be strings, exactly like in
-memcached, but also lists and sets with atomic operations to push/pop
-elements.
-
-In order to be very fast but at the same time persistent the whole
-dataset is taken in memory and from time to time and/or when a number of
-changes to the dataset are performed it is written asynchronously on
-disk. You may lost the last few queries that is acceptable in many
-applications but it is as fast as an in memory DB (Redis supports
-non-blocking master-slave replication in order to solve this problem by
-redundancy).
-
-WWW: http://code.google.com/p/redis/
diff --git a/databases/redis1/pkg-plist b/databases/redis1/pkg-plist
deleted file mode 100644
index 3f7c08dc7eee..000000000000
--- a/databases/redis1/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/redis-server
-bin/redis-benchmark
-bin/redis-cli
-@unexec (cmp -s %D/etc/redis.conf %D/etc/redis.conf.sample && rm -f %D/etc/redis.conf) || true
-etc/redis.conf.sample
-@exec [ -f %B/redis.conf ] || cp %B/%f %B/redis.conf