aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-03 02:51:47 +0800
committerknu <knu@FreeBSD.org>2001-06-03 02:51:47 +0800
commit3eef0275772f559ed4fbf4569a5fcd7877688f06 (patch)
tree7586dab777561b49bd1fd675d46947d2307369e5 /databases
parent5d14865d7ad1a0eaf1f38b09e36f5f8ad3f99801 (diff)
downloadfreebsd-ports-gnome-3eef0275772f559ed4fbf4569a5fcd7877688f06.tar.gz
freebsd-ports-gnome-3eef0275772f559ed4fbf4569a5fcd7877688f06.tar.zst
freebsd-ports-gnome-3eef0275772f559ed4fbf4569a5fcd7877688f06.zip
Add ruby-dbd_sybase, the Sybase driver for DBI-for-Ruby.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-dbd_sybase/Makefile39
-rw-r--r--databases/ruby-dbd_sybase/distinfo1
-rw-r--r--databases/ruby-dbd_sybase/files/patch-extconf.rb16
-rw-r--r--databases/ruby-dbd_sybase/pkg-comment1
-rw-r--r--databases/ruby-dbd_sybase/pkg-descr4
-rw-r--r--databases/ruby-dbd_sybase/pkg-plist4
7 files changed, 66 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7c932cfccfa8..47141e7b80f1 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -73,6 +73,7 @@
SUBDIR += ruby-cdb
SUBDIR += ruby-dbd_mysql
SUBDIR += ruby-dbd_postgresql
+ SUBDIR += ruby-dbd_sybase
SUBDIR += ruby-dbi
SUBDIR += ruby-gdbm
SUBDIR += ruby-rdbc1
diff --git a/databases/ruby-dbd_sybase/Makefile b/databases/ruby-dbd_sybase/Makefile
new file mode 100644
index 000000000000..2e0c60605e75
--- /dev/null
+++ b/databases/ruby-dbd_sybase/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dbd_sybase for DBD-for-Ruby
+# Date created: 3 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd_sybase
+PORTVERSION= 0.0.4
+CATEGORIES= databases ruby
+MASTER_SITES= http://www.sprytech.com/~rainer.perl/ruby/files/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-dbi-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= tds.0:${.CURDIR}/../freetds
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${.CURDIR}/../ruby-dbi
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/ext/${PORTNAME}
+INSTALL_TARGET= site-install
+
+DOCS_EN= doc/*
+
+post-install:
+ cd ${RUBY_SITEARCHLIBDIR} && ${MV} ${PORTNAME}.so dbi/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/dbi/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/dbi/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-dbd_sybase/distinfo b/databases/ruby-dbd_sybase/distinfo
new file mode 100644
index 000000000000..577d95dcd0c3
--- /dev/null
+++ b/databases/ruby-dbd_sybase/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-dbi-0.0.4.tgz) = 65dc83374cce86f8494fd47537902449
diff --git a/databases/ruby-dbd_sybase/files/patch-extconf.rb b/databases/ruby-dbd_sybase/files/patch-extconf.rb
new file mode 100644
index 000000000000..8bc4a421da7f
--- /dev/null
+++ b/databases/ruby-dbd_sybase/files/patch-extconf.rb
@@ -0,0 +1,16 @@
+--- extconf.rb.orig Mon Apr 23 21:31:46 2001
++++ extconf.rb Sun Jun 3 03:44:04 2001
+@@ -1,11 +1,7 @@
+ require 'mkmf'
+
+-# You may need to change these parameters
+-FREETDSDIR = "/usr/local/freetds"
+-# end of parameters
++dir_config("freetds", "/usr/local/freetds")
+
+-$CFLAGS = "-I#{FREETDSDIR}/include"
+-$LDFLAGS = "-L#{FREETDSDIR}/lib"
+ $libs = "-ltds"
+
+-create_makefile("dbd_sybase")
++create_makefile("dbd_sybase")
diff --git a/databases/ruby-dbd_sybase/pkg-comment b/databases/ruby-dbd_sybase/pkg-comment
new file mode 100644
index 000000000000..31ae78f705b6
--- /dev/null
+++ b/databases/ruby-dbd_sybase/pkg-comment
@@ -0,0 +1 @@
+Sybase driver for DBI-for-Ruby
diff --git a/databases/ruby-dbd_sybase/pkg-descr b/databases/ruby-dbd_sybase/pkg-descr
new file mode 100644
index 000000000000..9fbcaf7ccce7
--- /dev/null
+++ b/databases/ruby-dbd_sybase/pkg-descr
@@ -0,0 +1,4 @@
+This is the Sybase driver for Rainer Perl's DBI-for-Ruby.
+
+Author: Rainer Perl <rainer.perl@sprytech.com>
+WWW: http://www.sprytech.com/~rainer.perl/ruby/
diff --git a/databases/ruby-dbd_sybase/pkg-plist b/databases/ruby-dbd_sybase/pkg-plist
new file mode 100644
index 000000000000..08a1679dbc11
--- /dev/null
+++ b/databases/ruby-dbd_sybase/pkg-plist
@@ -0,0 +1,4 @@
+%%RUBY_SITEARCHLIBDIR%%/dbi/dbd_sybase.so
+%%PORTDOCS%%%%RUBY_DOCDIR%%/dbi/dbd_sybase/HISTORY
+%%PORTDOCS%%%%RUBY_DOCDIR%%/dbi/dbd_sybase/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/dbi/dbd_sybase
>Use constantSteve Klebanoff2019-01-032-1/+2 | * | | await alerting discordSteve Klebanoff2019-01-031-1/+1 | * | | Merge branch 'development' into feature/monorepo/release-notesSteve Klebanoff2019-01-03270-4073/+661 | |\ \ \ | * | | | remove unused exportSteve Klebanoff2019-01-031-1/+1 | * | | | feat(monorepo-scripts): Alert to discord when new publish happensSteve Klebanoff2019-01-036-3/+54 * | | | | Merge pull request #1437 from 0xProject/feature/instant/tell-amount-availableSteve Klebanoff2019-01-1012-17/+273 |\ \ \ \ \ | |_|_|_|/ |/| | | | | * | | | Merge branch 'development' into feature/instant/tell-amount-availableSteve Klebanoff2019-01-10510-2630/+21906 | |\ \ \ \ | * | | | | Add PR numberSteve Klebanoff2019-01-041-1/+2 | * | | | | Merge branch 'development' into feature/instant/tell-amount-availableSteve Klebanoff2019-01-03271-4065/+647 | |\ \ \ \ \ | | | |_|/ / | | |/| | | | * | | | | take out no-longer necessary testSteve Klebanoff2019-01-031-6/+1 | * | | | | Merge branch 'development' into feature/instant/tell-amount-availableSteve Klebanoff2018-12-222-10/+16 | |\ \ \ \ \ | * | | | | | Fix var name and use floor instead of .round(0, ROUND_DOWN)Steve Klebanoff2018-12-221-9/+7 | * | | | | | Make amountAvailableToFill requiredSteve Klebanoff2018-12-223-8/+3 | * | | | | | Merge branch 'development' into feature/instant/tell-amount-availableSteve Klebanoff2018-12-22411-1165/+14395 | |\ \ \ \ \ \ | | | |_|_|/ / | | |/| | | | | * | | | | | more documentationSteve Klebanoff2018-12-151-0/+6 | * | | | | | Fix for asset-buyer documentationSteve Klebanoff2018-12-151-0/+1 | * | | | | | rename boolean varSteve Klebanoff2018-12-151-3/+3 | * | | | | | one more test for undefinedSteve Klebanoff2018-12-151-1/+6 | * | | | | | Update asset-buyer changelog describing error changeSteve Klebanoff2018-12-151-0/+8 | * | | | | | Only send in amountAvailableToFill if it's a non-zero amount, add additional ...Steve Klebanoff2018-12-157-104/+154 | * | | | | | Nesting errorsSteve Klebanoff2018-12-151-23/+25 | * | | | | | More tests for assetBuyerErrorMessageSteve Klebanoff2018-12-151-3/+38 | * | | | | | Factor in slippage amount in InsufficientAssetLiquidityError error, and show ...Steve Klebanoff2018-12-158-9/+72 | * | | | | | feat(asset-buyer): Custom InsufficientAssetLiquidityError errorSteve Klebanoff2018-12-154-9/+107 * | | | | | | Merge pull request #1489 from 0xProject/fix/website/0x-org-endpointsFrancesco Agosti2019-01-103-6/+8 |\ \ \ \ \ \ \ | * | | | | | | fix: use getBackendBaseUrl instead of hardcoded stringfragosti2019-01-092-2/+4 | * | | | | | | fix: use new forum URLfragosti2019-01-091-2/+2 | * | | | | | | fix: use old forum URL for nowfragosti2019-01-081-2/+2 | * | | | | | | chore: point to 0x.org website-apifragosti2019-01-081-2/+2 | * | | | | | | fix: CORS issue by accessing 0x geth nodes through 0x.org endpointfragosti2019-01-081-2/+2 * | | | | | | | Clean up docs before publishF. Eugene Aumson2019-01-105-20/+69 | |_|_|_|_|/ / |/| | | | | | * | | | | | | In README's, don't mention non-existent tests (#1497)F. Eugene Aumson2019-01-103-15/+1 * | | | | | | Merge pull request #1249 from bakkenbaeck/dev-tools-pagesFabio B2019-01-0986-1276/+5707 |\ \ \ \ \ \ \ | * \ \ \ \ \ \ Merge developmentLeonid Logvinov2019-01-09119-386/+787 | |\ \ \ \ \ \ \ | * | | | | | | | Pin @types/styled-components versionsLeonid Logvinov2019-01-096-24/+15 | * | | | | | | | Add yarn.lock changesLeonid Logvinov2019-01-091-227/+1165 | * | | | | | | | Remove accidentally commited filesLeonid Logvinov2019-01-0970-51510/+0 | * | | | | | | | Merge developmentLeonid Logvinov2019-01-091217-6572/+99531 | |\ \ \ \ \ \ \ \ | * | | | | | | | | Fix static testsLeonid Logvinov2019-01-093-7/+8 | * | | | | | | | | Remove redundant semicolonsLeonid Logvinov2019-01-092-3/+3 | * | | | | | | | | Fix the circleci imageLeonid Logvinov2019-01-093-31/+17 | * | | | | | | | | fix puppeteer options for react-snapAugust Skare2018-11-211-1/+5 | * | | | | | | | | fix casing for entries in webpackAugust Skare2018-11-211-4/+4 | * | | | | | | | | Merge branch 'development' into dev-tools-pagesAugust Skare2018-11-21104-134/+1573 | |\ \ \ \ \ \ \ \ \ | * | | | | | | | | | comment for commented BundleAnalyzerPlugin webpack pluginAugust Skare2018-11-201-0/+1 | * | | | | | | | | | fix type for svg icon in footerAugust Skare2018-11-201-1/+1 | * | | | | | | | | | typedef for context dataAugust Skare2018-11-205-5/+20 | * | | | | | | | | | fix import orderAugust Skare2018-11-205-5/+5 | * | | | | | | | | | uniq export names for animationsAugust Skare2018-11-208-15/+15 | * | | | | | | | | | use lodash.map insted of array.mapAugust Skare2018-11-204-22/+23 | * | | | | | | | | | use lodash isUndefined functionAugust Skare2018-11-202-5/+7 | * | | | | | | | | | fix imports after renamingAugust Skare2018-11-2015-65/+65 | * | | | | | | | | | rename all files and directories to lowercaseAugust Skare2018-11-2030-0/+0 | * | | | | | | | | | separate component for inlinecode componentAugust Skare2018-11-191-1/+5 | * | | | | | | | | | added missing ;August Skare2018-11-191-1/+1 | * | | | | | | | | | cleand up code componentAugust Skare2018-11-191-22/+17 | * | | | | | | | | | strict check for children in contentblockAugust Skare2018-11-191-1/+1 | * | | | | | | | | | type function call for Container in Animation classAugust Skare2018-11-191-2/+5 | * | | | | | | | | | remove new-lines between methods in classesAugust Skare2018-11-192-8/+0 | * | | | | | | | | | clean up tabs componentAugust Skare2018-11-191-27/+17 | * | | | | | | | | | remove unnecessary children in InterfaceAugust Skare2018-11-197-22/+4 | * | | | | | | | | | fix typings for components in headerAugust Skare2018-11-191-6/+3 | * | | | | | | | | | use styled-components theme in logo insted of color propAugust Skare2018-11-191-3/+3 | * | | | | | | | | | removed unused prop def from footer componentAugust Skare2018-11-191-4/+1 | * | | | | | | | | | rename copied to didCopy in Code stateAugust Skare2018-11-191-5/+5 | * | | | | | | | | | remove constructor from Code componentAugust Skare2018-11-191-5/+0 | * | | | | | | | | | less verbose tslint disable ruleAugust Skare2018-11-191-2/+1 | * | | | | | | | | | fix timeout type in animation componentAugust Skare2018-11-191-2/+2 | * | | | | | | | | | fixed base link styling colorAugust Skare2018-11-162-4/+8 | * | | | | | | | | | Merge branch 'development' into dev-tools-pagesAugust Skare2018-11-16184-642/+2416 | |\ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | fix linting + code syntax for statless componentsAugust Skare2018-11-1636-843/+844 | * | | | | | | | | | | update styled-component and styled-component typingsAugust Skare2018-11-162-47/+40 | * | | | | | | | | | | Merge branch 'development' into dev-tools-pagesAugust Skare2018-11-1388-271/+697 | |\ \ \ \ \ \ \ \ \ \ \ | * \ \ \ \ \ \ \ \ \ \ \ Merge branch 'development' into dev-tools-pagesAugust Skare2018-11-131087-62833/+30200 | |\ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | remove unused dependeciesAugust Skare2018-11-122-11/+0 | * | | | | | | | | | | | | better positioning of hero animationAugust Skare2018-11-071-4/+4 | * | | | | | | | | | | | | lower deboune on animation resizeAugust Skare2018-11-071-1/+1 | * | | | | | | | | | | | | fix alignment on list bullestAugust Skare2018-11-071-8/+9 | * | | | | | | | | | | | | visual tweaks in code componentAugust Skare2018-11-071-7/+13 | * | | | | | | | | | | | | styling adjustment in uniq componentsAugust Skare2018-11-072-2/+2 | * | | | | | | | | | | | | align 0x logo in footerAugust Skare2018-11-071-0/+1 | * | | | | | | | | | | | | right align icons in trace componentAugust Skare2018-11-071-1/+0 | * | | | | | | | | | | | | more spacing on footer itemsAugust Skare2018-11-071-0/+1 | * | | | | | | | | | | | | break compiler cards on an earlier breakpointAugust Skare2018-11-071-2/+2 | * | | | | | | | | | | | | new og imagesAugust Skare2018-11-074-0/+0 | * | | | | | | | | | | | | new hero animation using bodymovin and lottieAugust Skare2018-11-0725-46/+261 | * | | | | | | | | | | | | copy changesAugust Skare2018-11-074-10/+8 | * | | | | | | | | | | | | fix issues in code elementAugust Skare2018-11-061-0/+3 | * | | | | | | | | | | | | fix large button on small screensAugust Skare2018-11-061-3/+10 | * | | | | | | | | | | | | rename pesudo element in code gutterAugust Skare2018-10-302-2/+2 | * | | | | | | | | | | | | fix code highlighting with ...August Skare2018-10-304-16/+31 | * | | | | | | | | | | | | remove outline on buttonsAugust Skare2018-10-301-0/+1 | * | | | | | | | | | | | | button tweaksAugust Skare2018-10-301-8/+15 | * | | | | | | | | | | | | optional copy button in code componentAugust Skare2018-10-302-3/+6 | * | | | | | | | | | | | | change footer copyAugust Skare2018-10-301-2/+1 | * | | | | | | | | | | | | fix link to 0x in headerAugust Skare2018-10-301-1/+1 | * | | | | | | | | | | | | Fixes/august (#12)August Skare2018-10-2918-58/+119 | * | | | | | | | | | | | | Feature/feedbacktweaks (#11)August Skare2018-10-295-24/+33 | * | | | | | | | | | | | | update content in tabsAugust Skare2018-10-264-15/+64 | * | | | | | | | | | | | | fix props drilling to far downAugust Skare2018-10-261-12/+11 | * | | | | | | | | | | | | alernate prop on inlinecode componentAugust Skare2018-10-262-3/+9 | * | | | | | | | | | | | | fix button position in code componentAugust Skare2018-10-261-17/+22 | * | | | | | | | | | | | | fix scrollbars in code componentsAugust Skare2018-10-261-1/+1 | * | | | | | | | | | | | | fixed links in footerAugust Skare2018-10-265-27/+24 | * | | | | | | | | | | | | new hover stylingAugust Skare2018-10-267-3/+11 | * | | | | | | | | | | | | new faviconsAugust Skare2018-10-264-0/+0 | * | | | | | | | | | | | | fix line-height in lead componentAugust Skare2018-10-261-1/+1 | * | | | | | | | | | | | | center logo textAugust Skare2018-10-261-2/+7 | * | | | | | | | | | | | | update codeblock in trace componentAugust Skare2018-10-261-1/+11 | * | | | | | | | | | | | | text color in trace componentAugust Skare2018-10-261-7/+12 | * | | | | | | | | | | | | 14px fontsize on codeAugust Skare2018-10-261-0/+1 | * | | | | | | | | | | | | update text color on dark backgroundAugust Skare2018-10-261-0/+3 | * | | | | | | | | | | | | update content on copiler pageAugust Skare2018-10-261-2/+16 | * | | | | | | | | | | | | fix dom elements type in introAugust Skare2018-10-253-7/+11 | * | | | | | | | | | | | | breakpoint on medium in intro componentAugust Skare2018-10-251-13/+2 | * | | | | | | | | | | | | add json support to highlightAugust Skare2018-10-251-0/+2 | * | | | | | | | | | | | | Updates intro componentMegan Pearson2018-10-251-7/+4 | * | | | | | | | | | | | | Merge remote-tracking branch 'origin/dev-tools-pages' into dev-tools-pagesMegan Pearson2018-10-253-22/+35 | |\ \ \ \ \ \ \ \ \ \ \ \ \ | | * | | | | | | | | | | | | Updates intro component (#10)Megan Pearson2018-10-253-22/+35 | * | | | | | | | | | | | | | Fixed typosMegan Pearson2018-10-252-6/+6 | |/ / / / / / / / / / / / / | * | | | | | | | | | | | | Feature/syntaxhighlighting (#9)August Skare2018-10-257-52/+159 | * | | | | | | | | | | | | Add highlighter.js; basic styling for .diff classes; Start of code block in covMegan Pearson2018-10-254-11/+41 | * | | | | | | | | | | | | Updates Intro Component to use IntroBody and IntroAsideMegan Pearson2018-10-252-19/+37 | * | | | | | | | | | | | | Content (#7)August Skare2018-10-256-65/+231 | * | | | | | | | | | | | | Feature/tweaks (#8)August Skare2018-10-257-22/+53 | * | | | | | | | | | | | | Feature/animations (#6)August Skare2018-10-2510-9/+41 | * | | | | | | | | | | | | Feature/colors (#5)August Skare2018-10-236-7/+7 | * | | | | | | | | | | | | Merge pull request #4 from bakkenbaeck/feature/moreresponsiveMegan Pearson2018-10-235-31/+60 | |\ \ \ \ \ \ \ \ \ \ \ \ \ | | * | | | | | | | | | | | | Update margin-bottomAugust Skare2018-10-231-1/+1 | | * | | | | | | | | | | | | Responsive Compiler Megan Pearson2018-10-231-15/+25 | | * | | | | | | | | | | | | Responsive intro, againMegan Pearson2018-10-231-3/+10 | | * | | | | | | | | | | | | Adds wide prop for full width sectionsMegan Pearson2018-10-232-4/+12 | | * | | | | | | | | | | | | Implements Lead typographyMegan Pearson2018-10-233-9/+13 | |/ / / / / / / / / / / / / | * | | | | | | | | | | | | Merge branch 'feature/variables' into dev-tools-pagesMegan Pearson2018-10-2213-143/+222 | |\ \ \ \ \ \ \ \ \ \ \ \ \ | | * \ \ \ \ \ \ \ \ \ \ \ \ Merge branch 'dev-tools-pages' into feature/variablesMegan Pearson2018-10-228-184/+187 | | |\ \ \ \ \ \ \ \ \ \ \ \ \ | | |/ / / / / / / / / / / / / | |/| | | | | | | | | | | | | | * | | | | | | | | | | | | | Merge branch 'feature/alternate-main' into dev-tools-pagesMegan Pearson2018-10-2219-192/+326 | |\ \ \ \ \ \ \ \ \ \ \ \ \ \ | | * | | | | | | | | | | | | | Remove unused importsMegan Pearson2018-10-221-2/+0 | | * | | | | | | | | | | | | | remove contentBlock from content componentAugust Skare2018-10-226-17/+15 | | * | | | | | | | | | | | | | rename Main to ContentAugust Skare2018-10-225-14/+14 | | * | | | | | | | | | | | | | remove container from all pagesAugust Skare2018-10-224-101/+88 | | * | | | | | | | | | | | | | support dark alternative of Main componentAugust Skare2018-10-223-50/+79 | | * | | | | | | | | | | | | | Remove font size adjustment for small screens from Beta Megan Pearson2018-10-222-3/+4 | | * | | | | | | | | | | | | | Responsive footerMegan Pearson2018-10-221-5/+35 | | * | | | | | | | | | | | | | Responsive font sizes in typography and globalstylesMegan Pearson2018-10-222-0/+11 | | * | | | | | | | | | | | | | Responsive traceMegan Pearson2018-10-221-2/+36 | | * | | | | | | | | | | | | | Responsive headerMegan Pearson2018-10-221-0/+6 | | * | | | | | | | | | | | | | Exports media breakpointsMegan Pearson2018-10-221-8/+27 | | * | | | | | | | | | | | | | Changed name of export to colors and updates componentsMegan Pearson2018-10-228-20/+22 | | * | | | | | | | | | | | | | Implements color variables and updates components Megan Pearson2018-10-228-10/+29 | |/ / / / / / / / / / / / / / | * | | | | | | | | | | | | | Feature/build step (#2)August Skare2018-10-1923-169/+665 | | * | | | | | | | | | | | | Responsive IntroMegan Pearson2018-10-221-13/+22 | | * | | | | | | | | | | | | Add light prop to codeMegan Pearson2018-10-221-1/+1 | | * | | | | | | | | | | | | Responsive listMegan Pearson2018-10-221-0/+6 | | * | | | | | | | | | | | | breakout container for small screensAugust Skare2018-10-223-50/+62 | | * | | | | | | | | | | | | ligt theme on codeAugust Skare2018-10-222-4/+6 | | * | | | | | | | | | | | | dont shrink icons in trace componentAugust Skare2018-10-221-4/+8 | | * | | | | | | | | | | | | button styling on small screensAugust Skare2018-10-221-0/+7 | | * | | | | | | | | | | | | code fontsize on small screensAugust Skare2018-10-222-68/+70 | | * | | | | | | | | | | | | hero spacing adjustment on small screenAugust Skare2018-10-221-0/+12 | | * | | | | | | | | | | | | spacing adjustments on contentblock and main componentsAugust Skare2018-10-222-1/+25 | | * | | | | | | | | | | | | remove padding on Trace component on small breakpointAugust Skare2018-10-221-1/+5 | | * | | | | | | | | | | | | spacing adjustment in footerAugust Skare2018-10-221-1/+6 | | * | | | | | | | | | | | | don't shrink icons in footerAugust Skare2018-10-221-1/+1 | | * | | | | | | | | | | | | keep fonts folder in gitAugust Skare2018-10-222-1/+2 | | * | | | | | | | | | | | | Feature/build step (#2)August Skare2018-10-1923-169/+665 | | * | | | | | | | | | | | | Merge branch 'feature/responsive' into feature/variablesMegan Pearson2018-10-195-7/+89 | | |\ \ \ \ \ \ \ \ \ \ \ \ \ | | | * | | | | | | | | | | | | Remove font size adjustment for small screens from Beta Megan Pearson2018-10-192-3/+4 | | | * | | | | | | | | | | | | Responsive footerMegan Pearson2018-10-191-5/+35 | | | * | | | | | | | | | | | | Responsive font sizes in typography and globalstylesMegan Pearson2018-10-192-0/+11 | | | * | | | | | | | | | | | | Responsive traceMegan Pearson2018-10-191-2/+36 | | | * | | | | | | | | | | | | Responsive headerMegan Pearson2018-10-191-0/+6 | | |/ / / / / / / / / / / / / | | * | | | | | | | | | | | | Exports media breakpointsMegan Pearson2018-10-191-8/+27 | | * | | | | | | | | | | | | Changed name of export to colors and updates componentsMegan Pearson2018-10-198-20/+22 | | * | | | | | | | | | | | | Implements color variables and updates components Megan Pearson2018-10-198-10/+29 | |/ / / / / / / / / / / / / | * | | | | | | | | | | | | added trace component to trace viewAugust Skare2018-10-187-1/+161 | * | | | | | | | | | | | | tweaking header and hero position and sizingAugust Skare2018-10-182-8/+19 | * | | | | | | | | | | | | compiler component in compiler viewAugust Skare2018-10-182-0/+78 | * | | | | | | | | | | | | intro component on cov viewAugust Skare2018-10-181-0/+8 | * | | | | | | | | | | | | intro component in profiler viewAugust Skare2018-10-182-0/+55 | * | | | | | | | | | | | | initial commitAugust Skare2018-10-1855-1019/+1222 | * | | | | | | | | | | | | update react and styled-componentsAugust Skare2018-10-152-5/+2511 * | | | | | | | | | | | | | Python contract demo, with lots of refactoring (#1485)F. Eugene Aumson2019-01-09136-178/+8274 | |_|_|_|_|_|/ / / / / / / |/| | | | | | | | | | | | * | | | | | | | | | | | | Publish@0x/website@0.0.64@0x/web3-wrapper@3.2.2@0x/utils@2.1.1@0x/types@1.5.0@0x/testnet-faucets@1.0.61@0x/subproviders@2.1.9@0x/sra-spec@1.0.14@0x/sol-resolver@1.2.1@0x/sol-doc@1.0.12@0x/sol-cov@2.1.17@0x/sol-compiler@2.0.0@0x/react-shared@1.1.0@0x/react-docs@1.0.23@0x/pipeline@1.0.3@0x/order-watcher@2.4.0@0x/order-utils@3.1.0@0x/monorepo-scripts@1.0.16@0x/migrations@2.3.0@0x/metacoin@0.0.33@0x/json-schemas@2.1.5@0x/instant@1.0.5@0x/fill-scenarios@1.1.0@0x/dev-utils@1.0.22@0x/dev-tools-pages@0.0.11@0x/contracts-utils@1.0.3@0x/contracts-tokens@1.0.3@0x/contracts-test-utils@1.0.3@0x/contracts-protocol@2.2.0@0x/contracts-multisig@1.0.3@0x/contracts-libs@1.0.3@0x/contracts-interfaces@1.0.3@0x/contracts-extensions@1.2.0@0x/contracts-examples@1.0.3@0x/contract-wrappers@4.2.0@0x/contract-artifacts@1.2.0@0x/contract-addresses@2.1.0@0x/connect@3.0.11@0x/base-contract@3.0.11@0x/asset-buyer@3.0.5@0x/assert@1.0.21@0x/abi-gen@1.0.20@0x/abi-gen-wrappers@2.1.00x.js@3.0.0Fabio Berger2019-01-0943-333/+333 * | | | | | | | | | | | | Updated CHANGELOGSFabio Berger2019-01-0974-19/+384 * | | | | | | | | | | | | Merge pull request #1496 from 0xProject/feature/solc-5.0Leonid Logvinov2019-01-0911-42/+76 |\ \ \ \ \ \ \ \ \ \ \ \ \ | |_|_|_|_|_|/ / / / / / / |/| | | | | | | | | | | | | * | | | | | | | | | | | Add CHENGELOG entrieLeonid Logvinov2019-01-091-0/+4 | * | | | | | | | | | | | Update sol-compiler binPaths to include the newest solidityLeonid Logvinov2019-01-092-34/+71 | * | | | | | | | | | | | Update solc used by sol-compilerLeonid Logvinov2019-01-091-1/+1 | * | | | | | | | | | | | Remove contracts dependency on solcLeonid Logvinov2019-01-097-7/+0 * | | | | | | | | | | | | Merge pull request #1494 from 0xProject/feature/order-watcher/dockerizeFabio B2019-01-095-16/+86 |\ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | rename methodFabio Berger2019-01-091-4/+4 | * | | | | | | | | | | | | Remove stray consoleFabio Berger2019-01-091-1/+0 | * | | | | | | | | | | | | Add assertions to catch trying to add undefined schemasFabio Berger2019-01-091-0/+9 | * | | | | | | | | | | | | Fixx request payload and expected responsesFabio Berger2019-01-081-6/+8 | * | | | | | | | | | | | | Fixx OrderWatcher WS tests so they are completely independent from one anotherFabio Berger2019-01-081-10/+12 | * | | | | | | | | | | | | Merge branch 'development' into feature/order-watcher/dockerizeFabio Berger2019-01-08550-4852/+13209 | |\| | | | | | | | | | | | | * | | | | | | | | | | | | Create server entry point and Dockerfile for OrderWatcherFabio Berger2019-01-083-0/+58 * | | | | | | | | | | | | | Merge pull request #1439 from 0xProject/migrations/docker-imageJacob Evans2019-01-098-12/+109 |\ \ \ \ \ \ \ \ \ \ \ \ \ \ | * | | | | | | | | | | | | | chore(python-packages): Change docker command in setup.pyJacob Evans2019-01-021-7/+1 | * | | | | | | | | | | | | | Python ganache snapshot 2.2.2Jacob Evans2018-12-291-3/+1 | * | | | | | | | | | | | | | Readme, read snapshot name from package.jsonJacob Evans2018-12-273-2/+52 | * | | | | | | | | | | | | | Dockerfile defaults to latestJacob Evans2018-12-241-1/+1 | * | | | | | | | | | | | | | Copy latest published version to 0x_ganache_snapshot-latest.zipJacob Evans2018-12-241-1/+1 | * | | | | | | | | | | | | | Use new bucket, bind on 0.0.0.0Jacob Evans2018-12-24