aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2014-09-04 22:24:25 +0800
committerale <ale@FreeBSD.org>2014-09-04 22:24:25 +0800
commit4537a4881b0b6d73e3ae464f01f8c34a0f0f6981 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /databases
parentbd99065cd762559478878408c8a5e4cadb54faa1 (diff)
downloadfreebsd-ports-gnome-4537a4881b0b6d73e3ae464f01f8c34a0f0f6981.tar.gz
freebsd-ports-gnome-4537a4881b0b6d73e3ae464f01f8c34a0f0f6981.tar.zst
freebsd-ports-gnome-4537a4881b0b6d73e3ae464f01f8c34a0f0f6981.zip
Import PHP 5.6 branch!
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile16
-rw-r--r--databases/php56-dba/Makefile10
-rw-r--r--databases/php56-dba/files/patch-config.m450
-rw-r--r--databases/php56-interbase/Makefile10
-rw-r--r--databases/php56-mssql/Makefile10
-rw-r--r--databases/php56-mysql/Makefile10
-rw-r--r--databases/php56-mysqli/Makefile10
-rw-r--r--databases/php56-mysqli/files/patch-php_mysqli_structs.h10
-rw-r--r--databases/php56-odbc/Makefile10
-rw-r--r--databases/php56-odbc/files/patch-config.m4124
-rw-r--r--databases/php56-pdo/Makefile10
-rw-r--r--databases/php56-pdo_dblib/Makefile10
-rw-r--r--databases/php56-pdo_firebird/Makefile10
-rw-r--r--databases/php56-pdo_mysql/Makefile10
-rw-r--r--databases/php56-pdo_odbc/Makefile10
-rw-r--r--databases/php56-pdo_pgsql/Makefile10
-rw-r--r--databases/php56-pdo_sqlite/Makefile11
-rw-r--r--databases/php56-pgsql/Makefile10
-rw-r--r--databases/php56-pgsql/files/patch-pgsql.c11
-rw-r--r--databases/php56-sqlite3/Makefile11
-rw-r--r--databases/php56-sybase_ct/Makefile10
21 files changed, 373 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 272a2e8f2116..4395e1167c95 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -614,6 +614,22 @@
SUBDIR += php55-redis
SUBDIR += php55-sqlite3
SUBDIR += php55-sybase_ct
+ SUBDIR += php56-dba
+ SUBDIR += php56-interbase
+ SUBDIR += php56-mssql
+ SUBDIR += php56-mysql
+ SUBDIR += php56-mysqli
+ SUBDIR += php56-odbc
+ SUBDIR += php56-pdo
+ SUBDIR += php56-pdo_dblib
+ SUBDIR += php56-pdo_firebird
+ SUBDIR += php56-pdo_mysql
+ SUBDIR += php56-pdo_odbc
+ SUBDIR += php56-pdo_pgsql
+ SUBDIR += php56-pdo_sqlite
+ SUBDIR += php56-pgsql
+ SUBDIR += php56-sqlite3
+ SUBDIR += php56-sybase_ct
SUBDIR += phpminiadmin
SUBDIR += phpmyadmin
SUBDIR += phppgadmin
diff --git a/databases/php56-dba/Makefile b/databases/php56-dba/Makefile
new file mode 100644
index 000000000000..ec617c162add
--- /dev/null
+++ b/databases/php56-dba/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -dba
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-dba/files/patch-config.m4 b/databases/php56-dba/files/patch-config.m4
new file mode 100644
index 000000000000..1df828460e05
--- /dev/null
+++ b/databases/php56-dba/files/patch-config.m4
@@ -0,0 +1,50 @@
+--- config.m4.orig 2012-11-21 06:12:20.000000000 +0100
++++ config.m4 2012-12-12 10:18:42.000000000 +0100
+@@ -320,6 +320,38 @@
+ THIS_PREFIX=$i
+ THIS_INCLUDE=$i/db4/db.h
+ break
++ elif test -f "$i/include/db5/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db5/db.h
++ break
++ elif test -f "$i/include/db48/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db48/db.h
++ break
++ elif test -f "$i/include/db47/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db47/db.h
++ break
++ elif test -f "$i/include/db46/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db46/db.h
++ break
++ elif test -f "$i/include/db44/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db44/db.h
++ break
++ elif test -f "$i/include/db43/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db43/db.h
++ break
++ elif test -f "$i/include/db42/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db42/db.h
++ break
++ elif test -f "$i/include/db41/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db41/db.h
++ break
+ elif test -f "$i/include/db5.1/db.h"; then
+ THIS_PREFIX=$i
+ THIS_INCLUDE=$i/include/db5.1/db.h
+@@ -362,7 +394,7 @@
+ break
+ fi
+ done
+- PHP_DBA_DB_CHECK(4, db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
++ PHP_DBA_DB_CHECK(4, db-5 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
+ fi
+ PHP_DBA_STD_RESULT(db4,Berkeley DB4)
+
diff --git a/databases/php56-interbase/Makefile b/databases/php56-interbase/Makefile
new file mode 100644
index 000000000000..894e1d5df5a0
--- /dev/null
+++ b/databases/php56-interbase/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -interbase
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-mssql/Makefile b/databases/php56-mssql/Makefile
new file mode 100644
index 000000000000..0e4995975e41
--- /dev/null
+++ b/databases/php56-mssql/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -mssql
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-mysql/Makefile b/databases/php56-mysql/Makefile
new file mode 100644
index 000000000000..a32da0666e1b
--- /dev/null
+++ b/databases/php56-mysql/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -mysql
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-mysqli/Makefile b/databases/php56-mysqli/Makefile
new file mode 100644
index 000000000000..8dd62aca30da
--- /dev/null
+++ b/databases/php56-mysqli/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -mysqli
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-mysqli/files/patch-php_mysqli_structs.h b/databases/php56-mysqli/files/patch-php_mysqli_structs.h
new file mode 100644
index 000000000000..d0daeee9ee54
--- /dev/null
+++ b/databases/php56-mysqli/files/patch-php_mysqli_structs.h
@@ -0,0 +1,10 @@
+--- php_mysqli_structs.h.orig 2010-07-26 15:52:54.000000000 +0200
++++ php_mysqli_structs.h 2010-07-26 15:53:14.000000000 +0200
+@@ -54,6 +54,7 @@
+ #define WE_HAD_MBSTATE_T
+ #endif
+
++#define HAVE_ULONG 1
+ #include <my_global.h>
+
+ #if !defined(HAVE_MBRLEN) && defined(WE_HAD_MBRLEN)
diff --git a/databases/php56-odbc/Makefile b/databases/php56-odbc/Makefile
new file mode 100644
index 000000000000..df644ab87af6
--- /dev/null
+++ b/databases/php56-odbc/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -odbc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-odbc/files/patch-config.m4 b/databases/php56-odbc/files/patch-config.m4
new file mode 100644
index 000000000000..d8e2798d4c36
--- /dev/null
+++ b/databases/php56-odbc/files/patch-config.m4
@@ -0,0 +1,124 @@
+--- config.m4.orig 2014-08-27 13:31:35.000000000 +0000
++++ config.m4 2014-09-04 12:44:43.855274203 +0000
+@@ -99,9 +99,12 @@
+ dnl
+ dnl configure options
+ dnl
++PHP_ARG_ENABLE(odbc,,
++[ --enable-odbc Enable ODBC support with selected driver])
++
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(adabas,,
+-[ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
++[ --with-adabas[=DIR] Include Adabas D support [/usr/local]], no, no)
+
+ if test "$PHP_ADABAS" != "no"; then
+ AC_MSG_CHECKING([for Adabas support])
+@@ -128,7 +131,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(sapdb,,
+-[ --with-sapdb[=DIR] Include SAP DB support [/usr/local]])
++[ --with-sapdb[=DIR] Include SAP DB support [/usr/local]], no, no)
+
+ if test "$PHP_SAPDB" != "no"; then
+ AC_MSG_CHECKING([for SAP DB support])
+@@ -146,7 +149,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(solid,,
+-[ --with-solid[=DIR] Include Solid support [/usr/local/solid]])
++[ --with-solid[=DIR] Include Solid support [/usr/local/solid]], no, no)
+
+ if test "$PHP_SOLID" != "no"; then
+ AC_MSG_CHECKING(for Solid support)
+@@ -171,7 +174,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(ibm-db2,,
+-[ --with-ibm-db2[=DIR] Include IBM DB2 support [/home/db2inst1/sqllib]])
++[ --with-ibm-db2[=DIR] Include IBM DB2 support [/home/db2inst1/sqllib]], no, no)
+
+ if test "$PHP_IBM_DB2" != "no"; then
+ AC_MSG_CHECKING(for IBM DB2 support)
+@@ -208,7 +211,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(ODBCRouter,,
+-[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support [/usr]])
++[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support [/usr]], no, no)
+
+ if test "$PHP_ODBCROUTER" != "no"; then
+ AC_MSG_CHECKING(for ODBCRouter.com support)
+@@ -229,7 +232,7 @@
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(empress,,
+ [ --with-empress[=DIR] Include Empress support [\$EMPRESSPATH]
+- (Empress Version >= 8.60 required)])
++ (Empress Version >= 8.60 required)], no, no)
+
+ if test "$PHP_EMPRESS" != "no"; then
+ AC_MSG_CHECKING(for Empress support)
+@@ -253,7 +256,7 @@
+ PHP_ARG_WITH(empress-bcs,,
+ [ --with-empress-bcs[=DIR]
+ Include Empress Local Access support [\$EMPRESSPATH]
+- (Empress Version >= 8.60 required)])
++ (Empress Version >= 8.60 required)], no, no)
+
+ if test "$PHP_EMPRESS_BCS" != "no"; then
+ AC_MSG_CHECKING(for Empress local access support)
+@@ -291,7 +294,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(birdstep,,
+-[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]])
++[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]], no, no)
+
+ if test "$PHP_BIRDSTEP" != "no"; then
+ AC_MSG_CHECKING(for Birdstep support)
+@@ -345,7 +348,7 @@
+ running this configure script:
+ CPPFLAGS=\"-DODBC_QNX -DSQLANY_BUG\"
+ LDFLAGS=-lunix
+- CUSTOM_ODBC_LIBS=\"-ldblib -lodbc\"])
++ CUSTOM_ODBC_LIBS=\"-ldblib -lodbc\"], no, no)
+
+ if test "$PHP_CUSTOM_ODBC" != "no"; then
+ AC_MSG_CHECKING(for a custom ODBC support)
+@@ -365,7 +368,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(iodbc,,
+-[ --with-iodbc[=DIR] Include iODBC support])
++[ --with-iodbc[=DIR] Include iODBC support], no, no)
+
+ if test "$PHP_IODBC" != "no"; then
+ AC_MSG_CHECKING(for iODBC support)
+@@ -401,7 +404,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(esoob,,
+-[ --with-esoob[=DIR] Include Easysoft OOB support [/usr/local/easysoft/oob/client]])
++[ --with-esoob[=DIR] Include Easysoft OOB support [/usr/local/easysoft/oob/client]], no, no)
+
+ if test "$PHP_ESOOB" != "no"; then
+ AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
+@@ -421,7 +424,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(unixODBC,,
+-[ --with-unixODBC[=DIR] Include unixODBC support [/usr/local]])
++[ --with-unixODBC[=DIR] Include unixODBC support [/usr/local]], no, no)
+
+ if test "$PHP_UNIXODBC" != "no"; then
+ AC_MSG_CHECKING(for unixODBC support)
+@@ -442,7 +445,7 @@
+
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH(dbmaker,,
+-[ --with-dbmaker[=DIR] Include DBMaker support])
++[ --with-dbmaker[=DIR] Include DBMaker support], no, no)
+
+ if test "$PHP_DBMAKER" != "no"; then
+ AC_MSG_CHECKING(for DBMaker support)
diff --git a/databases/php56-pdo/Makefile b/databases/php56-pdo/Makefile
new file mode 100644
index 000000000000..744b440c3b41
--- /dev/null
+++ b/databases/php56-pdo/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pdo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pdo_dblib/Makefile b/databases/php56-pdo_dblib/Makefile
new file mode 100644
index 000000000000..7d65bb8797f9
--- /dev/null
+++ b/databases/php56-pdo_dblib/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pdo_dblib
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pdo_firebird/Makefile b/databases/php56-pdo_firebird/Makefile
new file mode 100644
index 000000000000..d9d727bc9043
--- /dev/null
+++ b/databases/php56-pdo_firebird/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pdo_firebird
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pdo_mysql/Makefile b/databases/php56-pdo_mysql/Makefile
new file mode 100644
index 000000000000..5e61107e7511
--- /dev/null
+++ b/databases/php56-pdo_mysql/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pdo_mysql
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pdo_odbc/Makefile b/databases/php56-pdo_odbc/Makefile
new file mode 100644
index 000000000000..f88191238e5f
--- /dev/null
+++ b/databases/php56-pdo_odbc/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pdo_odbc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pdo_pgsql/Makefile b/databases/php56-pdo_pgsql/Makefile
new file mode 100644
index 000000000000..e8c263a154ba
--- /dev/null
+++ b/databases/php56-pdo_pgsql/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pdo_pgsql
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pdo_sqlite/Makefile b/databases/php56-pdo_sqlite/Makefile
new file mode 100644
index 000000000000..cf6f3cc9e4c8
--- /dev/null
+++ b/databases/php56-pdo_sqlite/Makefile
@@ -0,0 +1,11 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+PORTREVISION= 1
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pdo_sqlite
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pgsql/Makefile b/databases/php56-pgsql/Makefile
new file mode 100644
index 000000000000..3664f9d0e982
--- /dev/null
+++ b/databases/php56-pgsql/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -pgsql
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-pgsql/files/patch-pgsql.c b/databases/php56-pgsql/files/patch-pgsql.c
new file mode 100644
index 000000000000..667bb89ded7c
--- /dev/null
+++ b/databases/php56-pgsql/files/patch-pgsql.c
@@ -0,0 +1,11 @@
+--- pgsql.c.orig 2010-01-03 10:23:27.000000000 +0100
++++ pgsql.c 2010-03-08 11:00:26.000000000 +0100
+@@ -728,7 +731,7 @@
+ static int le_link, le_plink, le_result, le_lofp, le_string;
+
+ /* {{{ _php_pgsql_trim_message */
+-static char * _php_pgsql_trim_message(const char *message, int *len)
++static char * _php_pgsql_trim_message(const char *message, size_t *len)
+ {
+ register int i = strlen(message)-1;
+
diff --git a/databases/php56-sqlite3/Makefile b/databases/php56-sqlite3/Makefile
new file mode 100644
index 000000000000..00b59a490f0d
--- /dev/null
+++ b/databases/php56-sqlite3/Makefile
@@ -0,0 +1,11 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+PORTREVISION= 1
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -sqlite3
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php56-sybase_ct/Makefile b/databases/php56-sybase_ct/Makefile
new file mode 100644
index 000000000000..1a3071676011
--- /dev/null
+++ b/databases/php56-sybase_ct/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -sybase_ct
+
+.include "${MASTERDIR}/Makefile"